Mounting a new Fw PCB on FW 1884

Ben K

New Member
Feb 17, 2018
Gear owned
Tascam Fw-1884
Hi. My FW-1884 no longer syncs with my PC. It seems after looking into it for a while that the fw pcb may have simply died. I have found a company in Germany who stills sells the part (PCB ASSy, MAIN FW part no E95162800B°... a few questions, has anyone ever replaced this part and found it "useful" ? Iq it difficult to mount ? Does anyone know what the problem may be when both the firewire light and the Stop button blink on/off ? thanks for the help.

PS: I've had my FW for years now (serial number 0120012), have always had a few sync issues but nothing too bad. It has always been hooked to the same PC running XP SP2. Just in case i changed the FW card on the PC and changed the cable... but still have lights blinking on/off
If you are looking for the TASCAM U9 PDI1394P23B FIREWIRE CHIP, I have them.
Replacing the U9 chip is NOT a project for the "amateur".
Wish I could say definitely that the blinking "stop and firewire" leds indicates a
damaged U9 chip. I have never been able to find a FW1884 shop manual.
Here's the link to my website:
Thanks for the answer Tom.
I'm no good at soldering hence why I was looking for the full PCB... it seems easier to replace than just the U 9 component. In regards to the manual I managed to find the service manual with all of the block diagrams and exploded views... if that's what your after.
I'll be ordering the board this week and hopefully replacing it within the FW 1884 won't be too much of a hassle.
Thanks tom.
I have just passed the order. I should receive the PCB in the next few weeks hopefully.
The company I ordered from is :
The cost of the PCB exc. tax and delivery is 186.00 Euros.
It's a bit expensive but in the end much less than buying new gear.
I'll post again once I have the PCB and made the switch in the FW 1884.
With my Tascams FW-1884 & FW-1082, I've had an occasional issue with not connecting to the PC, or more so that the firewire light wasn't coming on.
I've discovered something new just recently. That if I open the Soft_LCD display applet FIRST (the one that came with the driver I downloaded from the Tascam site version 1.8) , then my Tascams firewire light comes on every time now.

I used to power up the Tascam 1st, then the PC and the firewire LED would come on. But hasn't been lately.

NOW, I power up PC 1st, open the Soft_LCD display, THEN power on Tascam & VIOLA, firewire light comes on. I had been wondering if my firewire connection somewhere was going bad, but if the Soft_LCD make/forces the LED to come on, it's GOT to be a more of a software thing.
Finally !! after weeks of not having any time to change the FW card... I can finally say it is done and.... WORKING !!! like a charm, even better than when I first bought the unit. Syncs up without pre heating, no cuts, everything is just f****g brilliant !
It was definitely worth the cost and it is easy as to change the FW board inside the FW 1884.
  • Like
Reactions: PereR
Could you please post the file you sent to the PCB service, in case one of us needs the same sometimes ?
the site is also in English but I had first sent an email to their contact with my request and spare part number. There is no direct link to the part on their site. All in all at the time they still carried the part and delivery was fast. Easy to install in the FW 1884 and no more problems.
  • Like
Reactions: PereR
Thanks - downloaded and taking a look. I think my old FW1884 has finally given up and gone into all lights on firewire light blinking 3 x then 5. I haven't inserted any firewire connector upside down though - but I was testing it on Windows 11 with a fairly cheap PCI-E 1x card. I may also have foolishly used a 1.80 FW1804 driver on it too 😁 its back on windows 10 old pc now with the adaptec pci T1 4300 but I can't get rid of all lights on...unsuprisingly.

I've ordered a new 2024 style 24 track modular DAW controller anyway BUT it niggles me to send the FW1884 to the dump.

I'm told here that all lights on is fried U9 chip but I would love to get hold of the service manual with the error codes. Or is it worth trying a reinstall of the last firmware update maybe version (1.83).

I had the FW for nearly 20 years - it has always been a tempremental beast. Its an old single client asio set up also - so a bit museum now. But still does a few things that even now modern tackle does not.

I had thoughts to just use it as a mackie style control surface but those went out the window last thursday 😁😁

Any thoughts more than gratefully received from any other preservers of old music tech. Best wishes.
I have a Tascam FW-1884, a FW-1082 & FW-1804, my FW-1804 is far less problematic, actually 'never has any' of the many issues as the others!

Anyway, I've had the all lights blinking a number of times on my Tascam FW-1884. 1st time, thinking is might be 'fried' but then a HARD RESET (or FACTORY INITIALIZE) did the trick & solved that issue ... each time. so try that first, before sending off to Tascam heaven. If you have tried that, try some more.

"Hold down SHIFT, CONTROL, and F8 at the same time when the FW1884 is already turned on (you do NOT need to turn it off and power it up while holding buttons)."

Many many thanks for this - not had chance to check it out yet. Never tried the reset keypress during a power up so who knows. Certainly sure I never put the firewire plug in the wrong way round - its difficult to do anyway without forcing it. Still it's an ancient old unit now - but I have quite a collection of older kit that I don't use much but still have sentimental attachment to.
OK the FW1884 has moved on a lttle from all lights flashing after trying a few power ups with cntrl+shift+F8 key press it now switches on with stop button light contnuously illuminated and master faser having shot up to max

I'm regarding this as a slight inprovement but if anyone has any suggestions about how to move it on from this state that would be great. I'm leaving it in for a while now because of all the advice on this site about keeping it warmed up

Wondered about trying one of the firmware updaters on it - maybe the 1.83 one. But I seem to remember reading we were only ever supposed to do this once - and I'm pretty sure i did apply it years ago.

Many thanks

New threads

Members online

No members online now.