Any leads on where to find DM Firmware beta release notes/info?

mixerizer

Soundaholic
Joined
Dec 25, 2021
Messages
349
Karma
179
Gear owned
DM-4800, -24, X-48, r250n
Hi folks.

I’m running really well on the DM-4800 1.70 firmware, but I have a copy of the 1.72b4 firmware as well and I was wondering if anyone had any info on the changes made in the interim. Would love to know before I go ahead and risk my stability in pursuit of features.

I know we have some very TASCAM savvy folks on the forum, and perhaps a few with experience or info about the dev process behind the firmware betas, would be very grateful if so!

thanks all and enjoy.
 
I should have stuff like that somewhere on my NAS, I'll check it later when I get to the studio.
 
  • Like
Reactions: mixerizer
Many thanks!
 
You ain’t wrong :) can one downgrade the firmware?
 
@mixerizer I have never been brave enough to attempt it to be honest with you.
 
  • Like
Reactions: mixerizer
Relatable :) they don’t call it a beta version for nothin.

If there are any forum folks using the beta, any issues?
 
  • Like
Reactions: Peter Batah
I'm on 1.72b3 firmware without issue - for a long time now. I never tried the b4 one cause I don't have any further info on it..
 
Hi @Juzz I do have a copy but I'm abroad now for work so can't get to it. I should be back early December so I'll try to remember and get back to you in this thread, or give me a shout-out by that time. Let me repeat though: I haven't used b4 so no guarantees..
 
Hi @Juzz, I was just revisiting this thread to send you the file, but I now see you have a DM4800 and the 1.72b4 firnware I have is for the 3200. So that wouldn't be much use for you I'm afraid (if it would anyway, since we don't know what the changes/ improvements were)...
 
@Arjan P Thank you very much for sharing, Any chance you can also share with me .Kext File
I am having trouble getting my DM 3200 to work on big sur. I have tryed all the previus recommendation for replacing the file and fixing the permissions on terminal and I still get a Driver offline error. I am using the IF-FWDM_MKII_188754_Installer.dmg version.
 
No sorry, I have no Apple products or any knowledge of the software issues on them.
 
Arjan, looks like that Wetransfer link expired. What are the odds of getting an updated one?
I am having no luck getting the firmware update installed from the Tascam site. Figured I would try any other one I can find.
My 3200 is 1.21 :(

Thanks
 
Yeah, the WeTransfers last only one week. I don't know whether my package has a different driver than the Tascam site, but I put it up again here: https://we.tl/t-3ZacXKpt2g
There's a read me file in the zip with some info about versions.
 
@Arjan P That is the 1.72b package.
Thanks for your help.
I still can't get the Tascam to respond. "protocol timed out" but have not exhausted all options on my side. Once I figure it out, I will document it for others.
Cheers
 

New threads

Members online

No members online now.