DM-24 IF-FW/DM under Windows 8.1 64 bit

Discussion in 'TASCAM DM-24' started by grecner, Oct 27, 2014.

  1. grecner

    grecner New Member

    Joined:
    Oct 2014
    Messages:
    6
    Likes:
    1
    Gear:
    DM-24 with IF-FW/DM
    Hi all,

    it has been a long time since my last post to the old Tascam forums, but here I am again. ;-)

    Yesterday I needed to do some recording from my DM-24 to my notebook,
    which in the meantime runs 64 bit version of Windows 8.1.
    I was reading about people successfully running 64 bit v1.10 drivers in Windows 7,
    but I have found no remarks on Windows 8. So I gave it a try.

    It turned out that the biggest problem is that TASCAM drivers are not digitally signed,
    and Windows 8 is really nasty about that fact, but luckilly it can be forced to ignore it.
    I will make the long story short, this is what needs to be done:

    1. Configure windows to run in "Test" mode. Test mode is used by developers to test drivers and does not require them to be signed. Without this test mode Windows 8.1 will not load the drivers even if you would install them and will display error code 52 (driver not signed) in the driver properties status in device manager.

    This is how to enable the Test mode:

    a. Open a command prompt window with elevated administrator priviledges (right-click the Windows symbol in the lower left corner of the desktop and select "Command Prompt (Admin)" from the list.

    b. Run the following two commands in the Comand Prompt window (paste the following two commands one by one to the Command Prompt window by right-clicking into the window and selecting "Paste", and press Enter after each paste.

    bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS
    bcdedit -set TESTSIGNING ON

    2. Reboot Windows 8.1 with driver signature checking disabled. This will allow you to install the Tascam DM-24 drivers. This is a link to the process for this special reboot:

    https://learn.sparkfun.com/tutorial...abling-signed-driver-enforcement-on-windows-8

    Note: In step 9. where it says you should type number 7 on your keyboard, I actually had to press F7 key instead.

    3. Check if Windows is running in test mode. "Test mode" should be displayed in the lower right corner of the desktop.

    4. Unzip the drivers and install them (right click setup.exe and select "Run as Administrator")

    5. If you have done the reboot in step 2. correctly, divers will install (with couple warning that the driver is not digitally signed to which you need to respond with "Install anyway"). If that special reboot was not done correctly, the installer will just pop an error and stop.

    6. Before the instalation is finished, the installer will pop up a window saying you should connect your DM-24 to the firewire port on your PC and switch it on. Do it.

    7. If you have correctly configured your WIndows 8.1 to run in test mode in step 1., the installer will continue with installation and finish (it took quite some time to finish on my laptop, so do not give up too soon). If you have not done the step 1. correctly, installer will pop up error messages about digital signature missing.

    8. Verify that the drivers are installed and working correctly by opening the Device Manager (right-click the windows icon in the lower left corner of the desktop and select "Device Manager" from the list) and checking the status of the Tascam driver. On my notebook the driver was displayed in a separate category (named by some strange string of numbers which I do not remember). Under that category name you should find a nice descriptive name of the if-fw/dm driver. Double-click it to open its properties and check the device status in the General tab. It should read "This device is working properly." If it shows a long text about digital signature missing with error code 52, your WIndows is most probably not running in test mode, see steps 1. and 3.

    9. Before starting the IF-FW/DM control panel you should make a standard reboot (not the special reboot from step 2.)

    10. After the reboot, check that the drivers are running again (see step 8.)

    11. Start IF-FW/DM Control Panel application (it gets installed to the Windows 8.1 "Apps" screen under TASCAM category) and check whether the panel shows the IF/FW-DM card and its serial number.

    12. Check the streaming state. If it is showing "error", try increasing all the buffer depth sliders a bit and then disconnect and reconnect the firewire cable. It should synchronize and show correct streaming state and sampling frequency.

    OK, so this is how to install the drivers.

    Limitations so far:

    1. The drawback is that you must always run Windows in the Test mode to use the drivers, which is a bit silly and maybe also potentially dangerous in case some mallware decides to install itself as a driver.

    2. I was unable to "Enable WDM across all chanels". I only see 8 channels (1-8) in Windows multimedia. This could be a problem for a multitrack software which does not support ASIO drivers.

    3. I have no real multitrack application installed on my notebook to check whether the ASIO drivers are working as well. Maybe I will go through this later, but for now I was only using Windows multimedia features to record. Please try ASIO for yoursefl.

    4. If you want to switch off the Windows Test mode, you need to use the following commands in the Command Prompt window and reboot:

    bcdedit -set loadoptions ENABLE_INTEGRITY_CHECKS
    bcdedit -set TESTSIGNING OFF

    ###EDIT1###
    I have tried to find some 64-bit application to test the ASIO drivers.
    I have found a free software called wavosaur, which has ASIO support and is 64-bit.
    But it does not see any ASIO drivers on my laptop.
    So I am affraid that the TASCAM drivers are only partially working, WDM only, and only 8 channels.
    Which means that this setup can not be used for any serious multitrack recording work. :-(
    ##########

    ###EDIT2###
    Well, at last, I got ASIO drivers working, and that for all 24 channels!
    What have I done ? Nothing, just a second thought.

    I assumed the problem is that the ASIO drivers are only 32-bit, even though the WDM driver is 64-bit. This was supported by the fact that there is only IFFWDM_asio.dll, and no IFFWDM_asio_x64.dll in the driver package.

    So I have tried a 32-bit version of wavosaur, and it suddenly did recognize my ASIO drivers. It has crashed, however, when I selected them. But I did not give up there. ;-)

    I have then instaled Audacity with ASIO support (I believe Audacity is 32-bit application as well), and viola, it works just fine with ASIO, and it seems that it works with all 24 tracks (I have tried track number 9).

    So, the resume is, you can use DM-24 under Windows 8.1 64-bit, but you have to use an application that uses 32-bit ASIO drivers. I guess Cakewalk or Sonar 32-bit versions would work well.
    ##########
    Martin
    Last edited: Oct 27, 2014
    Arjan P likes this.
  2. Fred Temps

    Fred Temps New Member

    Joined:
    Oct 2016
    Messages:
    4
    Likes:
    0
    Gear:
    Tascam Dm3200
    Hey dude I'm gona test that caus I'm using windows10 64 now and I couldn't set My DM3200 with the IFFWDMK1 ... Thanks for your post :)
  3. Arjan P

    Arjan P Veteran

    Joined:
    Oct 2012
    Messages:
    1,528
    Likes:
    977
    From:
    Netherlands
    Gear:
    DM3200 IFFW
    Nice work!