FW-1884 W7 x64: Instant BSOD when turning On and Off.


New Member
Sep 7, 2013
Gear owned
Hi guys,

I recently came into possession of a Tascam FW-1884 control surface.
I'm really liking the workflow and build of the unit a lot!
Now here's the thing...

I noticed that when i am using my PC (no programs running at all) and turn the FW-1884 on, off and directly on again this will always result in a BSOD on my system.

I was wondering if this was a known issue and/or something could be done about this?

I am using the latest firmware + driver for the unit.

Thanks in advance.
I don't mean to be flip, but stop doing that?

If I cycle the power without waiting several seconds, the FW-1884 itself freezes with all lights on. I have never seen it lock up the computer, though.

Anyway, welcome to the forum here. Since you just bought yours, you may not know the one most agreed-upon fact with the FW-1884, and that is to use a firewire card with a Texas Instrument (TI) chipset. What is your firewire source?

Another observation you will read has to do with the driver. In Windows 7, we found it works best to use what is called the Legacy firewire driver. What OS are you using?

And here's one more thing: units below a certain serial number lack protection against blowing out a channel when you plug in a mic with the phantom power on.
Hello there,

Thanks for your reply. Well, the BSOD usually hints me as a form of instability (be it driver, or hardware), which is what actually worries me. I have no problem to 'stop doing it'...

My OS is: Windows 7 Ultimate x64 SP1.
Are these so called 'legacy' drivers still available on the tascam site?
That makes more sense. Your first post sounded like you were causing the BSOD by cycling the power, and I wondered why you would do that.

The legacy firewire driver is part of Windows, not something from Tascam. I have forgotten the precise steps, but you go through Device Manager to update the driver and choose the legacy 1394 driver.

One thing you might try is to change Windows to not automatically reboot upon a crash. Then download a free black screen utility that will show the cause of a BSOD and pinpoint the driver at fault. Make sure it is the Tascam.
NessPJ, I just wanted to reassure you that Tom Deering (Deering Amps) who just posted is the authoritative source for these issues and has a terrific repository of info. Follow his advice.

There are still some facts you could share that may help us further to help you. Let us know your serial number and what firewire card or interface you are using (you should see info in the same drivers area mentioned in Tom's instructions). Good luck!
Wow, that's nice, Tom. Thank you.
Hey guys,
Thanks a lot for your help and replies.

The serial number of my unit is: 0130417


I was actually planning to upgrade to Haswell before the end of the year. I guess i will be on the lookout for a new Gigabyte motherboard that contains a TI chip.
I'm actually on a not so old (not low-end) MSI Z77A-GD80 board right now and i'm very much amazed they are using crappy VIA chipsets...
I had a recent machine that had a built-in VIA chipset, by SONY I think. It actually worked OK with the Tascam. However, I used a PCI board from Adaptec anyway.

I recently looked at new motherboards and concluded I would not easily be able to find one with a firewire port, and would have to buy a PCIe firewire card. I found one with a TI chipset for $20 or so at NewEgg. Let us know what you decide to get; I may even follow in your footsteps.

That serial number, I think, has the mod. I'll try to find the cutoff number.
Thanks a lot for all the information guys. :)

PS. Take a look at that motherboard i linked, if you are planning to upgrade to Intel Haswell and want a TI firewire chip onboard. :)
It happens with mine, but only if you switch it off straight away. I close down Cubase and give it 5 mins and then switch off the computer. Sometime though it still BSOD but not often...
A BSOD (or the White Freeze in Windows 7) is the result of some driver hanging on. Evidently it finally releases in your case after a few minutes. See if you can figure out which device is doing this by trial and error. Perhaps Process Explorer will show you what devices are still connected after you exit Cubase.
Yes, that's it. It's a bear to read, but the info should be there to help you solve this.
Nice one. I've d'l'd it and tried in on my home computer and it looks good, will do my DAW next. Cheers :)

New threads

Members online

No members online now.