HELP! 2488 Neo acting up...

Syrinx Sound

New Member
Oct 25, 2012
Gear owned
2488 Neo
Hoping someone can help with this one, because Tascam's customer support response was, of course, do a factory reset and/or send it off for repair...

My 2488 Neo has worked like a charm for years, but I am now having two issues. 1) When I try to name a new song, number symbols do not come up as an option as i scroll thru the characters. This has just started happening. 2) In my last session, I had recorded for quite some time, all seemed to be working fine. I stopped the recording, and the unit paused as it wrote to the HD. Then I tried to move to a previous location which I could and play from there. When I pressed play, the green LED on the play button flashed, but the counter did not move and nothing would play. The machine was acting "frozen," but I could move to different locations using stored "marks" or the transport buttons. Pressing STOP made the LED stop flashing, so I decided to just shut down (the "Bill Gates" solution) hoping it would save my work and regain composure. When I tried to shut down, I got the message that I could not do that with the transport running--even though all appeared stopped. Ultimately had to do a hard shutdown and lost my work. The unit appears to be ok now, but I don't want to be well into another session and lose it all.

Anyone else seen any of these issues? THANKS!
You could try a Resetting your 2488 to factory settings

"With the machine off, hold down [Quick Routing, Shift, Send, Shut down] all at the
same time....... and power up. This is supposed to reset everything to original
settings - INCLUDING THE HARDDRIVE (reformat). It remains to be seen how this
will reset the firmware."

From Don Robertsons 2488 guide.

Regards Peter
Thanks, Peter. That was also suggested by TASCAM customer support. I was hoping to avoid having to back up all the work that's on there. In a more general sense, I wonder what the 2488 is trying to tell me with a flashing green LED on the transport. It is not mentioned anywhere in the manual, FAQs, etc.
The flashing play led I only know if the midi synchronisation is set to slave. (menu midi).

Regards Peter
sorry for my bad english :-(
I will check that--I don't use Midi sync, but it may have gotten set by accident... Thanks a lot, and your English is fine!
My 2488 is brand new out of the box, haven't recorded one full song yet and it freezes up at random, one tech said re-init, which I've done 3times and no go, another tech said its hardware related and will have to be sent in at my expense.....I'll never buy another Ta-Scam product again....
Schuyler6 said:
My 2488 is brand new out of the box, haven't recorded one full song yet and it freezes up at random
Warranty repair?

Schuyler6 said:
I'll never buy another Ta-Scam product again....
Oh! How original! Did you really invent the phrase "I'll never buy another XXX product again" just by yourself?

PS. For your information: this site is not connected to TACSCAM company in any way. It's a place where individual TASCAM users are making their best effort on helping each other. So ... your rants against TASCAM are not going to help you.
I'm not ranting,,,cool your engines,,,,I've got plenty of Tascam equipment and thoroughly enjoy it !!! Just making a snide comment......Geez,,,,I'm getting the unit repaired and will move on, it seems to be a nice unit ,,when it works.
I finally got the unit running after re-init the proper way,,,,,,sorry for the previous post Jarno......I get aggregated easily and do not express things the right way sometimes....thanks for your help !!
Guess I spoke too soon, it worked fine for a couple of recordings but now it's back to freezing up again,,,,obvious hard drive problem and stated by second Tascam tech....never got to completely record a whole song yet with this recorder. Off to change the drive.
Guys, this is all very enlightening, but you kind of hijacked my post--it was about a specific issue regarding the transport.... Probably should have started your own thread, ya know?
Sorry for stepping on your post,,,I just thought your issue was similar to mine....a lot of uptightness around ...
Fair enough--no hard feelings, and thanks for the reply. I have been real happy with the 2488, and my transport issue has only manifested itself once, right in the middle of a huge session, so yeah--I'm edgy about getting it resolved without having to wipe my formatting. My notifications are set to shoot me an email when there's any activity on the post, so hopefully you can understand why I would have preferred posts that aren't helping me figure out a solution show up in their own thread. Good luck getting your issues resolved, too.
Have you thought about swapping over the HD? Or even just checking that the conections are all sitting as they should. I had an issue with my old 788 where it just started to freeze, had to keep pulling the plug each time I tried to fix it as it wouldnt shut down properly - it was suggested I try a new HD, swapped a new HD into it and whoosh - went perfectly. Put the old HD back in a while later and again - whoosh, no worries.

Worth a thought - Zeek
Thanks--yeah, I figure if it manifests itself again I'll have to at least reformat the drive, but since my post it has been operating fine. The only thing I can think is that the drive was nearly full--we were recording a live practice, 8 tracks hot for over an hour--when the "freeze" occurred. Since then I have kept it at below 90% full, and (cross my fingers) have not had it happen again.

My original hope was that I would post the symptoms and someone would point out some dumb thing I was doing wrong--but to no avail! TEAC's documentation is pretty decent, but I couldn't find any references to the flashing green "play" LED.

I'll probably bite the bullet soon and backup the real keepers that are on there--good practice anyway--and clean up the drive... but thanks again for the post.

New posts

New threads

Members online