Help with FW-1884, please!

midge F

New Member
Dec 31, 2013
Gear owned
I'm running Win 7 (64 bit) ...have TI compatible PCI firewire card and just can't seem to get the device to work - the furthest I've got is some stuttering sound (both from samples and vst's in Ableton 8 and 9) ... *Also* after following the great Deering Amps install instructions to the letter, my PC doesn't recognise my FW-1884 as an audio device. This is after several installs/ re-installs of driver v.1.80.

On my laptop with a similar configuration, using a 6 to 4 pin firewire cable, it's recognised as an audio device in Win 7 (32 bit) but doesn't play back mp3's and no sound at all in Ableton 9.

I only experimented with my laptop to see if the device is recognised...I really want it working with my desktop PC... In both cases, I'm not getting a blinking firewire light on the FW-1884 so I'm assuming there's nothing wrong with the unit's firewire ports and more a problem with my configuration(s). I'm not an expert, but am reasonably PC savvy and have googled this and followed installation instructions religiously. I've heard this unit can be a b**** to set up but great when it works. If anyone can help I'd be very, very grateful as, I'm sure you can imagine have spent upwards of 30 hours trying to get it working. I can provide further info if necessary.

Thanks, Midge

p.s. I'm pretty damn sure I've set up the FW-1884 in Ableton correctly (Mackie control surface, MIDI ins/outs etc...but am most perplexed why Win 7 doesn't recognise it as an audio device in the system tray, yet does in device manager. :cry:
"TI Compatible" ?
Did you run the OCHI utility to verify that the chipset is TI?

Shoot me an email and I'll try to make some time to walk you through the install.

Thanks... yeah, I've used the OHCI tool, and my PCI firewire card is, indeed compatible!
Does it say:
Looking for OHCI 1394 Host Controllers...
Vendor: Texas Instruments
IF it doesn't say TI and just reports
Support: Compatible
You may have an issue there.
IF you have more than one 1394 controller (for instance the MB has a built in controller) disable any that are not TI brand chipsets.
BTW, both my rigs are running on Gigabyte Mother Boards with "built-in" TI controllers.
Post a screen shot of the test utility.
Seems ok to me:


  • ohci screen.jpg
    ohci screen.jpg
    286 KB · Views: 27
Motherboard is : gigabyte ga-ma78lmt-us2h ...and has no built-in firewire

Ok.. to perform this OHCI test and send a screenshot I had to re-insert the TI chipset PCI card ... this slot is currently occupied by a Via USB and Firewire Hub I use for a couple of USB controller keyboards etc with my current, trusty old interface (Edirol DA-2496) etc..

I'm just wondering if it's possible that, when swapping over the cards, there might be some driver issues with the TI Firewire card....probably clutching at straws... I'm almost ready to put the FW-1884 on ebay... torn enough hair out and a shame I didn't get to play with this thing, unless someone can wave a magic wand!
Open "Device Manger" click the IEEE 1394 OHCI Compliant Host Controller
Right click the 1394 OHCI Compliant Host Controller (Legacy)
Click "Scan for hardware changes"
I would then re-boot and go through the "Legacy" driver install again.
In "Task Manager", "Processes", do you see "fw1884Panel.exe" listed?
You say that the FW led is not "blinking", is it "on" or "off"?
Hold "Alt" when you take the screen shot and you'll just get the app that's in "focus", is that the right term?

Ok (deep breath)...thanks again for your help...I did as suggested with the firewire card, scanned for hardware changes, rebooted a few times etc

1) Performed install of 1.80 drivers while device not connected, rebooted etc etc
2) Yes, the fw1884Panel.exe process is listed in task manager processes. And the control panel works correctly, device shows as connected.
3) The fw-1884 is not recognised as an audio device in the system tray (no audio devices are installed) although it's recognised in device manager twice.
4) I'm also using the ASIO4ALL drivers, that, when Ableton boots shows a red exclamation mark in the system tray
5) Tried the FW-1884 in ableton with it's own drivers and the ASIO4ALL in Ableton and although the device is recognised and selected in Audio, there is no sound.
6) Firewire light on the fw-1884 is on (not blinking)

As previously stated, I got my laptop to recognised the device in the system tray as an audio device but no sound in Ableton and couldn't play back mp3's etc.

I have a feeling, in order to get this thing working on my main PC, it would need to be recognised as a windows audio device...which it never has. I've tried the FW-1884 also as a standalone device with guitars and a mic and all seems to be fine - just can't get it to talk with my PC. Nearest I've got is some intermittent sound in Ableton and, if I recall correctly, this may have been when the internal soundcard was enabled (weirdly enough) and also when I'd accidently not uninstalled the drivers to my Edirol DA-2496.
So you are connected (maybe I missed that earlier in the thread).
Get the 1884 running, verify that the FW led is "on", and the 1884 "Control Panel" opens, set to 44.1 and verify that "in sync" shows under Sample Rate in the 1884 panel.

I know this is basic, but lets go step by step.
In "Device Manager" "Sound" the FW is listed twice?

If you "right click" select "properties" the driver is version 1.8 for both entries?
With me so far?
Now open Windows "Control Panel" "Sound".
There should be the 4 analog pairs and 4 adat pairs listed.

How we doing so far?
Set Windows playback to use the the 1884 and play a wav or mp3 in Media Player.
If that works we should be able to get everything going.
IMPORTANT: Re-assign Windows sound to your internal device BEFORE you open Abelton.
ALSO: I think ASIO4ALL has to go, but I don't know how to disable it.
Only 1 ASIO device will work at a time, so you can't have the Edirol selected in Abelton.
I have the 1884 (just for control) and an RME UFX (audio) on my Studio rig.
Both can be connected, just not both unit's audio "active" in Sonar at the same time.
Some Sonar users disable on-board sound, I've never had a problem, and that way Windows is "happy" it has a sound device.
Maybe this would be eaisier on the phone?
Let me know.
tom at deeringamps
Hi, and thanks again!

Not at home at the moment but everything is as it should be in your screenshots (I'll send a smaller one of mine next time) *but* in control panel/sound.. 'no audio devices are installed' .... when the FW-1884 is connected, the 1.80 drivers install automatically, the device shows in device manager, is present in ableton but *not* as a sound device in Windows 7. It's as if the drivers are only doing half a job, if that makes sense.. Like I said before, *if* Windows recognises it as a sound device (which it doesn't on my PC) My Edirol DA-2496 does and I can use it as a normal soundcard (i.e. playing back videos, MP3's etc) .. I must have tried connecting the FW-1884 50 to 60 times and it has never been recognised as a device in the control panel..

For the record, the Edirol doesn't support Win 7 drivers so I've used M-Audio delta 1010 drivers (cards have same/similar architecture) and all works ok until I try to record analogue signals (mic/guitars etc) and after a period get distorted sound...another weird issue and one for another forum..

I bought the FW-1884 to be able to have more analogue ins and to use as a control surface...why the hell isn't my pc recognising it as an audio device but device manager does?!
The forum software seems to be cutting off part of my images.
This is the lower right hand corner of the FW's Control Panel.

What does your unit list under "Unit Versions"?
Also, what is your serial number?
I'm thinking you have a driver conflict with ASIO4ALL or the delta driver.
Have you tried a "1884 clean un-install"; its a pain, and the pdf on my site was written
for XP.
But maybe if you un-install all the audio devices/drivers; its a lot of work.
I understand how frustrated you are, but you've evidently been running "workarounds" to get audio working.
That may be the root cause of your problems.

From memory (and as I don't want to swap various cards over again) I'm almost certain the unit versions match yours, I thought about updating the firmware and read about the various perils doing that and pretty much concluded it was the latest anyway.

Serial number is: 0010506

To add, I've tried various installs without the ASIO4ALL drivers and have generally removed the Edirol's Delta drivers through control panel with the same results.
Clean install of Windows, then the 1884.
That's how I did both of my Win 7 rigs (and my previous XP rig as well).
Total PITA, but if you want to quit troubleshooting and make music...
I love my 1884's, and knew I had a working unit when I moved to Win 7.
If I was having crazy problems today, and rolling back to an earlier image didn't solve it, I would not hesitate to do a clean Windows install; again total PITA.
I would try to clean up the registry on the current install first.
Sounds like that's the only thing you haven't done.
So... not exactly plug and play then?

You're probably right... so many old driver files and stuff all over the place in the registry that'd be the logical conclusion...I don't know if I have the stomach for a clean install and all that sails in her... and who knows, maybe it might not work after all that chipping away?..

I thank you, though, for all your sage advice!
"I don't know if I have the stomach for a clean install and all that sails in her... and who knows, maybe it might not work after all that chipping away?"
That's why I said that "I" would not hesitate!
It sounds like your unit is "OK", but I can't guarantee that.
From the serial # its a fairly early unit (made before any of the Service Bulletins).
But that shouldn't matter.
Maybe you try some other interface and everything is "fine".
You can email me any time you need help.

I'm gutted really, I half-expected a bit of a troublesome install but nothing like this. Shame I didn't buy the FW-1884 to coincide with a clean install but it's honestly not something I can contemplate right now even if it means the thing might finally work. I might give it a final try before selling... with previous attempts, I removed the M-Audio delta drivers through control panel - could you recommend a prog' or utility that would remove all traces of these from Windows/Registry? Or would I have to do a manual search? Thanks again.

New posts

New threads

Members online

No members online now.