iMac OSX 10.9 doesn't detect US144


New Member
Mar 18, 2013
Gear owned
US-144 DR-05
I just dove into the Apple world with an iMac (OSX 10.9). I plugged my trusty Tascam US144 in and expected to see the OS prompt for installation. Nothing. So I manually downloaded a driver from Tascam. After trying a few, the only one that seemed to install OK was version 1.13. The US144 GUI control panel also installed OK. However the device is never detected. The control panel tells me so and it never shows up in Reaper. I have rebooted many times, both with the device plugged in and without it plugged in.

Any help appreciated.
Anyone? I emailed Tascam and they have not responded, been about a week now. Looks like a new interface. Probably have to try a brand where tech support answers your emails.
Thanks, I tried to get tech support, almost 2 weeks and no response.
The Mavericks beta drivers were released on the 12th, so if you contacted support 2 weeks ago, you'd have just have been one of thousands of people asking the same thing.

Note the US-144mkII is on the list, but not the US-144
Thanks. I used the US144 Mk II driver and the control panel now works and I can use my electric guitar with Garageband. The interface seems to work when I use my guitar.

However I cannot get it to work with MIDI. I connected my Yamaha PSR-140 keyboard to the US 144 with MIDI cables. I installed a program called "MIDI Monitor" to see what was being transmitted to the computer. It shows no signals getting through.

However under "MIDI Sources" within OSX's "Audio MIDI setup" utility, the PSR0140 is shown, just as it was setup in "Audio MIDI Setup". When I use Garageband and create a piano track, the keyboard doesn't do anything.

I borrowed a UM ONE Mk II MIDI to USB converter and that worked. The keyboard is sending MIDI signals. However why it won't work via my interface and MIDI cables has me beat

In the Apple utility "Audio MIDI Setup" I connected the keyboard to the US 144.

I am at a loss as to why my iMac is not receiving MIDI signals from my keyboard.
I just tried it on a Windows laptop. It all works.
Having a lot of problems in OSX. Will have to look at buying a new interface. It won't be a Tascam. Lack of product support about to cost me a couple of hundred dollars +.
  • Like
Reactions: tokoshiro5
Same here. The MKii crashs all the time (with the last driver).
I've been told by Tascam distributor that Tascam has dropped support for the US144. So it's now a paperweight. Goodbye forever Tascam. How hard could it be to create a driver considering they created one for the similar US144 mkII?
  • Like
Reactions: tokoshiro5
the US144 MKII driver doesn't work too! LOL :( (I'm using a windows 7 computer with my mkii because the Mavericks driver sucks ;( )

New threads

Members online

No members online now.