Init Flag never went to 0, VERY BAD Abandoning PlugIn Instantiation


New Member
Nov 24, 2014
Gear owned
Tascam DM 3200
I have a DM 3200 with two ADAT cards and the meter bridge. I have used it purely for passing audio.
Around a year ago one day it began giving this error message every time it powers up:
Init Flag never went to 0, VERY BAD!!! Abandoning PlugIn Instantiation!!!

However the message goes away and it has continued to pass audio without any problem that I am aware of.

Does anyone know what this message means? Is there anything that is actually NOT working on the board? I don't even use any built in processing so I have no idea.

A Tascam tech on the phone walked me through holding Shift 1L and 2R while booting to get to diagnostics and do the whole factor reset options shortly after the error message starting showing up. But resetting it to factory settings didn't clear this message either and I was told it would have to go into TEAC/Tascam to be repaired.

But that was sometime last year and I have continued to use it JUST to pass audio to the speakers for this entire time with no problems (that I am aware of.)

After a little bit of internet research, I opened the unit today and tried replacing the 3 Volt battery -- but that didn't clear the error message. I found a little reset button on (what I assume is) the motherboard. I pressed and held it -- that didn't clear the message either. The only fuse I can see is right where the 3 prong power cable comes in, and that sure is fine or else it wouldn't even power up -- can't find any other fuses.

I updated the firmware to the latest 1.70 -- it updated successfully -- but error message still there every time I boot up.

I'm told it's $100 to evaluate it and $100 per hour plus parts to fix it. But without taking it in first, I have no idea what the damage could be.

I'm looking to sell this and I doubt anyone wants to buy it when it boots with an error message.

Can anyone who has actual experience with this exact model and this exact error message please share experiences/advice with me? Even if that means a story about how you took it in and it cost $200 to replace and the name of the part that was bad would be helpful.

Thanks for reading and I appreciate any possible help!
If you're only using the board to 'pass audio,' and it's functioned correctly in that role for more than a year, I'm at a loss to understand your issue. Apparently, you don't require much more from the unit than being a monitoring solution, so this error flag hasn't interfered with your workflow - yet.

I've never experienced that message, but the mention of 'Plug-In' is very suspicious. It might have something to do with the internal efx. You might want to conduct some tests using internal efx, apply some routing maneuvers to see if they work, and tracking something to discover if other problems occur.

Thanks for the reply. I wrote a lot so you probably missed me saying I'm looking to sell it.
I doubt it has much value if any with that error message.
Thanks for the replies. I wish there was something like a chip I could re-seat but I didn't see anything reseatable other than cables.
I really just wish I knew how much it would truly cost to get it fixed!
If anyone has experienced this exact message with this model, please share your story.
The error occurs when the CPU talks to the Effects DSP chip and doesn't get a reply, so it abandons trying to start the effect. If you see it every time you change the effects algorithm, there's a board/chip problem.
I would suggest doing preventative maintenance of opening up the front, compressed air all over the main board, especially the DSP chips in the top left.

  • Like
Reactions: Fiber
I've opened up the front and seen that, besides cables, there unfortunately aren't any chips or components I can reseat, but I haven't blown any compressed air on the board or even located the DSP chips.
Couldn't hurt. I'll give this a shot. Thanks.
Also, I did start playing around just with loading some of the effects presets and the first time I loaded a new one/algorithm, I did in fact get that same error message that I normally see on bootup. However all subsequent loads of new effects/presets no longer give that error -- but it's still there every time I boot up.
Thanks for the reply. I'll post again if I have any success with the compressed air.
Blew compressed air all over he place - board(s), chips, you name it. Reseated even more misc connectors everywhere.
No dice. Still get the error message.
And yes, I am seeing the error message when hitting Load on many randomly chosen Effects in the Effects Library.
No clue yet if that means those effects don't work. They sure seem to load on the screen.
Will have to read the manual on how to route signal to those effects and plug in a sound source to determine.
This model has two ADAT cards and the meter bridge. And is in truly excellent physical condition.
I really don't want to pay to get a new motherboard. It DOES pass audio. Error message is the only issue.
I wonder what it's worth like this. Anyone know?
My guess would be that the financial loss of trying to sell it on ebay as broken would be worse then then the loss of having it fixed, or at least having a new MB sent to you and you putting it in. And, if a new MB fixes the issue, it will go for a premium on ebay if you do decide to sell it, hopefully making up the difference of having to buy a new MB.
I just checked with the parts department. Main boards for the DM-3200 are $800.52, and we have them in stock.


New threads

Members online

No members online now.