Old Portastudio07 - no power to mixer circuit

Discussion in 'TASCAM DIY Repairs and Mods' started by Dan25A, Jun 10, 2020.

  1. Dan25A

    Dan25A New Member

    Joined:
    Jun 2020
    Messages:
    1
    Likes:
    0
    Gear:
    Portastudio 07
    I dug out my old Portastudio 7 to use as a mixer, but found that the power LED didn't come on and there was no sound from the headphones. The tape controls were working but I don't have any tapes to check whether there was any sound from the tape deck. I took the back off and one of the bigger caps on the bottom board (C609) had clearly gone. I replaced that but it's just the same as before - there's power to the tape drive but it doesn't look like it's getting anywhere else. The connectors all look OK. I don't think the unit will have been used with the wrong power adaptor. I have the original, which is putting out 20V into a multimeter.

    Is there a usual suspect I should check out next, or would it be a case of checking absolutely everything?

    Thanks
  2. SkywaveTDR

    SkywaveTDR Well-Known Member

    Joined:
    Feb 2014
    Messages:
    1,068
    Likes:
    222
    From:
    Chicago area
    Gear:
    Teac, Tascam, Sony
    I keep on hearing that this and that looks OK. How do you know are you an expert? Besides that most parts show no signs of failure when they go bad. That is why Technicians that fix these don't care what the parts look like as they take voltage measurements. After all these years anything can be a problem in there- if you just leave it sit for 20 years and then expect it to work 100% later on how do you figure this? The item was a made for profit plastic device so there are likely to be plenty of cheap parts in the deck that do not last long with just sitting and never being used. The voltage it uses is on the service manual and Owners manual. If you plugged in just any old thing I don't know what will happen- I guess you need to go in and find out what part went bad- there are no easy answers all the time.
    -mjk- likes this.
  3. SkywaveTDR

    SkywaveTDR Well-Known Member

    Joined:
    Feb 2014
    Messages:
    1,068
    Likes:
    222
    From:
    Chicago area
    Gear:
    Teac, Tascam, Sony
    If you have a service manual the task of checking the regulator out and the power to Op Amps goes pretty fast. Then you deal with what you find out.