Rewind button not working


New Member
Feb 13, 2013
Gear owned
a) Good to be back

b) Rewind button on my Neo stopped working a while back. Not a big deal, but I'm more worried what I'll do if the same thing happens to the other transport buttons. Any way to fix?
I am still using an original 2488 and had that problem in the past. My way of fixing it was to get a can of "Contact Spray" from Radio Shack (sometimes refereed to as "tuner spray".) I use a small jewelers screwdriver and lift the lift the plastic button up just enough to get the little straw that comes with the spray can under the button. I spray underneath rather liberally then let it dry out for a day or two (not really sure if that is necessary but I didn't want to take chances). It has worked for me on two of the switches (start and rewind) and I have not had to do again for several years now. It's just an idea that worked for me. I was desperate. I couldn't use my 2488 because my start button didn't work until I did this.
I can only say try at your own risk.

New threads

Members online

No members online now.