SX-1 fader problem


New Member
Sep 4, 2013
Hasselt - Belgium
Gear owned

I'm new here and I've got a problem with my sx-1.
Since I installed an other vga-monitor yesterday the faders don't work anymore.
I changed to the old set-up but still the faders don't react.
Everything else seems to work fine but not the automatic faders. I can change all parameters by mouse on the vga screen, but the faders remain dead.
At start-up when the faders are calibrated the lcd-screen says that the faders are not
responding. When I change the fader-banks everything acts like it should (solo/mute/
pan) except the faders.
I like my sx-1 a lot and I hope it's not fatal....
Anyone out there who could help?
try booting up with the CD and run the diagnostics maybe you'll be able to see what the problem is...
Hello Wolf,

Thanks for the reply.
I was so desperate I opened up the sx-1 and took it half apart. After putting it back
together it worked again perfectly. Me happy ! Next day the problem seemed to have re-appeared... But after several tries it started up correctly. So it must be a question of a bad contact here or there. Glad it's only a minor problem and nothing serious.
Probably a good cleaning will solve it.

try re-seating all the cards OR changing the battery...I had similar issues over the time, a new battery fixed it...another time, re-seating the cards fixed it...and another time, re-booting from the CD was the answer...and yet another time, I needed to attach "ferrite cores" to the power cord to eliminate RFI/EMI interference...and still another time, one of the fans needed replacing...and several other times, it was something else that I can't recall. but I know that the one unit was continuously giving me problems...
I was ALWAYS able to get my SX's up and running EXCEPT this time!!!
Thanks for the tips.
When I opened up the sx-1 I took out the cards and put them back. And indeed it started up correctly from the first time. But, as I mentioned, the next morning the fader problem re-occured and only after several tries it started up ok. From then on it acts normal again, but everytime I start it up I'm a bit afraid it will let me down.
I purchased my sx-1 about a year ago, after working about 20 years with Roland vs 880 and 1680. Never had an issue with them. I changed to the sx-1 because of the Roland's displays which had become too tiny for my old eyes and now I have a 24inch monitor and no longer need my glasses. Cool!
Oh well, in the end I still can use the sx-1 without the faders.
And I still have my Rolands too....

For sure boot with the cd and do a fader diagnostic. It sounds like a loose card but could also be a loose cable. If you've checked all those, perhaps reloading the OS may help. Make sure you have the latest disk for your specific machine ver. 1.52 I think it was. Also make sure you have backed up everything first as it will wipe the HD during installation.
Hi Greg,

Thanks for the reply.
The problem probably was a bad contact, because after removing and cleaning the
fader-board, the faders react normal. Except for the 'touch-function' of the faders
which doesn't call up the corresponding channel anymore.
Pity, but I can live with that. Perhaps reboothing from the cd will restore that, but as I'm
in the middle of a project I prefer to not change anything for the moment, I'll try later on.
That's good to hear. These machines are often salvageable with just the smallest effort. It's just getting parts that's becoming an issue.
Hi Greg,

Thanks for the reply.
I do like my SX-1 despite of its moods and its limitations, which makes it challenging to work with.
Pity though that Tascam didn't come up with the upgrades they promised.....
hey Greg...were you able to look at the RAM yet? I just want to know what the brand and model# you used...I bought the right size RAM cards, but they don't work in either SX...
I had a bit of a scare tonight. My SX-1 failed several times to boot correctly and would not perform the fader calibration process. The only thing different was a set of Chinese-made WIFI cameras I picked up. One of them had been sharing power with the console. After many attempts to get things up and running, I unplugged the camera, the SX-1 and then plugged it back in. I'm up and running again. I cant explain this one but I'm not complaining either!
Two things can happen that cause all kinds of crazy problems that seem different but are all related.
Ram failing. I do believe this machine is hard on ram but of course this type of ram is all old stock now too.
The other very common issue is fan failure or over heating. I had a fan failing intermittently so it was hard to diagnose. But the result was a host of issues until finally my CPU burned out. It took about 3 months of ghost in the machine stuff. With the most common problem trouble booting. 2nd most common issue was freezing during recording. I figured it out and replaced the fan (and CPU) with no issues since.

New posts

New threads

Members online

No members online now.