Sysex flood from console to DAW

Gravity Jim

Sep 28, 2012
I have been recording in Logic Pro for a few months now without incident. MacPro 8-core, OSX 10.7.5, Logic Pro 9.1.7, Tascam DM3200 with the latest firmware etc.

As recently as last night I was recording MIDI data as I always have, using the Tascam as a transport control for Logic. This morning, having been running the beta version of TMCompanion 1.7 for almost a year, and seeing that the finished version was on Tascam's website, I decided to go ahead and put the real, final version of TMC 1.7 on my machine. THIS WAS THE ONLY CHANGE made since last night.

But now, this morning, when recording MIDI tracks in Logic, I am getting a torrential stream of SysEx data on the tracks. Logic's event list shows that the data is coming from the Tascam... and reports Ch 78, Num 127, Val 33. (i haven't looked up what these numbers mean in Logic's manual yet).

I can easily filter out Sysex data from the Tascam, either in Logic itself or at the MIDI Time Piece, but I'm a root-cause kinda guy, and would love to figure out what the hell happened. I reverted to the beta version of TMC via Time Machine, and threw away TMC's prefs files, but this didn't fix it. I also opened a new sequence in Digital Performer 7.24, and got exactly the same behavior... torrents of sysex, two or three events to a single MIDI click, without touching a MIDI input device.

Any ideas out there?
Hey Jim,

This is a real head scratcher. :)

My first guess would have to do with some routing anamoly in the DM. Perhaps when you jumped up to the new TMC1.7, a midi portal 'opened up' allowing unwanted Sysex to flow through. This might explain why reverting to earlier apps and experiencing the same issue in DP has occured.

If it were me (and it isn't:)), I'd look carefully at all the MIDI settings in your DM, and if needs be, re-loading the ones you've previously chosen. Maybe that'll clean things up. I hope so.

Keep us posted. This is very interesting (if also a pain in the a**) :)

Well, if I just restore all the saved projects through TMCompanion, will the MIDI setting be restored? (Or maybe just the project I was working on?) Or do I have to go through them again virtual cable and switch? Talk about a head scratcher...
You'd think so - assuming there isn't a resident snapshot messing things up.
Can't hurt to give it a try (saving your work as required.)

If that fails for some reason, it might be necessary to 'force load' the settings by re-toggling your DM Midi settings - ie: - USB/Firewire, etc. I'm grasping at straws here, but it's an interesting problem worth getting to the bottom of.

EDIT: I wonder if unplugging/replugging your MIDI cables (USB?) might make the plug and play 'play right.' (More straw grasping.) :?:

Cap't, I thought the same thing about unplugging the cable... I intend to try that in the morning, letting the DM establish fresh contact with the computer.

I'll do all this when I get two days worth of VO recording out the door... Thanks for the replies.
Capt, I ran some diagnosis this AM, and restoring my backups fixed the problem. Don't know what the heck the deal was... I have noticed that one or two random sysex events have always leaked through when using the transport controls on the DM, right at the beginning of the record pass... and when I filter the sysex out, either at the mixer, through the interface or in Logic, the transport still works fine without it. So I guess I'll just leave the console filters on. I've never used sysex data to control my synths, so I don't really need it, but I hate shutting it off for the whole system just to make one piece happy! :D

I'll try re-installing Tascam's official version of TMC 1.7 sometime soon and see if the same thing happens or if I caused the problem in some other way.
Gotta luv those backups. :)

Glad you got it fixed, but it would be nice to know exactly what caused the 'flood.'
I'm inclined to think there's something 'delicate' going on with USB/MIDI and the way the DM passes it. Maybe all it takes is a snapshot anomoly or application upgrade to open the flood gate.

Whatever - it's a new one on me.

I'm glad the site is back! Glad to see the old names again!!!

Let us know what happens when you downgrade to the previous TMC app version.
cmaffia, I did, and even pitched the plists associated with it, but the problem persisted until I restored my project backups. It's okay now, but I'm still curious. I'm going to install the "official" version of 1.7 again soon to see if it happens again.
cmaffia said:
I'm glad the site is back! Glad to see the old names again!!!

Hey Charlie - good to 'see' you back. But - uh - I sorta miss your old avatar with you sticking your tongue out at us. :LOL:

Which reminds me, I've got to find a new avatar for myself. :shock:

Just found this forum (again) today!!

Really happy to see the same names floating around!!!
Glad the site is back!!!
Hey all, we're back! ;)

I have had a few weird anomalies as well from time to time, and not just on the DM4800, a lot of digital consoles. I have found the PRAM where the active progam is living in Digital consoles tends to get corrupted from time to time, and this can cause all kinds of weirdness. Sometimes, like on some Calrec digital consoles this will have a cascading effect, the errors in the PRAM becoming worse and worse every time you do a save.
The solutions can vary from wiping corrupted presets and reloading an uncorrupted preset, to reprogramming a patch from scratch, to reloading firmware all over again.
I suspect one way to screw up the PRAM on the DM4800 is to patch multiple input sources using input bypass to the same output destination. Sometimes I think trying to do so screws things up, and since it's a big patchbay and you can't see where everything is patched at a glance it's easy to do.
So I have a preset with everything going nowhere I call "Zero." That was I can always build a desk from scratch if I run into any weirdness.
BTW, sometimes I get strange things from certain effects patches too. Some of them don't work right, I think.
Just an update:

This morning I finally had a chance to try a fresh install of TMC 1.7. This time, no sysex flood occured.

So, Bog And All His Holy Angels know what the hell happened last time, but it didn't happen this time. Data flow is normal.
A sysex flood usually means two things:

1. The Tascam has lost midi connection and is trying to ping the DAW for Mackie Controll host to reply. Solution: check connections in the Mackie midi I/O.

2. The Tascam is using MTC and the host is running a different samplerate meaning the connection is lost. Now it tries to catch up...

I'm not a tech.... But this is what I have experienced.
The MIDI connection was fine, as the controls were still working normally. And either DAW I use will warn me if I'm running a different sample rate in the DAW than on the hardware. So... I'm still baffled.

But, it stopped when I reloaded my backups, and didn't come back when I re-installed 1.7, so... SOMETHING wacky happened, but it didn't came back. :cool:
Digital consoles cannot handle dips in the net power. This can surprise many. There are power UPS'es who register the current coming in and deliver clean current to the console. But offcourse this can become costly fast...

If you are living in an area wich has large factories nearby or maybe even a big mall. Whenever they power up or down something big the net takes a dip... Leaving you and the digital console with e certain zero's wich might have been ones... And thus stalling the mixer.... It is a dumb thing afterall..
Good point, it is costly but very effective.
I installed a Monster Power AVS2000 Voltage Regulator, I just had a feeling that my gear was not getting enough juice. After installing it and seeing that at some times the AVS was delivering an additional 6+ volts that was not present in the incoming power line. Until then I never knew what clean, constant power could do for your sound, your computer, your screens, yeah, even screen resolution improved.
If the gear ain't getting the power it needs it will always under perform.
Finny you should mention that. Power is mostly very clean here, but I do have the Tascam plugged into a Pure Sine Wave UPS, which does show when power dips below 120V and makes up the difference from battery power.

So, I don't think that was it either. It had something to do with installing the real, official version of TMC 1.7 instead of the beta I had been running for the last year.

Anyway, it's all good now.
I have used digital consoles almost exclusively in situations with clean, isolated audio power and still had occasional weirdness. The active memory (PRAM) gets corrupted by certain software bugs I think. Rebooting and reloading is the first line of defense, of course. Then try reloading a different preset.
DC in your audio can also really screw up a digital console, so it is good to check your files and make sure you are not recording DC crap that is getting induced from somewhere. At ABC we had DC in a digital sat feed that passed the console and recorded just fine on the analog recorders, but all the digital recorders had a big blank space where the feed should have been. DC in your input signal is a very wacky thing.

New threads

Members online