Tascam 133 blinking record button

Discussion in 'TASCAM DIY Repairs and Mods' started by RobW, Nov 14, 2021.

  1. RobW

    RobW New Member

    Joined:
    Nov 2021
    Messages:
    2
    Likes:
    0
    Folks, I have a Tascam 133 that only blinks the record button when turned on. It won't do anything else no matter what buttons are pushed. Any thoughts?
    Last edited: Nov 14, 2021
  2. RobW

    RobW New Member

    Joined:
    Nov 2021
    Messages:
    2
    Likes:
    0
    It was working previously. I thought it may be something with the board behind the main buttons (play, record, etc.) But I disassembled and it looked ok. I don't know if it got into the record mode somehow that I don't know how to get it out of. Some combination of button pushes? Or maybe a faulty component?
  3. SkywaveTDR

    SkywaveTDR Well-Known Member

    Joined:
    Feb 2014
    Messages:
    1,067
    Likes:
    222
    From:
    Chicago area
    Gear:
    Teac, Tascam, Sony
    First this is a solenoid operated deck and also the power supply caps might be done. You need to measure all voltages from the supply and then look for stuck keys. The Keyboard when unplugged and the deck powered on would tell you if the keys are stuck. Tactile switches are not usually a thing that sticks but they can become defective contact wise. Looking at something doe snot do any good as viewing a shorted cap or a defective IC tells you nothing. Look also for foreign material that could be triggering a switch contact that is not really being pressed. The different things I have found in decks can be pennies to paperclips and all are conductive. Some service shop leave screw floating in a unit from incompetent work. Otherwise to find out why it is doing this will take a Technician to look at it.