Tascam VL-X5 Monitor trying to remove rear panel

Discussion in 'TASCAM DIY Repairs and Mods' started by Manos, Mar 14, 2021.

  1. Manos

    Manos New Member

    Joined:
    Mar 2021
    Messages:
    1
    Likes:
    0
    Gear:
    VL X5
    Hi,
    New member but old VL-X5 user.
    I realised today that one of the monitors does not make any sound, although the led is on and any bad cable issue has been excluded.
    Trying to see if the problem was caused by any minor issue that can be easily fixed like a solder joint or something due to a small bump several days ago (otherwise it could be a transformer issue in which case i will not touch), my problem is that I cannot remove the rear panel although I have removed all the outer screws.
    Is it stuck or is it any other thing I havent thought about?

    Thanx!
  2. SkywaveTDR

    SkywaveTDR Well-Known Member

    Joined:
    Feb 2014
    Messages:
    1,068
    Likes:
    222
    From:
    Chicago area
    Gear:
    Teac, Tascam, Sony
    I have not worked on this kind of unit but they often have glue that might also stick. If all the screws are out then it should come apart. I have a feeling this is made in China and with that grade of work I am not surprised that it has failed but you might be right that a solder joint could be the reason for failure- you need to go in and see. I don't think they expected these to be repaired as the cost would exceed the cost of buying a new one- In other words we now live in a throw away society.