Track assignment issue


New Member
Dec 12, 2012
Gear owned
I've had my 2488neo for about a year now, but only recently started working with it in earnest - and ran into a strange issue. My intent was to record vocals on track 1 via microphone (plugged into the first xlr jack) and guitar on track 2 - plugged into H - but routed to track 2. However, on playback, what I get is everything on track 1, combined - even though I see VU level movement on track 2 - the track2 fader does nothing - If I only play back track 2, I get nothing - even though I see the VU meter moving - and it's got a pretty good sigtnal. I t hink somehow I must have told it to combine the two onto track 1 (by accident) - but I thought I should be able to hear the channels separately. This has happened on occasion with other tracks, so I'm thinking I must be doing something wrong with the track assignment / record buttons. Note - sometimes when I press input a (until it blinks) and then press the track I want to assign it to (say #1) - #2 gets activated at the same time - very confusing. Same thing happens when I go through the sequence of Selecting input A - asign to track 1 - then select input H and assign to track 2 - both 1 & 2 light up (apparently assigned to input H - which I think is how my situation occurred. I've looked at the manual - but it's basically walking through assigning a single input to a single track - doesn't cover multiple inputs and multiple tracks & how to make sure they are separated,. Thanks in advance for any input to this,.
Two thoughts - First is that you are "linking" the two tracks when you are assigning them. This would explain the hearing of both vox and gtr on one track. If you press input A and both track 1 & 2 are lit, try pressing track 1 & 2 at the same time to unlink them
Second is that the "Internal faders" are not set to real or catch. Look in the global settings and check what the internal faders are set too. You could also, before playback, pull the faders all the way down and then up again and see if that allows you to hear whats on track 2.

You could try a new song and not reassign the H input, record your gtr onto track 8 and vox on 1 and see if the same issue arrises.

I tend to think too that you probably have linked the tracks to form a pair. Try unlinking first. If that isn't it check back. We'll get it figured out.
My Neo also has channels linked during playback (and mix down). Channels 1-5 and 7-8. It records OK, but having these channels linked does not allow me to mix down. Channel 1 controls 1-5 and 7 controls 7-8. My thought is the mixer section of the machine is defective. I can purchase a mixer section for $179, but it may be difficult to replace.
You've tried the unlinking procedure for the channels and it did not work?
The only thing I can recommend trying is contact cleaner on the mixer buttons. If using the select buttons does not unlink the channels that tends to indicate the buttons are not functioning. The are several forum members who have brought buttons back to life with contact cleaner.
Thanks Keith, I'll give that a try and share the results in case anyone else has the same problem. BTW, kudos to the person / people that got the site up and running again. It was like losing a friend when it disappeared. I've been a member and supporter since 2005. I know you've been active for quite some time too.
hi - I just inherited this machine from a friend a few weeks ago and am having the same issue. it's very frustrating - it can record 8 live tracks at once really well but won't do something as simple as record a mic to track 1 and then a different mic on track 2, same input or not, linked or not. I tried the example in the manual (which only seems to discuss the 1/4 guitar input) and can't record guitar to track 2 either - the track shows up as armed in the display but the meter won't register on that track and no audio is recorded. noticed the firmware is 1.0 so I'll attempt an upgrade, but if anyone has an additional suggestion hit me.
If you are able to record 8 tracks at once without any problem, then you should also be able to record one at a time. Talk to me a little about what differs in your approach to recording 8 at once vs your attempt at 1 at a time.
Thanks Keith

If I'd like to record 8 tracks at once, I create and name a song, arm tracks 1-8 with the sources unlinked, set my preamp levels, and hit play/record. Once the tracks are armed, the display shows a separate signal for the loudness of each track. This has worked great for recording band practices although the machine has frozen up on me a couple of times, causing the whole recording to be lost.

When attempting to record one track at a time, I create and name a song, arm track 1 with the sources unlinked, set my preamp levels, and hit play/record. For this part, the display shows the level of the signal for track 1. When I attempt to record track 2, I disarm track 1 and arm track 2 for recording. I still see the input signal on the display showing for track 1 and no signal is visible for track 2. When I record I can hear track 1 but not track 2, and track 2 is not recorded. This occurs whether I am using mic/line input #1 or #2. I have also tried assigning input H to track 2 and using the 1/4 guitar input but I get the same result. Using the guitar input seems to be the only multitracking example given in the manual, but following the steps described still does not result in a recorded signal on track 2.

I've also tried updating the machine to version 1.02 but keep getting an error, so maybe the machine itself is defective.

edit - I reset the machine to factory settings and now I'm able to multitrack with no problem. I think the CD drive might be going (explains the difficulty with upgrading the software) but I can get my tracks off via USB. Thanks for your reply. Great forum, by the way. Most of the other questions I have seem to be answered in Double's Home Guide, so thanks to him for making the effort to provide additional documentation.

New threads

Members online

No members online now.