US-1641 Firmware update 1.02 FAIL on driver 3.00db Mavericks


New Member
Jan 8, 2014
Gear owned
Hi guys,

I'm writing as having problem updating the firmware for the new 3.00db OSX Mavericks only. I was waiting over 2 months for Tascam to release the new drivers but when download it and install and restart then appears that I have the 1.01 firmware which is normal I assume. According to Tascam's guides see here:
( ... omdoc_d(bk)_revb2.pdf) - for the new driver I should use and update to 1.02 firmware for my interface to work. Sadly when I download and run the new update it says: 'writing..' and then shows the process (blue line) the half way through and says : failed to do the update - unplug the device now..

any help on this? :shock:

Thanks in advance

Hi Guys
I have an identical problem updating the firmware to v1.02 except that I am running osx10.8.5 mountain lion. The write starts and the blue bar gets about half way then stops and the message write failed unplug device appears. I have contacted Tascam but all i received was an automated acknowledgement. Meanwhile my projects are all at a standstill. If anyone has a suggestion grateful to hear from you. I have already tried deleting the drivers and started from scratch carefully following the instructions but to no avail
Same problem here! I lost my digital "ins" after switching from Vista to Mavericks(yes I updated the drivers). I really don't feel like buying a whole new interface!
Same issue on Yosemite. So tried going from 1.00 to 1.01 and you don't get the half blue bar it just fails. I thought I might have to step up. Did anyone figure this out?

I may try and do the firmware upgrade on a Windows machine. Need to borrow one first!

New threads

Members online

No members online now.