US-4x4 possible driver issues?

David Denyer

New Member
Jan 6, 2015
Gear owned
Hey everyone, first time poster here, thanks for reading my topic.

I'm having some issues with my unit and I was wondering if any other owners of this unit could confirm/deny whether or not they have similar problems with their unit?

Device: US-4x4
OS: Windows 7
Driver version: 1.01
Firmware version: 1.01
(all updated)

Really the problems I'm having stem from switching between applications, or more specifically sharing the device between multiple applications. When running audio software such as Reaper, or Ableton Live, or Amplitube standalone, no other application can output audio at the same time. For example, while playing back in Reaper, if I go to the Windows Volume Control and try to change the volume (to produce a "ding" sound) no sound is produced, and moreover, the meter beneath the fader on that Windows control produces no sign of output either. This is the same for Amplitube, Ableton Live, and any other piece of I/O audio software. If I stop playing back, adjust the volume in Windows (producing a successful ding, as the software is no longer using the audio output) and then switch back to the audio software in question, it sometimes takes a number of seconds to reload the audio device, OR it fails to play back at all, and I have to close and re-open the software. This is not just with Windows Volume Control - I have the same issue with Windows Media Player, VideoLAN media player, playing videos on YouTube, you name it. It simply cannot handle multiple applications using the device at once. Using ASIO4ALL in the audio software (instead of the official ASIO driver) solves nothing - Windows is still unable to use the output at the same time as the audio software.

Switching between ASIO4ALL in (for example) Reaper and going back to Windows using the official driver, or even sometimes just switching between applications using the official driver sometimes results in every piece of audio software running on my computer hanging and not responding - pulling out the USB tends to fix it, but I have to restart the computer before any audio will work through the device again. I think the problem with the crashing is something purely to do with my computer, as I've only noticed that happening on one machine. However, the above issues playing output from multiple software source has happened on every computer I have tried (All Windows 7). Playing output from two purely out-put software (ie, VLC + WMP, or YouTube + Windows Volume Control) works fine - it's only when using I/O software and trying to use it with another software output.

I have tried disabling "Allow applications to take exclusive control of this device" to no avail.

If anyone owning the above interface could test out the above scenarios, it would help me to identify if it's my unit that is faulty or if this device is simply unsuitable for my needs. I hope it's not an unrealistic expectation to hope for a device to be able to do this - my last device, a hopelessly useless Akai EIE Pro, was able to do this (but not much else). Even my onboard soundcard can run Reaper I/O and YouTube outputs at once - I would hope that this device should be able to do it too. It's still in warranty so I can replace the device if it's not working.

Anyway, thanks for reading, and many thanks for your help,

  • Like
Reactions: Vonzar
I've run into this problem as well with my current Tascam US-2000 (and pretty much every interface I've used). It's pretty annoying, lol. Unfortunately, very few interfaces allow more than one audio source at a time. Sonar has an option to "Share drivers with other programs", so maybe Reaper has something similar. Also, there are some ASIO "proxy" programs that allow you to route multiple sources. I've never tried one, but I found this on Steinberg's site:

"[...] ASIO (Audio Streaming Input Output) is a technology of Steinberg.
It allows for low latencies and pretty much every state-of-the-art audio device is nowadays delivered with an ASIO driver (on Windows, at least). However, the basic idea behind ASIO is that professional audio applications entirely take ownership of the ASIO device. Only very few ASIO drivers support true multiple application access. This effectively means that you can not use 2 or more applications using the same ASIO device at the same time.

The ASIO Multiclient wrapper overcomes this problem by providing a 'proxy' ASIO driver (the ASIO client), several of which can connect to the one ASIO Server, which in turn 'speaks' to the target ASIO device (driver). The server mixes the output streams of all applications, and provides that mix to the target device. [...]"

Here's the link-

There's another one that seems to be authored by the same name (Vidance) as the file from Steinberg's site-

I know there are some others out there for purchase, but I'm pretty sure the two I linked to are free. I've never used them though, so good luck & let us know if it works out for you.
Yes same problem here , but it gets even worse in Windows 8.1 pro 64 bit !!!!

Well here it goes with a new setup >

Windows 8.1 Pro 64 bit
Cakewalk Sonar X3e 64 bit
CPU : Intel Core i7 5930K 3.5 GHz Six Core Socket 2011-3 140W Box
GPU : nVidia GeForce GTX 970 4GB DDR5 PCI-E
RAM : 32GB DDR4 Non ECC CL16 2400MHz Crucial Ballistix Sport
Mother board : Asrock x99 extreme 6

That happens to every programme I run from Sonar to Premiere.
If I run Sonar x3e directly after I enter windows , Sonar runs ok with Tascam drivers.
But if I play an audio file before I enter Sonar x3, and then run Sonar , sonar says the drivers are missing and there is no drivers in the listing from the Sonar's preferences menu.
It's like Windows are keeping the drivers only for windows themselves.
Same thing happening , after I exit sonar x3 after a session. (Sonar runs ok only if I run it directly after I start windows)
NO audio can be heard , no video files could be run , actually any multimedia file can't run for some reason. It stucks at 0 time play. That happens if I also run a video on youtube. The video on youtube won't start. All because probaly an audio driver problem.

I would like to share more information about this issue. I found a semi solution , it really stucks . The drivers seems to work better in win 7 as I can see from your side , but in windows 8.1 pro its really very bad.
The semi solution is the following: After running cakewalk sonar ,or premiere I do my work , and then exit, I wait for 10 seconds , and then starting to play music files , surfing on youtube , multimedia things. And that works.
The solution is to wait around 1 0 seconds after every exit from Cakewalk Sonar or before going into Cakewalk sonar after I have played various multimedia files. That's strange I can say , I am not sure why that happens. It's like the driver is not free after the exit of Sonar , or it's not free after I play a multimedia file (audio or video).
It needs sometime to rest and then use the audio driver again. If the conflict happens , it strains windows very much. If I don't wait for 15- 20 seconds , the conflict happens and the drivers of Tascam us 4x4 are disabled from the use of Sonar , or even from the Windows for every multimedia file access. And further more with that conflict I can't shut down the computer or even restart. It halts the whole system at the restart or shutting process.
Luckily that work around helps a little bit , but I am sure it really need a decent fix.

Well I still have my previous computer with an M-AUDIO Delta 1010Lt .
I never had the same issue with the M-AUDIO card.

I send this info to Tascam but after 24 hours no reply from them , and now its weekend. I see that they dont release many updates for their drivers , which is really very very very bad. If they dont make new update I will claim a full refund from them since their product is defective with bad drivers support.

I believe it would be good to send your problem to them as well.
more info. It's not just Cakewalk Sonar , it's all audio software or any software using audio.
I see you do not use a second disk for audio/video?
I have 10 hard disk drives. Externals and internals. Mostly externals.
All is working great. The driver is the problem here.

I found a solution by using a third party asio drivers.
Any Tascam USB audio users that would like to use this driver. it's only 18 euros but you can solve all the problems!
with your driver and experience much better your whole computer configuration and enjoy your work.
Here is the link driver :

I hope Tascam can read these posts here and find a solution by properly updating the drivers. Till then I can enjoy my system with those drivers. Big thanks to those people there .
Hello, first time poster here, I'm having problems with my Tascam US 4x4...

I have Windows 7-64bit (with SP1)
Ableton Live 9 Lite

Disabled Firmware & Security
I've installed the Driver&Settings Panel V2.10

I'm not seeing the 4x4 under my Control Panel-Sound-Recording & Playback.
When I launch the Tascam Settings Panel, it shows that "No Device" is connected. I have USB 2.0, and have attempted to plug the 4x4 into all of the ports, but the problem still persists.

I've uninstalled and re-installed the Driver&Settings Panel 20+ times with no luck.

I installed Ableton Live 9 Lite to check the Preferences-Audio-Driver type. I selected ASIO and the hardware does show the US 4x4, but I'm not getting any activity from the 4x4 in Ableton.

My apologies if I'm just kicking a dead horse here, but...

Any help is very much appreciated!

New posts

New threads

Members online

No members online now.