Windows 7 x64 Crashes with IF-FW/DM MkII on DM4800


New Member
Sep 25, 2013
Gear owned
Tascam DM 4800
I have Tascam DM4800 with IF-FW/DM MkII connected to Mac with Cubase 5
and every thing is running good.

I got a new PC with windows 7 x64 and cubase 7,
I tried to install all available drivers for IF-FW/DM MkII on my windows the driver install successfully but once i connect the Tascam with the firewire card my system Crash the whole Windows hangup and I have to force shut-down the computer ,

After the computer reboot if the Tascam still connected The windows crash once it can feel that there is tascam connected to it.

I don't know what to do.
Go to the firewire card in the device manager, "update driver", "browse computer", "let me choose from list" and choose the one that says (legacy).

Let us know if this fixes the problem.
Also, make it a habit to never connect or disconnect firewire cables to or from a running computer. After having cables connected, switch on DM first and then boot up the computer.
Thank you for your instant reply,and I'm sorry for the late reply I just tried what you told me and it didn't work.
I selected the legacy driver for my Fire wire, so Widows crash stopped but when.
I tried to open to open my Cubase got this massage : " The current installed soundcard driver does not support Direct Sound Input. Recording audio not possible."

When I opend the "TMCompanion" I got this error " no compatible mixer was found please check USB connection with mixer."

When I opened the "IFFWDMmkII Control Panel" I got nothing :

even On mac I got the same errors.

This is my Card configuration on the mixer :

Thank you so muck for the help.


  • cubase_error.png
    6.3 KB · Views: 31
  • TMCompanion_error.png
    6.5 KB · Views: 33
  • IFFWDMmkII_Control_Panel_error.png
    10.7 KB · Views: 32
  • IMG_20130929_130646.jpg
    72.8 KB · Views: 31
You need to upgrade your firewire card firmware!
Go to tascam website and download the latest version (1.10)
That will fix your problem

Here's the direct Link: ...

I think you might have to uninstall the current FW drivers and install the v1.10 version (included in the .zip) of the driver first... then update the firmware to v1.10 (also included in the zip) then after you've established connectivity, upgrade to one of the BETAS Rebus gave you.

I think I'm right unless someone else knows better.

EDIT: You should also make sure your DM is using the latest firmware as well which is 1.70. I would upgrade that first.

New threads

Members online

No members online now.