X-48 MKII OEM Recovery CD or iso?

mixerizer

Soundaholic
Joined
Dec 25, 2021
Messages
349
Karma
179
Gear owned
DM-4800, -24, X-48, r250n
Hi folks,

UPDATE:

X-48 MKII Recovery CD Image (ISO) OS V201
https://www.tascam.eu/fr/downloads/archive/X-48MKII


if someone wants to host the file, please feel free to add the url to a reply to this thread.

Thanks to Patrick from Paris!


restoring an old x-48 and this one has a bad motherboard.

After downloading the x-48 MKI Recovery CD .iso on the TASCAM web site, I was able to reinstall the x-48 OS on a hard drive connected to a replacement Intel D525MW motherboard, as others have reported doing here on the forums. However, after using the MKI CD for installation, the hard drive would not boot - as others have noted, it does a Blue Screen of Death with an error indicating a missing SATA driver.

Since users have reported an easy install using the MKII Recovery CD, I sought to track down a copy of the disk - which is no longer available online on tascam.com (only the 1.20 iso from the MKI page). The link provided by Patrick to the file on TASCAM.eu is above.

thank you!
Mixerizer
 
Last edited:
Update - yep, there is definitely a difference. Use the 2.01 installer image for MKII and Intel d525Mw motherboard-upgraded MKI units!
 
Last edited:
There are three BIOS passwords - in the x-48 service manual it lists the BIOS supervisor password as ‘mitaka’ -have you tried that first?
 
High Clarrie

Waouh ... big responsibility!!
No, I absolutely don't know with certainty if by removing the battery the entire BiOS will be erased, logic would have it so, since precisely when you remove the battery you have to reprogram everything!!
and I imagine the password too !!
If you want to get into the biOS programming for a detail it's not worth taking the risk, but if you're completely stuck in not being able to work without reprogramming the BiOS then you have nothing to lose!
Good luck in the lottery!

(and good information from mixerizer , I didn' teven know there was other pass Word in the X48 than One in the BiOs ! And personnaly in my 3 X48 I never had to enter or program any password, that's why when programming the BiOs , I didn't go inside programming any Password )
 
  • Like
Reactions: mixerizer
Same here, I have never had to set or reset a BIOS password. There are a few ways to do it, some boards have CMOS jumpers, etc. but I bet the info in the service manual will explain it.

Note - the options for resetting, as well as the flavors of BIOS password, as I learned when researching the x-48 project (w Patrick’s help among others), are laid out here https://www.dell.com/support/kbdoc/en-us/000131024/how-to-clear-the-bios-password
 
  • Like
Reactions: shredd
read @mixerizer 's article - brilliant - I can recall times in the past when I've used similar technique to recover a system I was sure unrecoverable.

It also explains/demonstrates my Luddite/old-school aversion to combining computers with music. I OF COURSE understand that not only is that 'how it's done now', and of course the awesome power/versatility of DAW-based production...
But my forays into that area over the years have brought nothing but misery and distraction from actual music. S0 - I do music production stone-age style. If it was good enough for for the YES's, P/Floyd's, and Beatles (etc etc) of the world...it's good enough for a hack like me.:rolleyes:
 
  • Like
Reactions: mixerizer
I know what u mean - those bands are big influences for me too. I try to work the way they would have back then, given today’s solutions to the problems they had (editing, crosstalk, variety of synthesizers).
 
I just fired up my 2 machines for the first time in about 5 years. One of them sprang to life like new. The other is stuck on Host Not Responding message and red flashing meter lights. I can't even open the CD tray. Any ideas?
 
Your Battery must be exhausted , so the BiOs must be erased
follow my instructions on that "Discussion" on this Site , it could help :


https://www.tascamforums.com/threads/x48-host-not-responding.7997/



MANUAL


The one that TASCAM DOES NOT provide to users of its machine!


When the battery is removed all BiOS data is "erased".


Super important because indicates where the Mothercard must connect, USB keyboard possible?


FW IEE1394 possible for external HDD? And plenty of other things,

But it is the Battery that keeps all this data


Your BiOS allows you to configure the operation of your components (clock speed, timings, etc etc). The problem is that the chip the BIOS is on, can only be READ, so changes made are stored on another chip called CMOS for Complementary Metal-Oxide Semiconductor, I expect battery powered.


As a precaution, after changing the battery, I first unplug the X48 if I had left it plugged in.


Sometimes we are lucky, it restarts normally, but in general the X48 no longer opens on a project, and displays lots of windows , with screened in front of the device

"HOST NOT RESPONDING"


And if you have a Boot CD inside, thinking it's a problem of Hard internal drive, it will do the whole process, and when you want to partition and format the internal hard drive, at the end of the process it will tell you


"An error occured while formatting your OS drive, (with usual Bla Blastuf about "Technical Support"...which is unreachable !)


Before being saved by this site, and the Posts of HelllvisPreley and others, I spent whole days trying to find the solution for this Big mess…Save my data on a computer, or other hard drive, try to reformat everything ,etc .. I'll spare you the details!


xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx



PROGRAMMING THE BiOS


Pitfall No. 1

You have to connect with a PS2 Keyboard…. it seems!

(The USB keyboard connection on an old X48 is also programmed in the BiOS!)


The first element to access the BiOS programming is;

As soon as the X48 turns on, and see the Dispay screen,

you must PRESS THE SUPPR KEY


Here is Pitfall N° 2 not the DELETE key with the arrow to the left which is used in Word for example to erase, but the SUPPR KEY

(you need a keyboard where it really appears, somewhere at the top right)


And there we finally have access to the setting window for all the elements of the BiOS

At each sub-window, exit by ESCAPE, and finally exit and save by F10 and then

the classic X 48 Project window reappears!! MIRACLE !!


LIST OF SETTINGS TO MAKE IN THE BIOS

The way to change values, to move, etc.; are marked at the bottom of the window,

even me, I understood !


1/ Go to the line "I will smart setting" / ENTER


Line : Change on-chip serial ATA set to ( ENABLED )

Line : Serial ATA Port0 mode, set to ( SATA0 Master )

Line : On Board 1394 line set on ( ENABLED )

ESCAPE


2/ Go to the line : "Cmos features" / ENTER


Set date and time

Line : Drive A, set to "NONE"

Line : Halt On, set to "No Errors"

ESCAPE


3/ Go to the Line : "Advanced BiOS Features" / ENTER


Line : First Boot device set to (CD-ROM)

Line : Third Boot Device set to (DISABLED)

Line Boot Other Device set to (DISABLED)

ESCAPE


4/ Go to the Line "Integrated Peripherals" / ENTER

then Line "Onboard Device" / ENTER


Line : USB Keyboard Support set to ( ENABLED )

Line : USB Mouse support, set to ( ENABLED )

ESCAPE


(Then, still in Integrated Peripherals, go to ..

Line : Super IO DEVICE / ENTER


Line : Onboard fdc Controller set to (DISABLED)

Line : PWRON After Pwr-fail to, put on (Former-Sts)

ESCAPE

And eventually, recheck everything,


Otherwise…., F10 for Save, and there it displays a Y for yes ,

and / ENTER and it's gone!

Everything is saved, there will be a little time, then it's MAGIC

we will FINALLY see the Projects window reappear with its Tracks!!


I did not take care of the Supervisor and User Password lines,

and the lines that I do not quote in this manual, I left them

as they were



GOOD LUCK !!!!
 
Thanks, Patrick. I have changed the battery. Was the first thing I tried. The Host Not Responding message is on the machine itself. It never gets as far as having anything on the monitor so there’s no way to get to the BIOS settings, or to open the drive tray.
any thoughts?
 
As for your screen, I imagine that you have checked the monitor itself, its source

For the CD I suppose you tried to extract it by pressing in the small circular hole at the bottom right of the CD tray with a sewing pin??
But without screen and having changed the battery, therefore Bios erased, it is I suppose impossible to reprogram it without video Monitor .
 
Sorry, Mistake in my last Post

"As for your screen, I imagine that you have checked the monitor itself, its source and the cable connection, otherwise it may be the graphics card, and that is beyond my skills. For the CD I suppose you tried to extract it by pressing in the small circular hole at the bottom right of the CD drawer with a sewing pin??
But without screen and having changed the battery, therefore Bios erased, it is I suppose impossible to reprogram it.
 
Also, hold down the CD eject button while you power up the machine, and wait. It should pop open.

if you find that you do have a significant problem on your motherboard, you may want to consider doing the MKII conversion, rather than attempt to repair a bad motherboard. It means you have to modify the case, but it is not hard to assemble all of the components and have a much more stable machine once you modify the case.
 
Thanks Mixerizer. This looks awesome, but I was just firing up the machines to see if I can sell them. I have been using the DA6400 as a backup machine for years now and it is awesome.
Not sure it’s worth it time and money to do the mod, although, back in the day, I would have been all over it in a heartbeat!
 
Understood! If you can’t get that CPU P’ing, u gotta either fix the motherboard, upgrade it to an MKII, or sell it in a non-functional state. There is one in the same condition for sale now on ebay, but imho it’s priced too high.
 

New threads

Members online

No members online now.