DM-4800 not locking to Pro Tools

samuelkasey

New Member
Joined
Nov 15, 2013
Messages
3
Karma
0
Gear owned
Tascam DM4800
Okay. phew... For starters my problem is that the DM4800 doesn't lock to protools 9. I have control, but apparently will not send generated timecode to the DM. I've researched and exhausted every outlet. What gives?

My DM4800 Settings:

Remote:
Machine control M HUI Emulate, with TRA Checked
Ext Control: 24 HUI Emulate - Ports (5-7)
Machine Control: Play, RecFn = True
Jog: Search

Automation Settings:
Automation: On
Sync Source MTC(USB)
Frame Type: 30ND

MIDI
MTC USB 3 Channel on

OPTION:
Timecode Set to Automation Sync Source
Timecode Display

Protools 9 Settings:
HUI Emulate set for Midi Channel 5,6, and 7
Synchronization: Midi Output set to Midi channel 3
Session settings to 30 fps


System Configuration:
Tascam dm4800
Firewire Card
Windows 7
Protoolos 9.06
Two (2) 3.0 Quad Core Intel Xeon CPU's
24 GB Ram
Dedicated PCI Firewire Card
120 GB SSD Drive
2 TB backup storage

Also, I'm getting errors saying the asio device has made changes, need to shutdown protools and save changes. This occurs just about everytime I change or add a track.

I feel like it's got to be juts a few settings/ switches on the DM, but does anyone have a complete list of all the settings requried for the DM to sync, lock and display the timecode from protools. Help! Obi-wan, you're my only hope.

thanks for the help.

Samuelkasey

Darren
 
Uh....first you have to understand a basic concept: Protools (9/10) and probably 11 as well expects to see time code from an external source. However, there's an exception: if you're NOT performing OTB/DM mix automation, you MAY receive MTC from Protools. This is especially helpful for tracking and editing.

I wrote a lengthy post on how to set up the DM and PT for both purposes (yes - you'll need TWO separate settings because when the DM sends MTC, you will NOT have the DM's RECord key available.) Problem is, I just searched through the message archives and can't locate it. Perhaps you'll be able to using the keywords "ProTools 9; mix automation; MTC; setup"

In the meantime, if you're using Windows7, be sure to run PT as 'Administrator.'

CaptDan
 
Thanks for the input. I believe I read the post you mentioned. I'll find it again and re-read it. Maybe, I must have missed some critical points.

Another Question for Clarification:

I guess I was expecting, and was under the the understanding that ProTools would send it's own generated timecode to the DM across the USB Midi Channel 3. If this is true, why can't the DM use that time code to base its OTB mix automation?

Again, thanks for the response and I will definitely ensure that Protools is running as Administrator. That is something I hadn't done. Thanks Again.

CHEERS!
 
PT DOES send MTC over Channel3. It also receives MTC from the DM over the same port.

Your question about MTC bi-directionality is a good one. Best way I can answer: when Avid kindly opened Ptools up to the ASIO world, they accidentally (maybe on purpose) forgot to exclude certain proprietary coding which was left over from the PTools flavor of old. Put another way, there are some strange issues that must be worked around in order to make PT play nice with the DM - particularly with regard to transport access and DM mix automation syncing. These are not big deals, but they have to be understood nonetheless.

Here's a message from earlier this year that should get you set up for tracking and editing in PT, but not mix automation. I can elaborate on that tonight after I've had a chance to upload some screens for you to see.

DM-4800 with Pro Tools HUI error SOLVED!!

CaptDan
 
Last edited by a moderator:
Awesome. ! I appreciate the link and the information. I look forward to learning more. Thanks so much.
 
Tascam support told me if I want to run the DM4800 automation, then it has to be the timecode master to the DAW. Your computer DAW has to be the slave. It seems odd, as you could have an external VTR deck as your timecode master and it would work, but apparently it's just the way it is.
 
Will... That may be true for ProTools (I haven't used it in years, so I don't know), but I run the DM's mix automation from MTC generated by Digital Performer. It all works perfectly, including the time code display on the meter bridge. The Capt's statement on what ProTools left out must be PT exclusive.
 
I think it is, Jim. When I ran Cubase (3.x), it was a non-issue. The DM would chase to 'Base's MTC - both in tracking and in automation mode.

When I jumped to PT9, then 10- a couple years ago, it was another ballgame entirely. I could still utilize PT's MTC - with full bi-directional transport/HUI/MMControl. BUT - when it can time to do an automated mix, I had to switch out to DM as MTC master, PT as slave, and accept a few other limitations. Again, though, it's become a non-issue too. But - if I hadn't had opportunity to discuss this stuff at length with our PT Supreme Leader - Ernie/Jamsire back then - I'd probably still be scratching my head today. :)

EDIT: Apologies for not getting around to those screen shots. Looking like tomorrow when I'll have the time to get it done.

CaptDan
 
Hi Darren,

I can't offer an answer, but I did have exactly the same problem / same errors / same configuration PC a couple of years ago. After spending way too much time trying to get it to function properly I had to do something and got a mac (I didn't want to move in that direction). The mac worked perfectly straight away (and is still working) with the same settings etc. Even the record button on the DM functions when sync'd to PT9.

I concluded that it was a PC motherboard incompatibility issue as there were specific m/boards listed as compatible. fyi I tried various supported firewire cards incl. TI and also tried the onboard f/w.

Not the advice you're seeking (sorry) - I hope you find an answer as the PC option is much cheaper.

:(
 
Somehow, I don't think a PC's motherboard is a factor in this case. But MBs, firewire driivers and chipsets have been problem areas.

Just to clear up some possible confusion, here are some guidelines and screen shots for running the DM & Ptools on a Win7 machine. These are based on the concept of using two separate DM setups (easy to switch between) - one for tracking and editing, where complete transport and function key access is available - and another for automated mixing. First - the tracking/editing setup: (based on a DM3200; for a 4800, an additional HUI extention is required.)

1. In the 'Automation' Menu, tick the MTC/USB3 box.
2. Choose 'HUI/Emulate' in the MMC Menu; check the TRA button.
3. In Protools, set up the Peripherals as shown in the attached screen shot.
4. Again in ProTools, enable the BLUE button on the PT transport: GEN/TimeCode

In this scenario, the DM will receive MTC from PTools and display it on the meter bridge and/or TMC's meters as desired. Also, full access of all transport buttons and Function keys (along with the CTRL key if required) is available.The DM RECord button is functional as well. Ptools will respond to those commands, as well as any other HUI device ('Tranzport' etc) that's been installed.
-------
Now - for DM Automated mixing:

1. Choose GENerate INternal in the DM's MMC menu
2. In the Automation menu, choose INTernal MTC
3. In Protools, DISable the blue MTC Generate button on the transport
4. On that same transport, ENable the two blue SYNC buttons (they should flash)

At this point, Ptools will receive MTC from the DM, but the DM's RECord key is non-functional. Also, the REWIND button's behavior will revert to a 'film-style' behavior - ie - it will rewind at slightly faster than play speed. But there IS a workaround and it works very well!!.............

You'll notice there are numerals around the DM's command keypad. These are for
jumping instantly to anywhere on the time line. Markers are set in the DM marker menu - which allows up to 10 numeric place markers to be set. In an automated mixing scenario, appropriate markers might be: RTZ (00:00:00), Verse #1 (maybe: 25 seconds in), CHORUS (insert number here), etc etc. With 10 unique marking points, it's simply a matter of punching up a pre-set - from #1 - to #10, and jumping immediately to that part of the track.

Finally - the DM's automation TIMELINE and Ptool's START time must agree. If, say the Ptools start is 5 seconds in, then the DM's MTC mark should ZERO out at that point. This is necessary, because if - in the future - you come back to remix the piece after completing subsequent projects, the start time has to be in sync for the automated file to perform as expected.

I hope this makes sense. After you've worked with these set ups for awhile, they become quite logical and convenient, in my opinion.

This website only allows 4 attachments per message, so I've added the remaining screen shots in the following message.

CaptDan
 

Attachments

  • AutoSetup.png
    AutoSetup.png
    5.7 KB · Views: 124
  • HUI.png
    HUI.png
    60.1 KB · Views: 42
  • PT-Track.png
    PT-Track.png
    65.7 KB · Views: 39
  • Sync.png
    Sync.png
    57.7 KB · Views: 40
So I am a noob at this automation thing, thanks to this thread I was able to get some things accomplished. As far as mixing down automation and sending code to protools, it seems like everything is fine, until this error. I know it can't actually bee the buffer setting. I must be missing something.

Screenshot 2014-07-23 23.33.21.png
 
Last edited by a moderator:
Devote less CPU power to your RTAS plugins in the Playback Engine tab.
 
I'll second Jamsire's advice. Trimming some CPU power load, or maybe omitting a power hungry DSPplugin from the DAW will usually correct these problems. But - sometimes, with certain computers, the buffer size has to be increased in the DM/Fwire driver as well.

Before I switched to the latest Tascam firewire driver (and Win7 'Legacy Driver') I would experience regular Avid/Ptools 'Contentions' like the message Raw_B posted. A 'contention' doesn't always indicate the problem specified in the pop up message is accurate. You'll excuse my crude reference, but often - in a DM/Firewire/DAW environment - it could mean that Ptools is 'on-the-rag.' :p

By that I mean - some programming idiosyncrasy, still entwined in PT9/10/11 from the ProTools Of Yore (pre version 9), is conflicted with a processing operation it doesn't recognize. As Ernie/Jamsire pointed out to me, prior to 2010, Protools spent its entire existence as a proprietary application designed to be used in conjunction with 'authorized' hardware interfaces. In the Brave New World of ASIO drivers, perhaps PT 9/10/11 hits a brick wall, loses its 'mind,' and unable to speak clearly, pulls up the first Warning!/Contention pop up it finds and kicks it towards you like a smelly wad of dirty laundry.

Apologies for the technical jargon. :mad:

CaptDan
 
Last edited:
  • Like
Reactions: Arjan P
The dreaded PT CPU error!

I have had that pop up ocassionally on Windows DAWs (with PT8 and Delta 1010 ADDAs) and Mac DAWs (with PT9 and the DM).

No amount of changing the cores allocation / buffer sizes etc has made it go away.

I never run any PT plugs so that's not the issue.

It occurs most often when I'm looping, but it has also occurred a few times just after PT bootup with no session loaded.

I now call it a "special PT feature" and live with it.....

I also use Reaper when it annoys the cr@p out of me.... and when it comes time to upgrade my DAW again I'm thinking of moving to Samplitude - but that's another discussion ;-)
 
Yeah - 95% of the time I'd get those contentions it would be during a lengthy looping session. But that's history - UNLESS - it's the 80th pass. Then, maybe I'll hear a crackle. I just go out of loop mode, save the project, then continue on without further interruption.

But I like PT and intend to stick with it because - by and large - it behaves itself and lets me work. :)

CaptDan
 
Yesterday was a bad day for PT9 - mixing a 17 minute song and it wouldn't go 3 minutes without the CPU error message. Going bzzzt occassionally too. <insert favourite expetive!>.
So this camel's back is now broken.
I loaded the .wavs into Reaper (drag and drop to tracks in a template) - 5 minutes later everything was humming along - not a glitch, not a hiccup, remote layer working too.
Goodbye PT - you have lost a long term users because of your flakey product.
 
  • Like
Reactions: cmaffia
You fought the good fight! Just keep making that good music.
 
  • Like
Reactions: Drumstruck
While Reaper has become a decent DAW over the past few years, I suggest you look into recent versions of Cubase or Nuendo, that has pretty much all the features of what even PT10 or PT11 offers and even more. No DAW is perfect but those work pretty solid with the DM IFFW card as far as audio and lack of CPU issues when used with a decent buffer size.

I know several others and myself have found that the DM's MTC via USB and to the MU-1000 meter bridge is pretty much hit or miss as far as being solid and reliable as you would expect it should be, but using the DM MIDI port with external USB MIDI device can be used as a workaround with much better results.
 
Thanks for the tips AudioWave - fwiw I can't find anything lacking in Reaper (for my purposes) other than the interface is not quite as pretty, and that was fixed with some massaging of one of the optional skins. Not only that but Reaper has unlimited track count which none of the others seem to match. Same with it's small footprint - it takes almost no memory and is very fast - apparently very well written code.

At this point I'd say that experimenting with an alternative name brand DAW s/w would be throwing good money and time after bad.

I've got PT9HD for sale (here in Oz) for $300 - I've really given up on fighting it.
 

New threads

Members online

No members online now.