Dr 40 freezing on startup screen

Heronildo Pimentel

New Member
Mar 9, 2019
Gear owned
DR 40
I updated the firmware of the DR 40 from 2.30 to 2.40, but when I log in I do not leave the loading screen written "LINEAR PCM RECORDER". how to downgrade ??


  • P_20190309_184738.jpg
    29.5 KB · Views: 14
> ... how to downgrade...

I don't believe you can.

An obvious suggestion is to do the update (including downloading a new zip file) again. Does it appear to succeed?

You might also try powering the recorder up with a different formatted SD card and, if that still fails, try powering up with no card, then insert a card while powered.

Lacking success you might try Test Mode to see if you can identify a failure. Try holding both Quick and Rewind while powering up to enter Test Mode.
Last edited:
  • Like
Reactions: Generator
Thanks for sharing how to enter TEST mode. More documentation on how to use it to troubleshoot would be most helpful. You wouldn’t know where one could find that, would you?
Hi, sorry to dig an old thread. I have the same problem on my DR-40 unit. Mine turns on then shows this screen and shutdown about 5 seconds later. It's in this state for years and I've tried everything. I can even successfully enter test mode, but from there, nothing have any effect.

I'm almost certain this is a problem of a corrupted eeprom (SPI flash). I managed to get a dump of mine with a SPI programmer but then I'm suck. Tascam site have files for 2.50 and 2.51 firmware version, but they're not similar to my eeprom dump. It could be that the firmware is compacted with god knows what algorithm (I've tried lzss, lzma, bz2, etc. etc...).

If anyone can make a eeprom dump of a working unit, I would be very glad. (my unit's flash is MX25L1606EZNI). Thank you.
I managed to get my unit working again, after years.

To wrap up the solution:

Boot into TEST MODE with << + QUICK + HOME
Go into Menu > VERSION. Press REC to run DistClear.
Go to Menu > ROM. Into "EEPROM Check" screen, Press REC to run the Write test.
Go again into Menu > VERSION and press REC to run DistClear again.
Now restart the device.
It should boot into the Language selection screen.
From then it should ask to write a sys file, Press ok. It should boot normally.

If it get stuck into the Language Selection. Press Enter quickly and lots of times. It should force it into boot.

I hope it helps anyone.
Hey Arthur, It's been many years since my dr-40 is entirely dead, but it was my fault. I tried to install the dr-40x firmware into my dr-40. The installation failed and I bricked it. The device is 99% dead, I cannot even boot into test mode, the only thing that happens when I press [<< + QUICK + HOME] is that there's a very high frequency sound while pressing the buttons, and that's it. Any ideas to be able to get into test mode? I've tried with new batteries, connected by USB, with and without an SD card.
You can write back a good firmware image directly to eeprom.
Mine is attached*. Is not exactly a perfect image, since I've dumped it right before recovering it, but it should work.

You'll need to unsolder from pcb, solder to an adapter, then plug into a eeprom programmer, do the writing, check, solder back to pcb, then run the procedure of distClear I mentioned earlier.
Good luck.

*I tried to upload a zip file but it is not allowed. Not sure if it's allowed to post binaries files here. I can try to upload anywhere else latter.

New threads

Members online