Front Panel buttens sometimes do not work

Discussion in 'TASCAM MX-2424' started by davidd, Sep 3, 2018.

  1. davidd

    davidd New Member

    Joined:
    Jun 2015
    Messages:
    6
    Likes:
    0
    Some buttons on my mx2424 stop working, I have to press multiple times or press other buttons inbetween. Spcially the „all safe“, „shift“, and the chennel buttons 1, 9, 17.
    When I press chennel button 1 or 9 or 17, sometimes two of them or all three get selected or record armed.
    I would suspect a cable connection or the buttons themselves to have to be reseated/cleaned.

    Any ideas?

    Many thanks
    Klaus
  2. davidd

    davidd New Member

    Joined:
    Jun 2015
    Messages:
    6
    Likes:
    0
    BTW, controlling the MX via MMC from Nuendo lets me record enable/disable chennels 1/9/17 w/o preoblems, so definitely a hardware problem...
  3. witzendoz

    witzendoz Active Member

    Joined:
    Sep 2012
    Messages:
    493
    Likes:
    37
    From:
    Fremantle, Western Australia
    Gear:
    M3700 MX2424 MSR16S
    I do believe there is ribbon cable(s) connecting the front panel to the main board but its been a while since I have looked inside, try disconnecting and reconnecting, this is all it takes sometimes to remake the contact. If you have some contact cleaner you could give it a spray while apart. There also could be dirty contacts within the buttons themselves.

    If you think you need a set of schematics send me a PM with your email address.

    Alan.
  4. rqstudio

    rqstudio Member

    Joined:
    Jul 2013
    Messages:
    122
    Likes:
    3
    Gear:
    MX-2424 DM-3200
    I have a brand new ft panel will all of the button and screen in a box around here somewhere!
    Tandersen likes this.