FW-1082 on Win 10

Discussion in 'Firewire PC Audio Interfaces and Control Surfaces' started by bolshed, Nov 30, 2017.

  1. bolshed

    bolshed New Member

    Joined:
    Nov 2017
    Messages:
    1
    Likes:
    0
    Gear:
    FW-1082, DR-40.
    Hello everybody.

    I couldn't find info on this so I decided to make a new thread.

    I got a FW-1082 from a friend who is not using it.

    Was disappointed to find out that it's not working on my Win 10. Also couldn't find info of someone that made it work. Is this just a brick in the corner of my bedroom or I can use it on Win 10 ? I'm not willing to install other OS on my studio computer just to work with it.
  2. Sousapro

    Sousapro New Member

    Joined:
    Apr 2018
    Messages:
    3
    Likes:
    0
    Gear:
    FW-1082, DR100MK2
    I got the FW-1082 working with Windows 10 after some fiddling. You definitely need the FW Legacy driver. You can find the driver on:

    https://support.microsoft.com/en-us/kb/2970191

    Install the driver and then select the driver via the Device Manager. And of course install the most recent Tascam software version 1.8.

    Please give it a try, If you are stuck contact me, I will do my best to help you out. Kind regards, Eduard
  3. Steve Fogal

    Steve Fogal New Member

    Joined:
    Oct 2016
    Messages:
    47
    Likes:
    2
    From:
    California
    Gear:
    FW 1884, FW-1082
    Curious, does setting Windows 10 to Win 7 backwards compatibility mode help, or necessary?
  4. Sousapro

    Sousapro New Member

    Joined:
    Apr 2018
    Messages:
    3
    Likes:
    0
    Gear:
    FW-1082, DR100MK2
    Hi Steve, my initial assessment was a bit premature. I got it working, and it remained stable as long as the computer and the fw-1082 were turned on. But when I started my setup the next day.... no cigar.

    The strange thing is that in most cases the fw-1082 shows up in the device manager, but the firewire light on the fw-1082 is not lit.

    Normally something does work or it does not work; in this case apparently not. I see 3 possible causes:
    1. The FW legacy driver;
    2. The FW-1082 software (ver 1.80)
    3. A combination of 1 and 2.

    I will keep on trying to get it working; I will definitely keep you posted. Kind regards, Eduard
  5. Steve Fogal

    Steve Fogal New Member

    Joined:
    Oct 2016
    Messages:
    47
    Likes:
    2
    From:
    California
    Gear:
    FW 1884, FW-1082
    Not sure if this will help you, as it's helped me in my situation. But I've just discovered a solution for my firewire LED light not coming on. It involves opening the Soft_LCD display. If I open this BEFORE I turn on the Tascam, the firewire LED comes on every time now, where as with other actions it won't light. I posted a thread in case anyone else has that issue. It may be worth a try or you, though I know you're using Win 10 and I'm using Win 7 in my case. If you know exactly what the Soft_LCD Display is, you may not need to read my thread below, just try it. But remember this Soft_LCD display in the future as you keep trying, it may come in handy, if there currently are other factors preventing operation for you.

    http://www.tascamforums.com/threads/discovered-how-to-best-connect-my-tascam-fw-1884-1082.5304/
  6. Sousapro

    Sousapro New Member

    Joined:
    Apr 2018
    Messages:
    3
    Likes:
    0
    Gear:
    FW-1082, DR100MK2
    Thanks, Steve! I will try it out. /Eduard
  7. DeeringAmps

    DeeringAmps Member

    Joined:
    Jul 2013
    Messages:
    123
    Likes:
    10
    Gear:
    FW-1884
    I got my 1884 up and running on Win 10 today. So far, fingers crossed, the firewire light comes right on.
    I did have to jump through some hoops to get the "Legacy" driver installed and then the v1.8 driver going.
    I will soon be putting a tutorial up on my 1884 site.

    Tom
  8. Schultenmedia

    Schultenmedia New Member

    Joined:
    Aug 2018
    Messages:
    5
    Likes:
    2
    Gear:
    Tascam FW 1884
    I made it work! Win10 newest update + ProTools 10HD/Reaper/Ableton10.
    Motorfader and audio works. I will make a YouTube tutorial about it.
    James Russo likes this.
  9. DeeringAmps

    DeeringAmps Member

    Joined:
    Jul 2013
    Messages:
    123
    Likes:
    10
    Gear:
    FW-1884
    Congratulations!
    We all will appreciate a video.

    Tom
  10. Schultenmedia

    Schultenmedia New Member

    Joined:
    Aug 2018
    Messages:
    5
    Likes:
    2
    Gear:
    Tascam FW 1884


    There it is :)
    Steve Fogal likes this.
  11. James Russo

    James Russo New Member

    Joined:
    Dec 2018
    Messages:
    6
    Likes:
    3
    Gear:
    FW-1082, Model 80, US-428
    I'm going to try to get mine working now :)
  12. DeeringAmps

    DeeringAmps Member

    Joined:
    Jul 2013
    Messages:
    123
    Likes:
    10
    Gear:
    FW-1884
    Best of luck James. Do please keep us posted.

    Tom
    James Russo likes this.
  13. James Russo

    James Russo New Member

    Joined:
    Dec 2018
    Messages:
    6
    Likes:
    3
    Gear:
    FW-1082, Model 80, US-428
    I tried last night, with a result of failure lol. I was exhausted n half asleep tho. I’m gonna try again in a few min.

    - I got a PCIe FireWire card
    - Installed that
    - Installed the Legacy Driver for that
    - Installed v1.8 Tascam drivers for my 1082
    - Win 10 doesn’t show 1082
    - 1082 window has evthing grayed out

    I tried opening SoftLCD before firing up 1082...I tried opening it after...NG for me. Please lemme kno anything I’m missing, as I attempt round too on a rainy, Brooklyn Sunday

    Best,
    JR
  14. James Russo

    James Russo New Member

    Joined:
    Dec 2018
    Messages:
    6
    Likes:
    3
    Gear:
    FW-1082, Model 80, US-428
    Not quite sure what I’m doing incorrectly but I’m having a hard time getting it to work.

    I’ve tested the install of the card n it is good. I plugged in n old FireWire hdd n it came right up n I could play all the files on the drive.

    When I install the tascam 1.80 drivers in compatibility mode, it goes thru the install but when it’s done and I power on the fw1082 it isn’t recognized by windows. I’ve tried starting the sofLCD first but still no dice.

    I can’t even get to a stage of trying the 1082 with any apps because it doesn’t even get recognized. When I open the tascam control panel, it’s all grayed out n I can’t adjust any settings n it doesn’t see the 1082. Also the soft LCD just says “waiting for...”

    Any help with suggestions would be greatly appreciated.
  15. James Russo

    James Russo New Member

    Joined:
    Dec 2018
    Messages:
    6
    Likes:
    3
    Gear:
    FW-1082, Model 80, US-428
    Update -- I got it working and now I'm restarting to test stability. I was so desperate that I thought to myself..."self, what haven't you tried? Good or bad!"

    I read some posts about the boot order and thought hmmmm firewire/1394 sometimes used to give issues with device recognition and power. I thought maybe the powering on and off of the FW-1082 was somehow not enough to get the PC to "notice" it was there and ready to rock. As a total long-shot, I left the device on and unplugged the firewire cable from the back and then plugged it in while the machine was on. I thought it would maybe "spike" the firewire/1394 bus and the system would see it, lmfaooooo. Such a longshot...I felt like a total idiot!!! However, the jokes on me or I guess -- not on me, in this instance! Saweeeeeet!!!

    So add that to the list of weird things you can do to get these beautiful devices working again in modern OS. The TASCAM devices themselves are SICK -- for the price!?! I've used the frickin thing for years and years and it only cost me around $1K originally. I even used a US-428 before this ha.

    I'm trying to attach some pics here so you can see the various states of not-working and then...poof -- working!!! I hope others can benefit from ideas and info here. Thank you to all the folks that posted their experiences and insights along the way -- you guys rock!!! I'll report back after I test it a bit.

    :)

    NO SYNC ON FW/1394 BUS
    1-SoftLCD-WAITING.JPG

    GRAYED-OUT TASCAM CONTROL PANEL
    2-GRAYED-OUT.JPG

    AFTER 1394 BRUTE-FORCE
    3-WINDOW-GOOD.JPG


    Soft-LCD CONNEX
    4-Soft-LCD-CONNEX.JPG


    FireWire LIGHT IS GO
    5-FireWire-LIGHT.JPG
    John Varney and Steve Fogal like this.
  16. DeeringAmps

    DeeringAmps Member

    Joined:
    Jul 2013
    Messages:
    123
    Likes:
    10
    Gear:
    FW-1884
    Happy to hear you got it working!

    Tom
    James Russo likes this.
  17. James Russo

    James Russo New Member

    Joined:
    Dec 2018
    Messages:
    6
    Likes:
    3
    Gear:
    FW-1082, Model 80, US-428
    Thanks Tom!!!! I’m so stoked. More folks should do this bc the gear is great n it’s a shame for it to be collecting dust.
    John Varney likes this.
  18. Andrew Pauly

    Andrew Pauly New Member

    Joined:
    Jan 2019
    Messages:
    6
    Likes:
    0
    Gear:
    Tascam FW-1082
    I have one as well but everytime I turn it on I get a Driver IRQL_NOT_LESS_OR_EQUAL error message from a BSOD restart.
  19. DeeringAmps

    DeeringAmps Member

    Joined:
    Jul 2013
    Messages:
    123
    Likes:
    10
    Gear:
    FW-1884
    Andrew we need a little more info:
    1) OS, Win 10?
    2) TI chipset for the firewire?
    3) Have you followed the tutorials and installed the "Legacy" driver?

    Tom
    James Russo likes this.
  20. James Russo

    James Russo New Member

    Joined:
    Dec 2018
    Messages:
    6
    Likes:
    3
    Gear:
    FW-1082, Model 80, US-428
    I had a Windows xp system a long time ago that constantly BSOD’d me with same error. Ultimately it was due to the FireWire chipset in the system. I remember there being some issues with certain FireWire cards/chips. If u have another card there, I’d pop it in n try it out. Or go get a cheap one or order one online.

    Good luck

Users found this page by searching for:

  1. tascam fw 1082 windows 10