FW-1884 does not find the connected FE-8 modules


New Member
Dec 8, 2012
Gear owned
FW-1844 + 2 piece of FE-8
I have been using my FW-1884 many years and I just love it. Now after many years research I found 2 piece of FE-8 and I cannot get them talking to my FW-1884.
I have properly both uninstalled and installed the latest FW-1884 software witch I think is the 1.80 version. So my FW-1884 is working alright but when I connect my FE-8 my FW-1884 does´nt find the FE-8, and sometimes makes my PC to make the "bluescreen"

My system is like :

Wndows 7 home premium service pack 1
Intel(R) Core(TM) i7-2700 CPU @ 3,50GHz 3.5GHz
RAM 16,0 Gb
CUBASE 6.5 Artist

Is there a version that I should use to get my FE-8 installed or does the 1.80 have all the drivers that the FE-8 needs to setup automaticly.

Ont thing I haven´t tryied out yet is buying a couple of new firewire cables, But I´ll try that that as soon some shop opens its doors.

Some notes I have made that when I try to start up both the FW-1884 and the FE-8 the "firewire! leds are blinking in a specific rate as 0000000-00 , that means seven blinks, a pause and two blinks. What does that indicate?

So this is my sad story, I´ll soon give my left arm to get my system going. Anybody please give me some advise.

best reg. JOHAN
Hi there,
I hope you connected FE-8 directly to FW-1884, right? Do you see the FE-8 in the control panel of FW-1884?
Thank you Yamahadrums!
I have tryied even that one but no connection and no FE-8 in the controlpanel.
You didn't answer if you see the FE in Tascam's control panel. Is it there?
Keep in mind, that only one of the 2 ports on the FW-1884 is for FE-8.
No FE-8 appears in the controlpanel but the firewire leds just keep on blinking so something is happening. I have to send the FW-1884 and the FE-8:ths to the Tascam importer for inspection because its either the FW-1884 motherboard or the firewire cirquit that causes the problems.
Many thanks for youre support and lets hope for a happy new year!
Change the driver for Tascam FW-1884 to Windows Legacy Driver in the Device manager. Very often this fixes the problems.
I have the proper drivers because the FW-1884 is working fine, it just can´t find the FE-8 modules.
The last thing I can suggest is factory reset FW-1884. I know it's working fine, but this helped me many times. For a hard reset on the FW-1884, its press PAN, FLIP, AUX3, AUX4 and simultaneously power on.
Tryied that one too but nothing seems to help so they promised to fix the whole thing by the importer, so I´ll let you know the results of their fixing session. I am prepared to pay a few hundred euros because I like the FW-1884 and it has been my "best friend" for many years.

Here is a link to my music done with the FW-1884 if you wanna listen, It´s a one man band system cause I do all the stuff by my self in my tiny homestudio :)
The site is in finnish language but the player is familier, just press the |> play button


Sorry to hear that. At least your music is good. What drums are you using?
I recently had the same issues. It was a bad FW board. Not cheap. But I really have loved the fw1884.

Since my most recent problems, I have also changed computers (Win7 home) and I cannot get the faders to respond. Plays back audio fine. but shuttle controls, faders etc. are not responding.

Any ideas?
Did you try to switch between different modes: Native, Mackie, HUI...?
Yes, I have tried that several times. I don't really see any changes. None of the faders nor shuttle controls work in any mode, and yet the master fader works in all. I suspect that's because it is just seeing the FW1884 as an "interface" and not a controller.
i have 2 x FE-8's on 1884...works fine but be advised NEVER hotplug ANY firewire cables...ONLY when all power is OFF. I purchased this FW1884 with a blown firewire interface chip resulting in someone hotpluging it. the chip is basically connected directly to the interface pins (no protection) so im assuming the FE-8's use a similar design. TEAC/Tascam can repair for a reasonable fee. hopefully is just bad cable in your case.
Once I upgraded my DAW to Audition CS6 - all is well. I learned the hot swap Firewire lesson the hard way a while back. Another caveat: I use TRS patch bays. NEVER plug in patch cable with phantom power on. Burned up a few mic preamps in the FW1884 doing that. Still like the damned thing, though.
Hello, new member here. I have been using the FE-8 times 2 for years. The only way I could get my FW-1884 to see the FE-8's is to use a fire wire card that has a TI (Texas Instruments) chip set. they are not expensive and easy to find on the web. Be careful with the bandwidth. I had to buy another TI fire wire card when I added the second FE-8. It worked with the one but was not stable. I was to close to the bandwidth limitation. Hope this helped.

New threads

Members online

No members online now.