FW-1884 doesn't boot


New Member
Nov 19, 2012
Gear owned
my FW-1884 doesn't boot anymore, the button 'computer' is blinking and nothing else, even with nothing pluged.

it happenned after I started using it with my new macbook pro.. I made it work under windows 7 (64 bits) since there is no drivers for mountain lion.
It worked good but sometimes the sync was lost when I decreased too much the buffer size (<256), and then impossible to sync it again until I hard reboot all the system. It worked good with a buffer of 512, for about 30 min with cubase 5, and then it crashed again, but definitively failed to reboot..

Is there a documentation about error codes of the device (fast blinking buttons, etc..) ?
Welcome to this forum.

I am not aware of anything to help interpret the codes.

I don't know anything about using the FW-1884 on a Mac, but to get help, you should tell us what version of the OS you are using. Also, you can check on the Tascam site to see if they made a driver to support your version. Tascam announced they will go no farther with drivers on this discontinued unit.

Are you running Windows under the Mac OS? Using Parallel or something like that? As far as Windows, those buffer sizes sound way too high. I run at 128 or 64, and I have an older Core 2 Duo-based PC.

Have you tried another firewire cable, to be sure yours is good?

On the PC, were you using a firewire card with a Texas Instrument chipset, such as one that Adaptec makes? This really does make a difference with the FW-1884.
hi, and thank you for reply

yes I saw that there is no driver for lion and mountain lion, and i used it with windows 7 (64 bits) installed on a separate partition for that purpose..

the problem is that now, the fw-1884 doesn't boot at all, even without any firewire or anything plugged in ! it keeps the 'computer' button blinking and nothing else.

I don't know if I can find some support since the product is discontinued
There are one or two ways to reboot the FW-1884. We used to have this prominently on the original Tascam User Forum but I don't know where it might be on this new site. I'll look around.

New threads

Members online

No members online now.