****Help Please*** Tascam 133 Blinking red LED


New Member
Mar 3, 2023
Gear owned
Tascam 133 tascam 234
I was fiddling about with it today and went to turn it on and got a blinking red LED (record button) on the control panel. Now none of the play functions work. I checked all the wiring and connectors and all seems OK. Is this a fault warning? And what's usually the culprit? The thing worked great up until this. There was a relay that was added on by the previous owner that was bypassing the weird waka remote control plug via an xlr plug. I have removed that but still blinking. The relay had been clicking when I was pushing and moving wires and one time the transport started working as it should. But when I tried to isolate the problem It went back to blinking. Its a bit frustrating, but I don't think I blew a resistor or a board because it worked fine at one point troubleshooting. Any of this ever happened to your Tascams transport before?

New threads

Members online

No members online now.