M24 Turns On, USB port will not light up

Discussion in 'Model 24/16/12' started by Angelic.Chorus, Sep 14, 2020.

  1. Angelic.Chorus

    Angelic.Chorus New Member

    Joined:
    Sep 2020
    Messages:
    1
    Likes:
    0
    Gear:
    Model 24
    And apparently freezes at the Model 24 Tascam screen. Restarted with new firm ware on a clean SD card. Tried to hold down the Jog wheel and play button (I think) to reload off the SD card and new firmware. studio one will not see it and I can’t get to the recording controls. Just seems to freeze. Any ideas? Bought from Sweetwater less than a year ago. I think it may be a warranty repair. Either that or I’ll buy a Presonus SX32. Can’t believe the fracking thing died. Again, any ideas?
  2. -mjk-

    -mjk- Moderator Staff Member

    Joined:
    Oct 2018
    Messages:
    1,488
    Likes:
    738
    From:
    Hukou Township, Hsinchu County, Taiwan
    Gear:
    DP-32, | 2A Mixer, A3440
    Sorry you're having issues.

    There is a lot going on here. For troubleshooting purposes, please confirm what you did.

    You say it turns on, mention the USB port and then say you "Restarted with new firm ware on a clean SD card." So, finding the USB port not functioning, you tried to update the firmware? Or, you tried to update the firmware and then the other problems occurred?

    There is an issue with trying to update from firmware 1.0 because it doesn't support cards over 32gb. SD cards seem to cause multiple issues: https://www.tascamforums.com/threads/sd-card-“invalid-card-change-card”.7604/#post-36164

    You can try removing the SD card to see if the unit will start up normally.

    There are reported issues with the Model 24 freezing on the startup screen: https://www.tascamforums.com/threads/frozen-screen-hard-reset.7292/#post-38426