MIDI Rx Framing Error


Oct 17, 2012
Lancaster, PA USA
Gear owned
DM3200 UH-7000 3030R2R
See attached picture. I've seen this before, but have been able to cancel it by hitting enter. Now when I hit enter, it cycles to the next error number. It will do this continually through all the errors, cycling back to the first one. I cant get rid of it. USB cable is fine and Tascam Companion sees the mixer (that's how I go the screen shot). FW cable is fine and audio passes through fine, but I cant make any adjustments in the display with the error message in the way.
Any Ideas?


  • Rx Framing Error.png
    Rx Framing Error.png
    6.9 KB · Views: 27
Call me today and we can troubleshoot
Thanks Charlie. Good find! I wonder if Tonepad is still on the forum...

It seems the first idea from that post was to pull the FW card and air blast the midi connector, and clean/cycle the connector with a midi plug. I'll try that this afternoon.

The second idea, which I found by our troubleshooting, also seems to work, but feels like a workaround...For me the message appears immediately when the board does it's initial lights/faders test after turning on. Specifically, when I first throw the switch, I see a normal blue screen with the static "TASCAM" and the notes/staff image. But as soon as the screen goes to the sliding TASCAM display, and all the lights test and go out, that's when I see the MIDI Rx framing error. As discussed on the phone yesterday, quickly tapping the RECALL button, just to the left of the CF Card slot, gets rid of the error message, allowing me to do everything I need.

With the error message out of the way, I did what Tonepad did from that old post back in 2012. I created and stored a new Project on my CF Card, which included opening the virtual MIDI IN (MIDI IN since the framing error is labeled as Rx (receive) and not Tx (transmit)) connections on the MIDI page . This did the trick!...kinda...

Now, when I turn on the board, I still get the message as described above, but then the board loads my new project from my CF Card automatically, and the error goes away and I am back to normal.
Since the board is reloading a project from my CF card, and not internal memory, could this be an issue with my internal memory?

I have a few more tests to do. I would like avoid the several hundred dollar shipping cost and the several week time away from my DM if I can.

Big thanks to Dr. Cmaffia (Phd. in Electronious flowisious) for helping me yesterday. I'll post with more results.....If anyone has some ideas, please post.
I reached out to Tonepad on LinkedIn for you so I will let you know his response.

Tonepad says he reformatted his CF and THEN saved to it to fix his problem.

In addition to pulling out the FW card, what about trying what RedBus suggested and open the DM3200 to see if there's a loose connection where the internal MIDI ports are?

What sucks is that you can't initialize the board to factory settings because the error message overlays itself even over the diagnostic screen making it impossible to hit enter on any of the diagnostic choices...
Last edited:
A couple more tests to help pinpoint the issue.

1) I was able to close the virtual MIDI in connections on the midi page. That's a good thing. I shutdown/restarted and everything came back as described above, but the error went away when my CF project was loaded.

2) To check the internal memory, I pulled the CF card out of the slot and shutdown/restarted. Bam...the error message is back full time. Hitting the RECALL button got rid of the error message again, but created a momentary new message in the error message's place...."EFFECT...Preset 1-080 recalled to Effect1" and then the message goes away and I am running normally with no error messages. Hmmm... not sure how the effect presets are related to the issue.

Anyway, once the message was gone, all of my routing is back to where it was when I shut down the board without the card inserted, which means that the board is able to save to and recall my routing setups from internal memory.

More test to follow.
That's true. I can't do a factory reset from the diagnostic screen because the error message is sitting on top of everything. I have jog wheel control, but hitting enter just increases the error code number.
I wonder if there is an alternate key for hitting enter to choose a parameter...
I went around the back of my desk intending to pull out my FW card, to see if I could isolate the problem to either the FW MIDI or the internal MIDI. Upon inspection, I realized I had an old midi cable plugged into my MIDI IN port on the back of the DM. It was plugged into an M-Audio midisport 4x4, which I use to control functions of certain digital pieces of digital equipment via software over midi. But I typically don't run anything midi-wise to/from the board via that port , so I pulled the plug out and restarted. NO Message! yeah. All is right with the world again. Thanks again for your help Charlie. Time for breakfast!
  • Like
Reactions: captdan and cmaffia
Friggin awesome!!!!!!!
I wonder if Tonepad is still on the forum...

Wondered that too, recently. He is/was involved with audio post on a major tv drama series and his input here was quite valuable.

Charlie - if he responds, tell him he's missed here....ASSuming he still drives the 'Tascam Bus.' :)

I am having this same problem but the removal of midi leads hasn't solved it.
I have an error message - MIDI Rx Framing Error (E214). Press Enter to continue.
When I press 'enter' on the desk, this only produces the same error message but with a higher number.
I think this error message was caused by a midi lead that was connected to the back of the machine and is now disconnected. However I'm unable to get rid of this error message and reboot the machine. I can switch the machine off but it restarts in the same state. I've booted into diagnostic mode but I can't reset the desk to factory default because this error message is still present and doesn't allow me to use 'enter'. I'm pretty much locked out of the machine. I've also updated the Firmware using TMCompanion but the error message is ever present.

I've also reformatted my CF card as suggested by Tonepad via cmaffia above, and tried every aspect of 'saving it' I can think of. Not entirely sure what 'saving it' really means in this context.

Would really appreciate any help!
Pull out all expansion cards and see if that does anything
I'm afraid not. I've tried disconnecting everything. I've also switched the desk on without anything it's connected to being switched on. Error message is constant.
If only I could shut the desk down properly and reboot, do you think that might help?
Have you powered off and disconnected the power plug? Where was the MIDI cable plugged into that you said earlier you used to have one plugged in? Did you try inspecting or cleaning that midi connector with contact cleaner?
  • Like
Reactions: Emyr Rhys
The midi lead was connected to MIDI OUT on my RME card in my mac. I have used this in the past to display timecode on the meter bridge (with my old DM24) but I don't think I was able to get this to work on my recently acquired DM4800 and gave up. The midi lead was left in the in port but didn't cause any difficulties. Removing it hasn't cleared this error message. I've also loaded new RME drivers and driven time code at the desk to see if it will respond but nothing clears this error message. I've also tried to reboot by holding down the ALT+STOP+PLAY. The desk will not respond to this. It's waiting for me to press ENTER but ENTER just generates another iteration of the same error message. With the ENTER button tied up like this, there's very little I can do.
As the midi ports are basically simple digital connectors I'm reluctant to use contact cleaner. Also tried changing the midi lead - nothing.
@Emyr Rhys Allow me to chime in. I have experienced this error message on a few occasions (very few). But, I was able to identify the cause and was able to rectify the issue almost immediately. I record to an external DAW (Soundscape Red32) via TDIF. If I don't power on my equipment in the proper sequence I am sure to see the "MIDI Rx Framing Error". And, I too will continue to see the message with incrementing error codes if I keep hitting the enter key. If I power up in the appropriate sequence (always powering up my external DAW first) followed by my PC, etc. I never see the error. Perhaps, this may seem totally unrelated to the problem that you are having but I thought that I'd throw it out there anyway. Best of luck! Peter
  • Like
Reactions: Emyr Rhys
Hi Peter.
Thanks for your input. I usually power up in that sequence but I gave it a go anyway. No luck I'm afraid. Over the weekend I sent a message to Tascam UK tech support, and I received the following reply this morning (fair play)...

Thank you for contacting Tascam U.K.
There is a data communication port on the main CPU that is locked in communication with another peripheral hardware device on the main PCB- hence the Error message and unable to select ENTER in diagnostic mode.
Try removing the internal battery and leaving the unit off for a couple of hours.
If this does not clear It, then you are looking at a new main PCB.

This all makes sense, so I'll give it a go. I can change the battery at the same time. I'll let you all know how I get on. Anybody know what battery I need?
  • Like
Reactions: Peter Batah
Hope that works. Fair warning, unless you can find it used and install it yourself, the Main PCB from Tascam plus installation will cost more than half of what the console is worth. Not sure what battery is used. My guess is a CR2032 but once you remove the battery you'll know for sure. There's a Main PCB on eBay for $300 but beware as it was "pulled from a DM3200" and we've learned that although they are the same board, there are chipsets (in addition to the firmware) programmed differently than the DM4800 and will not work correctly.
OK - thanks for the heads up. I'll probably tackle this towards the end of the week. Wish me luck....

New posts

New threads

Members online