Please help me.. US-144

Lachlan Webster

New Member
Oct 24, 2014
Gear owned
Hi all,

I plugged in my mic for the first time in a while yesterday (it had been being repaired) and set about recording. Worked fine for the first hour or so, but then I started having troubles.

I just can't get a signal from the mic. I know it's not a problem with the mic, because my signal lights up on the Tascam itself when I speak into it.

I think it must just be a driver issue. I'm half suspecting that the problem might have arisen after I tried to use both the US-144 and my computer's stock soundcard at the same time. But that was only after the headphone out on the US-144 started playing up.

I'm running Windows 7 Professional 64-bit with Cubase 5 LE.

I have been using the Tascam drivers, latest ones for Windows 7.. I've also tried with ASIO DirectX Full Duplex. Also ASIO4ALL, but my computer doesn't like it. Get the Black Screen of Death.

Any help would be so much appreciated, I really need to get this thing up and running in the next couple of days. Let me know if you need any more information/screenshots.



New threads

Members online

No members online now.