Problem with Lacie D2 External Firewire Drives

Oct 26, 2012
Gear owned
I thought I'd just document a problem I had with 2 newly acquired Lacie D2 drives when I tried them with the X48. The drives were the 200Gb and 300Gb versions which I got from Ebay.
When I initially tried them on the X48, they were not recognised within 'File Manager', nor 'Drive Benchmarking' but did show up in 'Disk Management' although they couldn't be formatted or anything else done to them.

I was reading under 'V1.20 changes' that 'the unit sometimes would not recognise a hard disk accessed via a Firewire hub' , so wondered whether this was the problem. When I bought my X48 it had I think 1.04OS on it which I upgraded via pen drive to 2.02. I hadn't gone through 1.20 so any drivers supplied on that update might be missing on my install. The Lacie D2 external drives have 400 and 800 Firewire ports as well as a USB2 port. The drive again were not recognised via USB2, although I have used other drives pen drives and a Seagate 1Tb drive over USB2, so I knew the ports themselves were ok.

The fix for this required a full OS install from the V1.20 OS disk (which I didn't have), so I contacted Redbus at Tascam. He very kindly pointed me to the Tascam site where it is located. He also suggested formatting the drives as FAT32 which I did with Partition Magic. I then upgraded the OS to 2.02 via pen drive.....and tried the drives again.

They still didn't work but I noticed even after formatting they both had a prefix after the drive name in brackets GPT protection partition. After Googling this I found this:

How to remove the GPT Protective Partition in Windows XP.

Occasionally you might find yourself unable to initialise or format an external hard drive with a GPT (GUID Partition Table) Protective Partition. There is a quick and easy fix to this problem, and only requires a few simple commands at the Windows Command Prompt:

1 - Open the DOS Command Prompt Window (Click on "Start", then "Run". Type "cmd" in the text box, then Click OK)

2 - At the Command Prompt, type "diskpart"

3 - Type "list disk" at the DISKPART Command Prompt

4 - Make a note of the Disk Number that you wish to remove the GPT Partition from

5 - Type "select disk 1" if disk 1 is the GPT disk

6 - Type the command "clean"

This will remove the GPT partition from the selected disk.
7 - After this, type "exit" to end the Diskpart command line.

I did this and the drives then started working as they should in the X48. I hope this might help someone in the future. Thanks to Redbus for his help in getting this sorted.


New threads

Members online