Switching between Mix and Edit PT9

Yes. But first you have to be sure you've set up your HUI/ProTools parameters correctly. If so, the Edit/Mix windows are accessed on the DM's machine control section using the F8 key to toggle between them.

Most all of the other functions are available as well - including looping using the 'Repeat' key (yellow light on when enabled.) However, I've found that certain functions require that the Shift Key be used in conjunction with machine control keys - for example, scrolling through the Mix channels using the 'Bank' keys.

CaptDan
 
Should be a some info in the 'Documentation' section.

However, it's pretty straightforward: set up your HUI in ProTools, choosing DM3200 in one of the device boxes. (If you have other devices, say, a TransPort, you'll need to set these up in their own HUI boxes.) Choose PT in your DM's machine control menu, setting up two Mackie banks -1 thru 8; 9 thru 16 (if 3200), and a 3rd bank 17-24 if using a 4800.

Automated mixing is a little more involved; you'll need to choose INTERNAL as the MTCode in the DM, but disable that when doing routine tracking with PT. Not in front of my machine right now, but I can provide details if you need them.

Except for not having touch-control/SELected faders in the Remote Layer, the functionality is fairly rock solid.

CaptDan
 
As promised, here are the steps for setting up automated mixing with PT9/10:

First, you'll need to add a separate config in the DM's MMC menu: Generate Internal TC. This is added to the 'HUI/Mackie control' selection which has the Transport Record option. Essentially, you switch between HUI and Generate Internal; the former for routine tracking when PT is set to GENerate timecode; the latter for automated mixing. (This can also be done using Snapshots.) Protools requires that it be FED timecode from the master device - ie - the DM - when performing lockstep tasks like auto-mixing. Otherwise you'll get nasty contentions like 'YOU'RE RUNNING OUT OF RAM! Or: DAE IS OVERSTRESSED! Neither of these warnings is true, but the moment they pop up, everything stops.

The downside workflow-wise is, when Generate Internal is selected, you don't have the RECord key available on the transport Icon. But that shouldn't matter, because you've already completed tracking prior to mixing anyway.

Next, you have to DISable GENerate Time code in PT. Then go to the Devices menu, and enable External MMC by ticking that box.

Finally, on the DM's Automated mixing menu, tick the box that states: 'Internal Time Code.' You should now be set up to write automated mixing moves with minimal lock up time. If you experience any issues in that regard, there's a feature in Protools where you can adjust the 'freewheel,'.

Also: Protools is chasing to the DM's timecode. Therefore you need to ZERO OUT the DM's timecode counter. Otherwise, if you have -say - 00:10:10:23 on the DM, Protools will immediately jump to that number on the time line. This can be very frustrating, so zero out, and start from the beginning of the project.

When you return to tracking mode, you'll need to invoke HUI/Mackie, disable internal timecode on the DM, disable MMC in ProTools, and choose the GENerate TC on PT's transport menu. This gives you back your entire DM control surface, including the RECord key. A bit of a hassle, but not that big a deal.

I hope I didn't leave anything out. If so, just holler if you run into trouble, and I'll retrace my steps.

PS: I wouldn't have figured out any of this without the able and patient assistance of the great Jamsire - Ernie Jackson - who spent untold hours with me on the phone last year. Thanks again, Ernie!!!

CaptDan
 

New threads

Members online

No members online now.