Tascam 32 VU meters malfunction

Discussion in 'TASCAM Analog Forum' started by Willl, May 26, 2020.

  1. Willl

    Willl New Member

    Joined:
    May 2020
    Messages:
    2
    Likes:
    0
    Gear:
    Tascam
    Has anyone experienced a new problem I see here -- my Tascam 32 2-track recorder suddenly doesn't have working VU meters. All connections to PCB boards appear to be O.K. Everything else works fine. Any ideas?
  2. SkywaveTDR

    SkywaveTDR Well-Known Member

    Joined:
    Feb 2014
    Messages:
    1,068
    Likes:
    222
    From:
    Chicago area
    Gear:
    Teac, Tascam, Sony
    The only meters I have had trouble with are the 22-4 which were a very cheap designed meter.
    Meters can give reading sometimes due to static charge- there is nothing wrong with the meter and the charge can be taken away by some Windex cleaning the cover that discharges it. I have done it many times. Other problem I see is when the scale layer starts to spring up and stop the meter from moving. You can see this by looking at an angle. Otherwise on the 30 series the trimmers they used are not Cermet and that can help- I put some Bourns Cermet trimmers on to upgrade the deck at times. The edge connectors can need resoldering and also look for those offending capacitor type I have mention before 10V and Marcon brand. IF you deck does not work right then to say connection appear to be good- what does that mean then?
    Find the problem then you can say what it was. Motherboard problems can be the issue and these decks are not getting any younger. Try switching cards around to see if it follows the card.