TMCompanion connection error


Well-Known Member
Mar 5, 2013
Gear owned
Tascam DM-3200
Hi guys, I'm pretty new to this forum and hoping someone can help me. I just bought a used Tascam DM-3200 with a Firewire MkII card and when I install the TMCompanion Version 1.51 for windows 7 this is what I get when I click on the tascam icon on my desktop. The error in full is as follow:

"Connection error" No compatible mixer was found. Please check usb connection with mixer.

Another thought:

If the DAW is booted up, TMC can suddenly become unavailable. There's probably a workaround, but - as they used to say about gold in 'the Old West' - 'I ain't found it yet."

Hi guys,

Yes I did check my usb connection as it doesn't show a problem in the device manager. I do see in the I/O settings in protools the ins and outs 32 channels including the buses etc. Do I need to re-install protools 10?
I wouldn't reinstall PT10 just yet. (It's a huge pain and should only be undertaken when all else fails). Besides, the 'busses' and I/O pertain to the ASIO/firewire channels; USB has nothing to do with that.

As I mentioned earlier, I experience the same issue when PT10 (and even its predecessor PT9 as well as my long-gone Cubase). It only happens when the DAW is resident; at all other times, TMC is available.

TMC runs by default on its proprietary USB1 port. It MIGHT be that your DM's MIDI settings are somehow interfering with USB1. The way to check that is to go to your DM's MIDI page, and study the 'flowchart.' (I call it the 'plumbing schematic.') Trace the in/outs to/from USB1. You'll see 'TMC' at the upper right, and where it connects in the scheme. If you discover something also connected to USB1 (unlikely), disable that connection by cursoring over it and hitting ENTER.

More likely: you PC/Operating System is 'hijackin' USB1 for some other purpose. Check in the Devices/USB menu - going into the 'Advanced' settings to see what USB ports are assigned and where.

Short of that, I have no other suggestions; I've simply used TMC before or after running ProTools. TMC just isn't available otherwise, and I've yet to find out why.

Thanks Captdan I will definately look at this tonight and let you know my findings.

Thanks for your feedback and help.
Like CaptDan, I also have never gotten TMC to start up while the DAW is running - it will however remain functional if started before the DAW.

Another thought (I seem to remember this 'no mixer found'): Which firmware version does your DM have? Should be 1.61 IIRC..
Hi Captdan, I looked into the midi setup page on the tascam and the TMC is set to USB1. It goes upto USB 6 in the tascam with other settings to their own USB port. Is it only the TMC USB1 that needs to be set to USB1?

The other part of your answer where you mention it could be the computer in device manager but where do I see what ports are being used?

I’m having the same problem with the TM Companion software. I seem to only have the problem with windows 7 64Bit? Works fine in windows XP 32Bit?
If you see USB 1 connected to USB6, disable that connection. USB6 would likely be used by something else; if you were using a DM4800, USB6 is utilized for a HUI extension.

As to checking USB device portals: right click on the device icon, go to the 'Advanced' settings, and click on it. You should see what port is assigned to that device.

Finally - I suspect that Win7/64 does funny stuff behind the scenes with USB and 'plug-and-play.' Can't say really what's going on, but it's annoying sometimes.

Strange, I have a DM-4800 connected to a windows 7 64Bit PC. Now I have tried removing all USB devices connected to the pc except the DM-4800 and still no luck.

I checked the USB/Midi settings in the DM-4800 and TMC is connected to (USB-3). What is strange is when on the same computer running win XP 32bit with all of the same settings the TM Companion works fine? But for some reason when under WIN7 64Bit it does not work. I have not tried win7 32bit.

In win7 64Bit when I launch the TMC app I get the splash screen and then it goes away and does nothing but when I look in the task manager under “Possesses” it shows the TMC as running?

I hope someone comes up with a solution for this. Tascam says that the TMC is compatible with win7 32 & 64 bit versions but not for me?
Please check your mixer firmware. it needs to be at the latest version, otherwise no luck on Win7-64. Also, if you have the IFFW card, its driver on the PC needs to be latest update, 1.21.
my firmware is 1.10version but I will not be able to get the latest version without the TMC working. Isn't this where you connect to go get the updated firmware?
Hi Hammadejam2013 what version of TMC did you install? what tascam firmware are you running?
TMC is 1.51.
DM-4800 Firmware 1.70
IF/FW MkII 1.21.
Basicaly all of the latest updates.
Windows 7 64Bit with latest service packs.
Hi hammadejam2013, my mistake yes I have the same thing as you and I got my TMC working. All I did was plug my tascam usb into my other computer with win xp and it worked right off the bat. Then I put it in win 7 computer and it didn't recognize it, so what I did afterwards was I used a shorter usb cable and plugged into my hub on my desk and opened up TMC and voila. Now I guess I need to work on the routing aspect.
The shorter cable is the only thing i have not tried yet. I will keep you posted and let you know if that works.
Same problem here. But It looks like I found a workaround for cubase and I think the problem is the DAW that loads DM4800 midi driver device (USB1) so that TMC cannot find its native port. If some of you would like to try in cubase device setting uncheck the midi device DM4800. Now I can open cubase and TMC and have the two working fluently.
But I cannot do it in PT10. Is there anybody Who knows how to disable a Midi device in PT?
PT10 is a mystery. Although I show no USB1 portals assigned in the Peripheral/Device menu, TMC won't load when PT is resident.

I just use both apps separately; not a problem for me, but likely a problem for others - especially those who don't have the DM meterbridge.

Hi guys,

I've update my macbook pro iOS lion to yosemite… I've installated IF-FW/DMmkII V1.30f10 and works fine, my card is locked , I've updated dm fw to 1.72 and use tmc 1. 7 but my mac can't see any mixer connected….how can get it work?? thx best regards

New posts

New threads

Members online

No members online now.