US-122MK2 not recognised by MAC with Mavericks OS


New Member
Dec 28, 2013
Gear owned
Hello there

I have a MAC with Logic, the Apple music recording suite

I just went from the Snow Leopard OS to Mavericks, and since then, I have problems

The US-112MK2 works well with Logic (versions 9 and X as well), but this gear is not recognized anymore by the MAC as a standard sound output (path : system preferences / sound / output) for - by example - listening to iTunes.

In the window "system preferences / sound / output", the US-122MK2 was well recognised by its name with the Snow Leopard version of the MAC OS.

Not anymore.

I installed again the Tascam pilot, but it changed nothing.

Did somebody met the same problem?

Hey Tascam guys, what do you say?
Same problem here!
Waited ages for the mavericks driver installed it successfully however no playback from mac. The interface shows up correctly in the sound section of system preferences as well as in logic (bit accurate + core audio) but still no computer audio(Safari/Itunes ect).
So far I have tried reinstalling the mavericks driver several times, PRAM and SMC reset, different usb cables, setting it up in audiomidi utility and updating its firmware to 2.03..... still no luck.
The only sound from the interface its through its direct input straight to the head phone or line outs.
The unit has sat on my desk since the mavericks update so I doubt its spontaneously developed a fault. Am I missing something or do I have to wait for tascam to release an new updated mavericks driver :shock: :shock:
ok BT, any idea of how to get TASCAM interested by this problem and work on a update of the driver?
I'm hoping that tascam reads these posts, I'm also going to email the directly. Has anyone had any luck with the Us-122 or Us-144 on the new mavericks driver ?
I too have exactly the same problem-no sound output or input where is before when I was using snow leopard with logic pro 9/Garage Band I had no problem at all. I was hanging out for the drivers to come out so I could go and use Logic Pro X as I could not use that on Snow Leopard because I had to have at least Mountain Lion (which I didn't have), so thought I would wait for updated drivers for Mavericks, but am totally disappointed. Am thinking I may just give up on Tascam and go for the Apogee Duet (as is recommended by Apple for these music programs) as they seem to be more on the ball with their updates. But, it is a little pricey.

Has anyone at all had any luck with Mavericks/Logic/ Tascam US-122MK2?? If I can save my money on not buying another MIDI interface, I will.....
Going to the downloads page I've noticed that they're named beta drivers meaning that they're still in a testing phase, i would give it a couple more weeks before giving up to buy the apogee duet. I'm worried they haven't issued a release date for the full driver though!!
With the beta driver I've seen reports of "input works, output doesn't". If this is what you are seeing as well, please use the contact us page

and tell them the exact model of Mac you are using. Mac Mini, Mac Book Pro, iMac are all behaving differently, and different years are causing different problems. Apple is also looking into this, even Apogee has said they are seeing problems, so it must be on the OS side as well.

These forums are user-to-user, TASCAM does not watch them or provide end user support through them.

Ok I have just uninstalled new drivers, and installed old driver for snow leopard and now playback works as well as input of virtual instruments! Go figure??? According the Mac Rumour forum this is what some people have done. But cannot get the mic working though, so still wondering about that one....
Actually, nope I just got the mic to work by flicking the phantom switch on interface from off to on.....So I see no need for a new driver for Mavericks at this stage.....Weird!!!

New threads

Staff online

Members online