US-200 not working with macOS Sierra


New Member
Sep 26, 2016
Gear owned
Hi Guys !
I just uploaded my computer to Sierra, and the OS doesn't recognize my US-200 interface.
Since the US-200 is already discontinued,
are TASCAM releasing the Drivers for the US-200 for Sierra ?
So what options do we have? Without the proper driver, are we just left to downgrade to El Capitan?
I had the same problem with my US-1641 but I did find a solution which may work for other units such as the US-200.

Basically Sierra does not seem to load drivers (kexts for Mac OS) that contain both a 32bit and 64bit binary and, at least for the US-1641 El Capitan kext, both binaries are present. See
Luckily, code signing seems to be done on each binary when it is compiled and removing the 32bit version allows the kext to be loaded.

The following steps worked for me but obviously your mileage may vary.
Usual disclaimer: I accept no responsibility for what may happen to you, your computer, peripherals or anything else that may occur from following these steps. Use strictly at your own risk!
Messing up with kernel extensions could prevent your machine from booting or cause crashes so make sure you have all work saved, a backup and are ready to restore/fix your machine from the recovery partition. If your are not comfortable performing the steps outlined, reverting to El Capitan is a safer option.

In the instructions below you will need to replace all instances of 'TASCAM_US1641' with whatever applies to your device.

Open a terminal.

Ensure that you can proceed further by checking that you see information about x86_64 and i386 from the following command:
file /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

If so, remove the i386 binary with the following:
sudo lipo -thin x86_64 -output ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

This will have output a file named TASCAM_US1641 to the desktop which should only have the x86_64 binary.

Remove the orignal:
sudo rm /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

Copy the new binary (thanks to gizabj for adding the missing 'sudo' here):
sudo cp ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/

Try loading the new kext:
sudo kextload /Library/Extensions/TASCAM_US1641.kext

There should be no errors at this point. You can use kextstat as an additional check here.

Now rebuild the kext cache:
sudo rm -rf /System/Library/Caches/
sudo kextcache -prelinked-kernel /System/Library/Caches/ -K /System/Library/Kernels/kernel /System/Library/Extensions

Reboot your Mac, delete that file from your desktop and assuming everything went fine, get back to using your Tascam :)
Last edited:
I had the same problem with my us-200. I tried the Nevirtus solution and it worked!! Thank you very much!
I have got the US-1641 and Sierra, so the usb interface is not working at the moment with my Mac.
I have been trying to go through the process as described above, but can't go through one point..

when I do
'Copy the new binary:
cp ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/'

I get a message: Permission denied.
I'm the admin on the Mac and in 'Sharing & Permissions' for that file (File info) it says 'System: Privilege: read and write', so maybe I should look somewhere else to be able to copy the binary?..

Any help will be very appreciated!
Hi, Mich.
Try adding "sudo" before the command line. Like this:

sudo cp ~ / Desktop / TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/

The sudo command allows ordinary users to gain privileges from another user
Thanks, will try as soon as and if I manage to restore the system as it looks I have messed it up! :]..
Managed to restore the system and this time went well through the process of adapting of the driver as per the instructions.
Ableton Live and Garge Band see the device, but the signal is not coming through the usb.. Any suggestions?
My US-1641 works fine with GarageBand for analog in/out (Bit accurate) and as the system in/out device (core audio).
I had this issue too (where the device is recognised but does not actually work) but it was fixed after clearing and rebuilding the kext caches followed by a reboot.

Some simple things to try though you may have already given them a shot:
Power cycle everything - Mac & Tascam.
Deselect the interface and use built-in, the reselect.

If the device is recognised then the output of:
kextstat | grep tascam
should have an entry for com.tascam.us1641.driver.

Retry this step:
sudo rm -rf /System/Library/Caches/

Then check:
ls /System/Library/Caches/ | grep kext
This should return nothing if the remove command was successful (you can try before and after).

Rebuild as before:
sudo kextcache -prelinked-kernel /System/Library/Caches/ -K /System/Library/Kernels/kernel /System/Library/Extensions

Then reboot.

If you still have issues then I can have a go at retracing my steps to try and reproduce the problem.
  • Like
Reactions: mknrls
MIDI is OK in my US-200 but audio inputs are not recognized by Garageband or Audacity. I tried all the procedures but the problem remains.
Ok, I see there are things to try. Thanks for sharing your experience!
Btw, if I'd like to start from square one, how to clear the system of any trace of Tascam drivers and the modifications described above?.. I'm having another go hoping not to have to spend a 200 quid on a device that I have already got actually... Bloody crooks! ;)
Last edited:
now, when trying to 'remove i386 binary' I get message

'xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun'

I went this path and in the 'usr' folder can't see 'bin' indeed..
Hey Nevirtus, I tried all your steps, including the steps you recommend for those like myself with a US 200 that now does work, but still will not be recognized by any applications. Here's a screenshot of what happens when I rebuild cache: Screen Shot 2016-12-14 at 10.27.47 PM.png Screen Shot 2016-12-14 at 10.31.11 PM.png
Hey Mich,
To begin again I would delete the Tascam kext:
sudo rm -rf /Library/Extensions/TASCAM_US1641.kext

Then rebuild the kext cache and reboot. You can then install the El Capitan kext.

As for the error when trying to remove the i386 binary, try this: xcode-select --install
Hey Razvans119,
The error you get when rebuilding relates to another kext - AppleMobileDevice.kext. Check whether the kext cache now exists (I suspect that it will). In any case, you may want to look into removing that kext.
If you can set the US-200 as the main output then when you use say iTunes, does sound come from the US-200 but not when using something like GarageBand?
This works perfectly as long as you include the sudo on the copy new binary command!

Thanks very much
Hey Nevirtus, thanks for your post. Actually, sound doesn't come out of the tascam no matter what program (itunes, garage band, youtube) - youtube videos wont even begin to play until I unplug the us-200. And it did work perfectly before the sierra update. You think it has to do with that broken apple kext? I'm not sure how to remove that. What else would you suggest? Thanks so much!
@Nevirtus what would be the cause of this below:

iTunes, Youtube etc (CoreAudio)

GarageBand detects the interface but no audio coming out of it (doesn't matter if is on CoreAudio or BitAccurate). Also causing audio to not work after been close, requires a reboot and sometimes unplugging /replugging the usb connection.

New threads

Members online

No members online now.