US-200 not working with macOS Sierra

Hi,i followed all the process, but when i tried to rebuild kext cache i got this error!

MacBook-Pro-de-Salva:Volumes salvaromanelli$ sudo kextcache -prelinked-kernel /System/Library/Caches/ -K /System/Library/Kernels/kernel /System/Library/Extensions


String/URL conversion failure.
Man, Nevirtus, you're a KING!!! thanks a lot. works perfect!
(I have a tascam 1641)
tell me your PayPal account please.

I just bought an US-1641 and was concerned that I'd have to sell it again, because it wasn't recognised in Sierra.

I followed your instructions and it works perfectly! Thank you!

Although, this last step gives me this error:

Prelinked kernel directory '/System/Library/Caches/' cannot be used

When entering the command again, it starts rebuilding the cache and there is a set of errors>

String/URL conversion failure.

AppleDataSetManagement.kext - dependency for lacks valid OSBundleCompatibleVersion.

AppleDataSetManagement.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)

AppleDataSetManagement.kext - dependency for lacks valid OSBundleCompatibleVersion.

KernelCache ID: (edited out)

String/URL conversion failure.

Nevertheless, the US-1641 is being recognised and works perfectly.

I just don't understand why Tascam didn't make this small workaround for Sierra.

Anyway, thanks a lot for your instructions on making it work!

I had the same problem with my US-1641 but I did find a solution which may work for other units such as the US-200.

Basically Sierra does not seem to load drivers (kexts for Mac OS) that contain both a 32bit and 64bit binary and, at least for the US-1641 El Capitan kext, both binaries are present. See
Luckily, code signing seems to be done on each binary when it is compiled and removing the 32bit version allows the kext to be loaded.

The following steps worked for me but obviously your mileage may vary.
Usual disclaimer: I accept no responsibility for what may happen to you, your computer, peripherals or anything else that may occur from following these steps. Use strictly at your own risk!
Messing up with kernel extensions could prevent your machine from booting or cause crashes so make sure you have all work saved, a backup and are ready to restore/fix your machine from the recovery partition. If your are not comfortable performing the steps outlined, reverting to El Capitan is a safer option.

In the instructions below you will need to replace all instances of 'TASCAM_US1641' with whatever applies to your device.

Open a terminal.

Ensure that you can proceed further by checking that you see information about x86_64 and i386 from the following command:
file /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

If so, remove the i386 binary with the following:
sudo lipo -thin x86_64 -output ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

This will have output a file named TASCAM_US1641 to the desktop which should only have the x86_64 binary.

Remove the orignal:
sudo rm /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

Copy the new binary (thanks to gizabj for adding the missing 'sudo' here):
sudo cp ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/

Try loading the new kext:
sudo kextload /Library/Extensions/TASCAM_US1641.kext

There should be no errors at this point. You can use kextstat as an additional check here.

Now rebuild the kext cache:
sudo rm -rf /System/Library/Caches/
sudo kextcache -prelinked-kernel /System/Library/Caches/ -K /System/Library/Kernels/kernel /System/Library/Extensions

Reboot your Mac, delete that file from your desktop and assuming everything went fine, get back to using your Tascam :)
hi! I have a tascam us-200, I tried to follow the procedure but I can't have the permission (I'm talking about the first step) what can I do? thank you so much
Any chance to get this working on High Sierra? I have a US-1641
I also have the US-1641 on High Sierra, any fixes? I've tried Netvirtus instructions but after restarting my mac wont boot and i have to restore to a previous time machine
Anyone got any news for High Sierra? I'm not really too hot on going through Nevirtus’ directions if there’s a danger of bricking my macOS installation.

I have the US-200 and I'm extremely disappointed by the lack of support for this. When I bought this, it seemed to be the newly developed alternative to the older US-144mkII. Yet here we are, the aforementioned is still supported, while the US-200 is not.
Hi! I'm having Fireware Issues with a Tascam DM-4800 (With a if-fw/dm mkII expansion card) and OS El Capitan 10.11.6(on a late 2009 i7 iMac). In fact, I would say that the issue is concretely with the expansion card, wich is not detected in its own app. The system says that there is a fireware port (It indicates max speed 800, and It doesnt show the red message saying that there is no device found). We have tested same setup on a Mac Laptop with same El Capitan version and it works fine (It is detected by the expansion card app and also works fine with Logic X) but there seems to be some kind of problem in this one wich we arent able to solve.

Reading all around the internet we've seen al kind of issues and fixes wich didn't worked (restart-reset SMC, and related) and I got to this post but im not very experimented in solving OS/Apple related issues.

How can I know what name do I have to replace in 'TASCAM_US1641' in order to do the same technique with my DM_4800 or with the if-fw/dm mkII?

Thanks in advance, and any suggestion or need for extra information will be provided :).
Hello @Nervirtus and everybody here.

My unit is a US-800 also discontinued, and i had make it work in mac OS 10.9.5 (Mavericks) instaling Asio4all driver or something like that, until yesterday, that i got updated to Sierra O

I`ve never used the terminal before, so i´d ask you to check my "resumen" of the steps you recomended before, replacing the model of the unit:


file /Library/Extensions/TASCAM_US800.kext/Contents/MacOS/TASCAM_US800


sudo lipo -thin x86_64 -output ~/Desktop/TASCAM_US800 /Library/Extensions/TASCAM_US800.kext/Contents/MacOS/TASCAM_US800



sudo rm /Library/Extensions/TASCAM_US800.kext/Contents/MacOS/TASCAM_US800


sudo cp ~/Desktop/TASCAM_US800 /Library/Extensions/TASCAM_US800.kext/Contents/MacOS/


sudo kextload /Library/Extensions/TASCAM_US800.kext

ATENCIÓN: No debe haber errores en este punto. Puede utilizar kextstat como un control adicional aquí.


sudo rm -rf /System/Library/Caches/

sudo kextcache -prelinked-kernel /System/Library/Caches/ -K /System/Library/Kernels/kernel /System/Library/Extensions

Reiniciar la Mac, eliminar ese archivo de su escritorio y asumiendo que todo salió bien, vuelva a usar su TASCAM US-800

Muchas gracias por todo, espero que me des OK para llevar a cabo la tarea.
Thanks! The whole system is being actually revised by another person but I'll pass him this link in case he finds it helpful. Lots of thanks for taking your time :)
Please someone help me out, I have a US-1641, with or without following Nervirtus' guide I get the same issue, where outside of DAWs sometimes it works, sometimes I have to reset it, but in DAWs i get no playback at all, both core audio or bit accurate drivers. The weird thing is that when I first installed it on sierra with the el captain drivers it worked no problem, DAWs or not, then then next day I suddenly started having issues..
I got this soundcard pretty cheap thinking I got a bargain, but I think I'll hato to return this...
Nevirtus, YOU ROCK! I am now able to use US 1641 on Mojave! I wasn't able to clear cache, but it worked anyway. Stoked!
I used the Nevirtus method many times and it worked perfectly but this last time I tried I ran into a problem. When I tried to load the kext with
sudo kextload /Library/Extensions/TASCAM_US1641.kext

I got the error
/Library/Extensions/TASCAM_US200.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

I solved this by disabling System Integrity Protection by booting into recovery mode and using the csrutil disable command in the terminal. Reboot, try to load the kext again and it should work.
Dont forget to repeat the steps and this time enter csrutil enable to reenable your SIP.

Many thanks again the Nevirtus for his method!
I can confirm this works on High Sierra and using the US-600. I followed all steps and thought it did not work at the end. As a last ditch effort I unistalled all drivers again and re-installed and now boom...working. So happy thanks so much.

I'm on Mojave 10.14.6 and after following the instructions in Nevirtus post, I got it to play in iTunes and the driver display looks like it is working properly. Then I opened up my DAW and nothing could output/input. I tried iTunes again and now it doesn't work. I tried disconnecting and power cycling the US-1641 but no luck. I'm about to try rebooting but thought I would try checking in first just in case it doesn't work.
No luck yet.

Here's the output I get when I type in:
sudo rm -rf /System/Library/Caches/

Output is as follow:
rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted

rm: /System/Library/Caches/ Operation not permitted
Also, as a reference, here's what happens when I use a different command with the intent of rebuilding the cache.

sudo kextcache -i /

Output as follows:

KernelCache ID: [i have omitted the cache ID]

kext file:///Library/StagedExtensions/System/Library/Extensions/IKStealthPedalDriver.kext/ is in hash exception list, allowing to load

kext file:///Library/StagedExtensions/System/Library/Extensions/IKStompIO1Driver.kext/ is in hash exception list, allowing to load
Last edited:
Has anyone found a workaround to get this working on Catalina? I managed to use the installer, get the Tascam control panel installed (although of course, its a 32bit app so it wont open on Catalina), and this allowed me to follow Nevirtus' instructions. Everything seemed to go ok, I can see my US-200 in System Preferences - Sound but with "The selected device has no input controls". I can also see it in Ableton preferences and select it, but no sound.
I thought it would either show up and work or not show up at all so Im a bit confused, and slightly hopeful that there is a workaround.
  • Like
Reactions: Per Lichtman
That’s pretty much what my experience was like under Mojave, too, yum.yab. I didn’t find a workaround.

New threads

Members online

No members online now.