US-200 not working with macOS Sierra

Well, that sucks. I was guessing it was a problem related to the the end of 32 bit support, but if its Mojave too then god knows.
If anyone has a breakthrough, let us know. Although I think I will go back to High Sierra as this isnt the only piece of hardware that I cant get working with Catalina.
It worked for me. Tascam 1641 Interface in Logic Pro 10.3.2 on Mac OS Mojave (10.14.6)

Thank you very much.
Su-weeeet! This worked for my US1641 on High Sierra 10.13.6 (with latest security updates)! Logic recognized it no problem-o and I've been jamming all morning :D

One addendum to the process is to disable SIP before -- and re-enable SIP after -- the sudo rm -rf /System/Library/Caches/ command. Otherwise, it throws "Operation not permitted" errors.

Summarized action steps for High Sierra 10.13.6 would then be:
  • file /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641
  • sudo lipo -thin x86_64 -output ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641
  • sudo rm /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641
  • sudo cp ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/
  • sudo kextload /Library/Extensions/TASCAM_US1641.kext
  • Reboot into Recovery Mode (CMD+R), disable SIP from Terminal (csrutil disable), reboot normally
  • sudo rm -rf /System/Library/Caches/
  • Reboot into Recovery Mode, enable SIP from Terminal (csrutil enable), reboot normally
  • sudo kextcache -prelinked-kernel /System/Library/Caches/ -K /System/Library/Kernels/kernel /System/Library/Extensions
I will send you a fruit and cheese plate of the finest origins, kind Nevirtus. THANK YOU! :D
I had the same problem with my US-1641 but I did find a solution which may work for other units such as the US-200.

Basically Sierra does not seem to load drivers (kexts for Mac OS) that contain both a 32bit and 64bit binary and, at least for the US-1641 El Capitan kext, both binaries are present. See
Luckily, code signing seems to be done on each binary when it is compiled and removing the 32bit version allows the kext to be loaded.

The following steps worked for me but obviously your mileage may vary.
Usual disclaimer: I accept no responsibility for what may happen to you, your computer, peripherals or anything else that may occur from following these steps. Use strictly at your own risk!
Messing up with kernel extensions could prevent your machine from booting or cause crashes so make sure you have all work saved, a backup and are ready to restore/fix your machine from the recovery partition. If your are not comfortable performing the steps outlined, reverting to El Capitan is a safer option.

In the instructions below you will need to replace all instances of 'TASCAM_US1641' with whatever applies to your device.

Open a terminal.

Ensure that you can proceed further by checking that you see information about x86_64 and i386 from the following command:
file /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

If so, remove the i386 binary with the following:
sudo lipo -thin x86_64 -output ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

This will have output a file named TASCAM_US1641 to the desktop which should only have the x86_64 binary.

Remove the orignal:
sudo rm /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US1641

Copy the new binary (thanks to gizabj for adding the missing 'sudo' here):
sudo cp ~/Desktop/TASCAM_US1641 /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/

Try loading the new kext:
sudo kextload /Library/Extensions/TASCAM_US1641.kext

There should be no errors at this point. You can use kextstat as an additional check here.

Now rebuild the kext cache:
sudo rm -rf /System/Library/Caches/
sudo kextcache -prelinked-kernel /System/Library/Caches/ -K /System/Library/Kernels/kernel /System/Library/Extensions

Reboot your Mac, delete that file from your desktop and assuming everything went fine, get back to using your Tascam :)
Thank you Nevirtus for your post.
My TASCAM US 1641 , now is working on High Sierra.
Any way to make this work on Ventura? Just made the switch from PC to Mac, and it keeps telling me that prelinked kernels can't be used anymore.

New threads

Members online

No members online now.