US 2400


New Member
Nov 20, 2014
Gear owned
Tascam US 2400
I just purchased a US 2400 second hand. I plugged it in and am using it with Logic Pro X but still having some issues.

1) Faders 1-8 work, but faders 9-24 mirror 1-8. So when 1 moves, 9 & 17 move in the same way.

2) The transport buttons are non-responsive (i.e.: play, record, etc.)

3) The solo, mute, and sel buttons above each fader don't select/light up, same with the bank and scrub buttons etc.

4) The "flip" button keeps flashing.

I feel like it's just a set-up issue that I can't seem to pin down. If someone could help me out that would be great!


Hey, no I haven't solved it. Still looking for answers. Do you have any information?
Sounds like the control surfaces in logic are setup wrongly.
Did you set them up as Mackie Control ?
Hey, no I didn't set them up that way. I just read that it was plug and play but I guess not. Did you set it up as Mackie Control? My faders are allocated in such a weird. The 1,9,17 channels are synced with the master for some odd reason :S Any idea?
I don't have a US2400, but two dm3200, but the setup should be allmost the same. Does Logic recongnize the controller ?.

I think you have to set up one mackie locic controller and two extenders
Does your DM3200 function seamlessly? Logic does recognize the controller. The manual says just play and play but I could try that as well. How do you set it up with Mackie settings?
The dm3200 works like a charm. Have two of them cascaded with 32 faders working in Logic X.
I recomend reading this thread as it might explain what you are up against

To find out more about setting up as Mackie control, go to the and search for dm3200 and find the PDF under the download. the section about setting up under Logic wil give you an idea what you have to do in Logic
Did you set your DM3200 up as a Mackie unit? Is there anything on the unit that isn't synced with the software or doesn't work?

I'll give that a shot. Thank you
i am having similar issues. brought my US2400 when it first come out 2004 ish and worked treat with cubase and reason on windows, such a great controller to works with. Since 2008 its been packed away under the stairs due to starting a family. (babies, wifes and home studios are a bad mix) anyway thats the end of the life story.

i've just started putting my studio together and read that windows no longer support the US2400 and tascam no longer support the product (Why!!!!). so ive gone down the logic pro x route as i read it was still fully compatible, plus i wanted a more stable DAW.

First plugged it in, set the us2400 up in native mode (power up holding down master sel and aux 5) as per Logics instructions, fired up a new project, preferences, control surfaces, did an automatic install, found the US2400 and also a Mackie control with 2# XTs. started to lay down some audio tracks moved some faders ...nothing?

so.... set us2400 up as mackie control emulation mode for logic (power up holding down master sel and aux 4) hey presto... nothing again, although moving faders adjusts the pans on various channels on the logic mixer.

read up forum after forum... the best i have found is power up holding down master sel and channel. This works..... almost. the faders work, but you have to press the solo and mute buttons twice to enable and twice to disable?? and sometimes you press solo on a track works fine... then disable solo and loads of other tracks mute buttons light up but you can still hear the tracks playing in the mix.... so works kinda but very buggy.

i am still working through it at present, if i find a solid solution i will post.

1# MAC mini 2012 server edition Maverick
i7 2.6, 16gb RAM, 2# 1TB
1# TASCAM US2400
Logic Pro X
1# extremely frustrated individual

New threads

Members online