DM 3200 IF-FW/DMMKII Transport control

kk570

New Member
Joined
Aug 27, 2013
Messages
7
Karma
0
Gear owned
DM 3200 IF FW DM MK II
I am using the DM 3200 with the IF FW DM mk II Firewire card and using Sonar X2 Producer as the DAW. My question is: I can get audio to the DAW via the Firewire but I can't seem to get the transport controls on the DM 3200 to control the transport controls on the DAW. I have followed the setup for ext control and machine control to the letter. Setting MC for Sonar on the Machine Control screen and setting MC for Sonar on the External Control List.I do not have a midi card on my PC so I am trying to use the USB connection on the DM 3200 to send the transport control signals to the DAW. In Sonar I have set MIDI preference to TASCAM DM 3200 assuming that will enable USB control of the transport controls, no luck. Does anyone have any ideas? Thank you for any help you can provide.
 
It looks like you have everything setup correctly. An easy way to check your USB connection is to open Tascam Companion. If it does not find your mixer, then that's the problem. All the midi data for transport control is over USB. However, a simple misplaced setting could also be the problem. I have attached 5 screen shots of my DM3200 screen. I also use the setup for Sonar using MMC, so our settings should be the same. Take a close look at each page. In particular, take a look at the "Remote MC" picture. There should be a little triangle inside the circle. If it's not there, move your curser up to the circle and hit enter. Then try it. Hope it helps...S
 

Attachments

  • Remote MC.png
    Remote MC.png
    7 KB · Views: 277
  • Remote MC Setup.png
    Remote MC Setup.png
    5.2 KB · Views: 271
  • MIDI Page.png
    MIDI Page.png
    6.7 KB · Views: 276
  • Ext. Control List.png
    Ext. Control List.png
    6.2 KB · Views: 257
  • Control Page.png
    Control Page.png
    5.1 KB · Views: 234
Hey TascMan, you are using these settings for Reaper as well, right?

Also, your clock is MTC. Should I be using that for my Reaper or is that something you're using for your many out-board devices?

Mucho thanks for posting these!!!
 
I am using these settings with Reaper. I am not quite sure what your second question is asking me. However, it sounds like an explanation of MTC vs. Sample Rate clock might be in order.

MTC stand for Midi Time Code. It is a newer version of LTC, (Linear Time Code),
some explanation can be found here: http://en.wikipedia.org/wiki/Linear_timecode
and here: http://en.wikipedia.org/wiki/MIDI_timecode.

Basically, when engineers recorded to tape, they needed a way to do linear automation, (like automatic volume (fader) changes or pans). So, they developed a linear time code that was printed to one track on a multi track tape that used "frames" to tell everyone mins, secs, etc. This was done because they wanted to keep the tape machine and the board synced, so that the board "knew" where the tape was in the song. That way, they could rewind, or fast forward, but the automations remained the same anywhere within the song. BTW, I really don't want to sound like I am taking out my ass. I was a teenager in the 80's, when these techniques where in use, and certainly not in any recording studios. I am going on stuff I've read over the years and would really appreciate any corrections by other members who may have some experience with this.

Now, typically I do my automations within Reaper. It's easy and I can zoom way in to make sure they are accurate, so, I don't really need a linear time code. However, I find it fun, and occasionally necessary to see where I am in a song on the time clock readout on my meter bridge. To do that, I use up a track in reaper to generate an MTC signal, sent out to Tascam MIDI 3. There's a bit more to it than that, but basically, that's how it's done.

When you referenced my many digital outboard devices (all four of them) I think you were thinking that this has something to do with syncing them via the digital sample rate clock, as generated by the DM. It doesn't. The board sends out your current sample rate not only over the BNC connector, but also over AES/EBU and the RCA digital connectors. The digital devices use this sample rate clock to accurately regenerate the digitized audio signal. It has nothing to do with Midi Time Code. That's a different clock, altogether. (........."THATS A DIFFERENT CLOCK") ---a little "airplane" humor.
 
" I really don't want to sound like I am taking out my ass. I was a teenager in the 80's, when these techniques where in use, and certainly not in any recording studios"

I was, and that's all true. SMPTE clock was also used to sync pre-produced midi material stored on (Atari/Commodore) floppy disks. One of the 24 tracks on a 2" tape was timecode striped before the midi data was dumped through machines/keyboards in real time to individual analog tracks. Thus, the analog tracking tape machine became the sync master. A hellava lotta dance/pop music was done that way - in the UK as well as the USA. :)

Thanks for the trip down memory lane. :)

CaptDan
 
How did I know that line was going to be quoted by someone.....:)
 
HA! :D
Well, me too. Back in the 80's, when I was 35(...am I REALLY that old! Geez), I would stripe a track with SMPTE on my 8trk cassette (Tascam 688) and tie that to an early model Macintosh running Opcode Vision sequencer. That allowed me to record all my midi gear(drum machines & Yammy DX7) in Vision and all analog stuff on the 688. Worked like a champ. SMPTE kept everything rock solid. I still have all that gear... and yet I don't know why. Memory lane indeed, CaptDan.

But getting back to my MTC question, since I'm trying to mirror all of your Reaper settings, I was unable to set the DM to MTC (as shown in the upper righthand corner of all the pictures above). I was "assuming"(there's "that" word) you were using that in conjunction with an ADAT or whatever. That's really cool using a Reaper track for MTC to display time on the meter bridge. Sometime down the road I'd like to attempt that but right now it would be a major victory to arm, record & playback 24 trks at once.
So, it's okay if I'm set to "INT" in the upper righthand corner of all my screens above?
 
"it's okay if I'm set to "INT" in the upper righthand corner of all my screens above?"

Possibly not. I can't speak to Reaper's particulars - I'm familiar with ProTools & Cubase. However, you might try setting your MTC to receive FROM Reaper as opposed to Generating INTernal. This is done in the Automation Menu on the first page: choose MTC external. By default, the DM will use USB3 as the MTC pathway from your DAW.

Next: you must set Reaper to send MTC outboard via USB3. I can't tell you how that's done, but it's likely accomplished via a 'Perpherals' or 'Device' menu.

Caution!: this setup may NOT work with the DM's mix automation! If that's the case, you'll need to revert back to DM's Generating Internal MTC and setting Reaper to RECEIVE timecode from the DM. All I can say is, this wasn't an issue when I was using Cubase, but an absolute necessity for performing OTB automated mixes with ProTools. All DAWs aren't created equal; some need to march to external code for frame- accurate syncing procedures - others apparently don't.

CaptDan
 
Cool! Thanks Capt. I'll give it a try and report back.
 
I'll set you up with a step by step in Reaper for generating a clock signal, in another post, so you can see it on your meter. However, for now, follow Dan's advice about going to the automation page, and clicking on MTC/USB.
Sorry for the tangent earlier. You obviosly have much more experience than me with SMPTE. Your question sounded like you were wondering how I synced up my external digital effects with MTC, so I wasn't sure where you were on that. Since I haven't met you, you could be some 12 yo kid for all i know.
Anyway,
1) How's it going with the transport stuff?
2) Are you now able to record and playback 24 channels at the same time yet? you should, given your laptop's massive capabilities.
3) I wanted to point out that, from your PM, your latency is really high. I have found that disabling ANY networking devices (wired or wireless) will cut your latency WAY down. Of course this would be done in your windows device manager. Find the device, right click and disable. When you need it agian, just right click and reenable. (Thanks Charlie---I bought a set of electronic drums BTW--More later) Give that a try and let me know what your Tascam spike checker says.
 
In hindsight, you're right. If you knew my background there would have been less time & typing for you. So that's why the "Introduce Yourself" threads exists to begin with. You've been incredibly gracious with your time & help from what I've seen on this forum(along with other folks like CaptDan) and the last thing I want to do is waste any of that time.

So I'm now set to MTC (thanks Capt) on the DM but no changes in Reaper yet. Playback remains ok until other "issues" occur... more on that later. But at least I am now "mirroring" your DM from the earlier pictures.

1) Transport controls are ok about 85% of the time. There are occasional errors ranging from small to large, like fader 9 returning to the wrong level when switching to other layers then back to remote. Then there's times when all transport controls go to sleep. :?: BTW, before I switched to the Sonar settings you use, I was set to MMC Steinberg. Both MC's act the same. I have Reaper's Control Surfaces set as per one of your earlier posts using midi 5,6&7 with correct offsets & tweaks (0,9; 8,8; 16,8).

2) No, still only 5 seconds worth of a test track recorded on track 24 from channel 24 with a mic plugged into ch 24. The track will playback but for some reason I cant get a mic signal when I arm it to record. No idea how I did it the 1st time. I can see the DM meter move on the Stereo buss and on ch24 if I'm on the CH 1-24 layer but Reaper doesn't respond. I'm still clueless when it comes to routing but this sounds like a Reaper problem to me.
Now here's something weird I just discovered. Playback goes along just fine until I open the Tascam Spike Checker. As soon as it's open the audio distorts and has long drop outs. Closing the spike checker does not help. Weird. Also, in order to open the spike checker I have to right-click>run as administrator. If I just click the icon to open the readings remain at "N/A". BTW, I have already uninstalled & reloaded the IF-FW DM mkll driver.

3)AHH MAN... You mean I cant surf for naked weemens while I'm tracking?!? :shock: :shock: Man, it's gettin' rough around here.
Well, ok. If I have to, I have to.
Looks like this laptop has 3 wireless adaptors & one wired, with only one enabled. I'll shut them down and see what happens.

Thanks, Lee
 
Okay. I am reading number 2), and I see that you may have your routing setup wrong. So let me start there. It looks like you have the DMs inputs set correctly, using M/L 1-24 as sources for inputs 1-24. But, if Reaper doesn't show a meter for 24, than here's a couple of things to check.
Before going on, is your FW card in SLOT1? or SLOT3? I am going to assume it's in Slot 1. If its in SLOT2 or 4, that may be a problem. I think it can only be in slot 1 or 3. Typically SLOT1 is used for the FW card. Moving on....assuming it is...
Go to ALT/ROUTING/OUTPUT SLOT. On the right side, under SOURCE SELECT, move the curser (POD 4) to "M/L" under Input Bypass.
Now in the middle, under TERMINAL SELECT, Choose SLOT 1 Trk1-8, using POD 3.
Now, under OUTPUT SELECT, go down to BATCH SETUP, and select it using the arrow keys. Now, using the jog wheel, turn left one click, then one click right. It should now say M/L 1-8 (or something like that) and hit enter. Now do that for SLOT 1 9-16, this time using M/L 9-16, and SLOT 1 17-24, using M/L 17-24.
Now, all of your input channels are properly assigned to the correct FW channels.
Remember, you still have 8 channels more to mess with. I usually keep chs 31 and 32 reserved for the DM's stereo buss output.
Now, in Reaper, check your preferences. Go To OPTIONS/PREFERENCES/AUDIO/DEVICE. You should have ASIO set for audio system, and IF-DM/FW for the ASIO driver. Make sure "Enable Inputs" is checked, and CH1 is set for "First" and CH32 is set for "Last". Same for "output Range" What's your sample rate...44.1? then make sure "Request Sample Rate" is set for 44.1.
Now, open a new track. Under the horizontal fader, choose your track input. How about channel 1. Arm it for recoding Now plug a mic into channel 1 in the DM and set it's gain. You should definitely see movement on the meter in Reaper. Try recording something.
When finished, select "save all". now, disarm the track and try playing it back. Do you see meter movement in Reaper on the Master meters? bottom left? If so, good. If Not, look at the Track 1 I/O button and click on it. in the window that opens, look at the top left at "Master/parent send". Make sure that is checked.
Now moving to the outputs...
Look at the I/O button just above the Master's meters. Click on it and look at the output routing for the Master buss. Under Audio Hardware outputs, you should have it set to FW Ch1 and Ch2. Now, on the DM, go to Routing/INPUT. On the right select SLOT1 under "source select", then under Layer Select (lets put Reaper's master returns on chs 25/26), so you would select layer 25 to 32. Now go to Ch 25 and select SLOT1-1, then go to Ch 26 and select SLOT1-2. Now make sure these are paired (hit SEL for both at the same time, then hit enter). Also, make sure they are assigned to the STEREO buss.
This should do it. Again, make sure the DM and Reaper are set to the same sample rate.
 
Success!! 24 trks recorded & played back. Sixty one minutes total recorded. First minute was done one track at a time, moving a mic from channel to channel. This went fairly well but there where some snags. Sometimes when hitting play/record the recorded item would not print in the track until maybe 2 or 3 seconds after start. Also, on a different occasion, Reaper's clock in the transport area flashed red for a couples of seconds.
For the last 60 minutes. I wired a headphone signal from my stereo into the 2TRin port and "somehow" :?: routed it to all Reaper tracks. The recording & playback were flawless. Total disk space used was around 13 gig.
The above mentioned "snags" were threefold until I disabled WiFi. The IF-FW control panel reported a grand total of "3" audio dropouts for 61 minutes of recording... excellent! The Spike Checker showed a max latency of 1457 at the very end but it did not suggest changing to "Safe Mode Level 1" until well after 1300, which again did not happen until the end. I did not hear any distortion or dropouts.

Details:
Yes, FW card is in SLOT1. DM is set to 48khz, 24bits. Windows sound card set to 48khz, 16bits. Transport controls are more solid now, however fader 9 occasionally still resets to an incorrect level when changing layers then returning to "Remote". The Reaper trk 9 fader does not change until I manually change the DM fader.

All in all, the snags are very minor... which makes me very happy. Thanks TascMan, you're THE BEST! I actually feel like there's a light at the end of the tunnel. :D :LOL: :D
 
Awesome!!
If you get a chance disable Wi-Fi, and any network cards, then try your
spike checker again. Your latency is VERY high. I recently reported that mine was around 700-800, thinking that was good, until Cmaffia told me his was around 80!
I asked how he got his so low and he told me about the network cards, of which I have two in this computer. I disabled them and now I'm at 130 max latency. I am even able to set the performance mode to Low Latency. My buffers are set to 128, with 64 being the min, and I'm still at 88.2.
I think the ch9 fader issue might be something to do with the Reaper's Control Surface settings. On MIDI5, you should have a MACKIE CONTROL, be at offset 0, size 9 and nothing checked in boxes.
In MIDI6, you should show have a MACKIE CONTROL EXTENDER, be at offset 8 and size 8, nothing checked.
In MIDI7, another MACKIE CONTROL EXTENDER, be at offset 16 and size 8, nothing checked. Just double check those settings.
I think the red time display happens when the throughput on your laptop can't quite take the load. Check you buffers. I am attaching a screenshot of my buffer settings in Reaper. See if they help

Reaper Buffer Settings.png

Sorry for the huge picture!

Also,
I just PM'd this to someone else and thought you could use it to.
How to make the Timeline time show up on your MU1000 time display, using Reaper:

1) On your DM, Go To AUTOMATION, above the "2" key. Near the bottom, look for MTC (USB) and make sure it's checked.
2) On Your DM, Go To ALT/MIDI and make sure the "USB:3 MTC" lines are closed, in and out.
3) In Reaper, up in the menu, click on INSERT, and select "SMPTE LTS/MTC Time code Generator"
4) click on the right edge on the inserted media item and drag it to the length of your project.
5) Now look at the track fader section, and look for "I/O" next to the track name, and click on it. It will open a new window defining Ins and Outs. On the right side of the window look for "MIDI Hardware Output". Click on the dropdown under that and look for "MIDI OUT3 (Tascam 3200)" and select it. Close window.
6) Now Double Click the gray media item in the track.
7) A window named "Media Item Properties: Time code Generator" will appear. At the bottom, select "Properties"
8) "SMTPE Generator Properties" window will open. Click on "Send MIDI MTC" keep frame-rate at 30fps and everything else the same. Click Apply, and OK. Then, OK for the properties window.
9) Now, right click on the Time display in Reaper. Check the option to have it show HOURS:MINUTES:SECONDS:FRAMES
10) Now, highlight and right click and copy this step by step and save it somewhere. You'll need it again!
DONE enjoy...S
 
Last edited by a moderator:
  • Like
Reactions: Doug Kelley
Cmaffia told me his was around 80!
Wow, that's great. I've got some work to do. I bet I can find more stuff to turn off.

Buffer & Control Surface settings look correct... I'll re-check.

I actually like the big pix. Easy read for old eyeballs.

Big thanks for the "Timeline" info for the MU1000. Cant wait to give it a try!

I'm heading out of town today so I'll report back next week.

BTW, check your email. I sent an aircraft related link.

G'day
 
Thank you, TascMan, for the transport control help. Very detailed and very helpful. I really appreciate it.
 
no prob. I am hoping it helps many.
 
The MU1000 time display works great. I can see where it can come in handy. Thanks again!

Reaper's Control Surface settings, unfortunately, were set correctly. Fade 9 still occasionally goes goofy.

Buffer settings in Reaper were the same as yours but I haven't seen the red time display since the following latency adjustments were made.

Latency is now down in the 400 range. I disabled 4 network cards, virus protection, screen saver/changer and several other items that didn't bring on a BSOD. All systems seem to be running well. No dropouts. I suppose I'll find out how well it's working when I figure out how to set up headphone queues.
I'll try to post a pix of my Task Manger(I don't feel lucky). If you see anything else I can cut let me know.

JRQNfhD.png
 
Last edited by a moderator:
I have rebuilt my PC recently and had to again, get all the settings.. I am using Reaper and followed the setup posted above by TASCMAN.. (thanks a lot.. I needed those again.) I now have transport/record/stop/RewF. Fwd running again, But my time code on the DM meter bridge does not move when reaper is playing/recording.

Is there a way to get that to show the time code generated by Reaper? ( I know it's a relatively minor issue but it would be nice to get more of my DM features to be utilized )

thanks in advance, Blickerding
 
MTC transmits on the DM's USB midi channel 3. Did you set that up?
 

New threads

Members online

No members online now.