Newbie (sort of!) needs firmware bug update help

Feb 22, 2014
Gear owned
Hi, just enjoying the heck out of this console.. but only one major issue that I would appreciate help with.
Running Win7/64 bit. I have the correct companion software (1.51) and 4800 firmware version (1.7o).

... And it seems that there are others on this forum with the same issue but I can't find the resolution.

Currently, the board has 1.62 firmware but I MUST update it, as all my faders are "sticking", until I move each one once... then they move!

So the Firmware Updater software process starts but stops at 5% and says PROTOCOL TIMED OUT.

It wont update and I have to shut the board off to restore the 1.62 original firmware...but of course, my faders stick!

Thanks for your time!
If memory serves, V1.70 is for Mac based DAWs. Your sticking faders might be due to several things, including a corrupted file. Have you done a full, factory reset? If not, you should try that. But first, be sure to backup any current projects.

Thanks Dan; appreciated. 1.70 is also for win 64 pc (which I have)
The only reason I tried to update from the 1.62 it came with, was/is because the faders stick with 1.62.
But I can't even try the "improved" new version, as it only gets to 5% and times out. I see two others had the same "protocol times out" message when installing 1.70... On 64 bit Win.
CaptDan, I think you're confusing the mixer firmware with Mixer Companion, which indeed has 1.51 as the highest Windows version (and 1.70 for Mac).

The highest mixer firmware is 1.70, and maybe the OP can try updating it in Win XP compatibility mode. I remember having had some difficulty updating in the past (not sure if that was to v1.70), when it had to be done from an XP computer even. I may be mistaken for the IFFW firmware though..
The console came with 1.62 (just got it a few weeks back) and no idea where to get the 1.60 firmware update (is that not from 2008?)... sorry for the newbie query but how would i try updating from my 1.62 to the 1.70 via WIN XP comp mode? Not sure how to do that. I will also try what Dan said: reset the console...
Hi Arjan,

I know, it's confusing - and I've been confused by these two things before. All I'm going by is what I see in my DM's firmware screen, which shows V1.60. I never bothered to upgrade to 1.70 because I never found a need.
Perhaps you can fill me in on what the improvements are and I'll jump up too. :)

The XP Compatibility Mode is a good idea though; I'd forgotten about that problem.

Does anyone know where i can get the 1.60 version AND my current 1.62 (cause i will lose that when i try the previous version!)
I don't know about 1.62, but I do have a 1.61 in my downloads backup. Not at home now, but I could send it to you. However, 1.70 should just work.. Not sure how I did it, and maybe I'm confusing it with IFFW updating, but at some point I had to install an older version of Mixer Companion to get the firmware updated.

And the improvements of 1.70 over 1.62 are:
New features:
1. It supports IF-AV/DM (Aviom Pro16 A-Net Interface).
2. It supports IF-CB/DM (Cobra Net Interface Card).

Improvements and Bug fixes:
1. Digital Signal was not come out from Digital Output if the Fs Converter was set to On and Digital Input signal was not come to Digital Input. – fixed –
2. Studio Out signal did mute momentarily when SOLO was changed. – fixed –
3. When the RS-422 command (Sony P2 control) was sent, unexpected function might happen on the target machine. – fixed -
E.g. Pressing REC key during recording on target machine made Punch Out (Record off). It should keep Recording.
  • Like
Reactions: HappyMetalHead
Love to get 1.61 firmware and a previous version of companion (if it is compatible with 64 bit Win!)
email is:
watersound AT

Ya I'm taking a guess that, if I can get the previous companion version, it should load the new firmware... Just can't find it online
Attention DJ-X, The Moderator Guy!:

Perhaps you might consider making a sticky for the previous message. I think others might want to know about the 'European Connection too.' :)

Thanks guys. I tried all pc versions of TMC and the firmware but every time I tried to load ANY firmware version, it stops at 5% and displays PROTOCOL TIMED OUT .. Dang! I also have no idea how to try a total factory reset... any links or comments how to>? Thanks again! Gotta lick this one... starting ANNIHILATOR's 15th studio cd and all but this issue has been solved.. need to rock! :)
oh, and when I try to update the firmware, the console seems to be recognizing the update is being attempted... it even shows version 1.70 update starting... but then the TMC software always times out with the PROTOCOL TIMED OUT message after 5% ... (seems to be waiting for the file to start loading...)
DOes this process of receiving the file, via the TMC software, come OUT of the computer via the 1st usb/midi channel of the 8? I notice in my Cubase 7.5 device menu that the Tascam 4800 midi port IN from the usb/console is ACTIVE but the Tascam midi port OUT to the 4800 is INACTIVE.
Is that where the TMC software sends the update file out to the 4800??
If so, that port is INACTIVE and no option to enable that in the Cubase midi section
Well, I'm out of ideas, other than trying to do the update from a different computer with just USB connected. But it's a shot in the dark, really..

I've sent you an email with a Factory Reset document, but I doubt whether it will change anything in the firmware or the behaviour.
  • Like
Reactions: HappyMetalHead
I notice in my Cubase 7.5 device menu that the Tascam 4800 midi port IN from the usb/console is ACTIVE but the Tascam midi port OUT to the 4800 is INACTIVE.
Is that where the TMC software sends the update file out to the 4800??
If so, that port is INACTIVE and no option to enable that in the Cubase midi section[/quote]

TMC defaults to USB4. If that portal is being used by another device, it could explain why you're having problems.

Here's what you might try:

1. Check your WIN7 devices menu; using the advanced option, see if anything besides TMC is working on USB4. If there is, make changes accordingly.

2. Reboot the DM and the PC

3. Load TMC first, then try the firmware upgrade again. Be sure nothing else is open but TMC; no Cubase, no interweb, email, etc etc. :)

K.... getting somewhere at least. tried all above tips. here is where it is at... I KNOW you can figure this one out!

usb 1 is the default for TMC on the 4800... at least for mine. tried the reset... poop, no luck BUT
I THINK the prob is that, when I pop up Cubase's midi port status infos, it shows that all the usb ports are working fine EXCEPT that the midi OUT if the midi channel 1 (Tascam-4800) is showing INACTIVE ... so since the 4800 defaults to midi ch 1 (usb) for the TMC, and since Cubase is showing that midi ch 1 (usb) is INACTIVE; something must be using the midi ch 1 output... but it can only be within the usb 8 channels... my only midi in the whole chain is via the 4800 usb to computer cable...
so what on earth could block the ch 1 midi output from the computer to 4800 ?? Keeping in mind that no other midi device or data is connected...
First, I apologize for a typo: I meant USB1 NOT 4. Sorry. :)

Second, have you done that check I suggested? Win7/Devices Menu/Advanced - USB Controllers? Anything can block a USB portal: a mouse, thumb drive - or just Windoze making a dumb call. (It IS a robot, after all, right? :)

I think you're very close to getting this thing solved. Worse case scenario: you pull every single USB device in your rig, then replug the DM's USB first, then see if USB1 works like it should.

  • Like
Reactions: HappyMetalHead

New threads

Members online

No members online now.