TC Companion

John Flynn

Nov 14, 2012
Shankill, Dublin Ireland
Gear owned
Tascam DM4800 IF-FW
Hi All,

today i downloaded the latest version of TC Companion for Mac mountain lion and it looks great. Normal colours and appearance at last but when i try to back up my CF card to my host computer as i often did with the old version it refuses to allow me too.

Has anybody else experienced this or would have any ideas?

Thanking you i advance

No clue... mine has been working fine since the beta version.

You might try repairing disk permissions... I make this habit anytime I install even the smallest bit of new software.

Also, did you "replace"/overwrite the old one, or did you remove it and then install the new one?
Hi Jim,
I too am obsessed with repairing disk permissions. i cannot install any software without doing this so this should be ok. I am not sure if i trashed the old version before installing the new one to be honest. I will trash the latest version and reinstall to see if the problem persists. If it resolves it i will note it here. If not i will give a better description of exactly what happens when i try to back up my CF card.
Thanks for taking the time to reply to my post Jim. I really appreciate it.

Ok I have trashed TC Companion, repaired disk permissions and reinstalled TC companion after downloading it again from the Tascam site. My projects appear om the left pane and i hit backup all. I get an error half way through the back up saying 'back up file not found' Any ideas?

I now installed the old version (the one previous to V7 with the colour problems) and it shows the exact same error. When i would have last backed up my projects successfully i would have been using lion rather than mountain lion. What gives? Has anybody other there any suggestions?

And backing up a single mixer project?
When it says "backup file not found," is it saying it can't find a file on your Mac, or on the DM's card?
First - my usual caveat: I don't speak Mac.

Second - a wild guess: if TMC can't find the file, it's likely referring to the one residing on the DM's card. It's possible that - somehow - the USB port communicating with TMC became disconnected or is in conflict with something else.

I'd suggest another uninstall-reinstall, then doing whatever Mac detective work is necessary to ensure that port is soley dedicated to TMC.

Re the first point I am guessing 'backup file not found' is referring to the file on the cf card. The projects are showing up perfectly on the dm mixer screen and on the left pane of the tc companion. I have backed stuff up previously using the old tc companion on lion. I could try plugging in and out the USB cable but remote and time code are being transferred perfectly.....
CaptDan's point is interesting. One chooses the remote ports for communication via the USB and the port for sending time code from the software to the desk etc. I will check which port communicates with the TC companion and make sure i have not chosen this port by accident for something within one of the softwares. I use the DM4800 with ProTools 10, Logic 9 and Nuendo 5.5.That would cause a conflict if it were the case.I doubt its a bad connection with the USB because the remote layers are fine on all softwares and time code is being transmitted perfectly from them all to the desk.
I must find out exactly which midi port does the communication with TC Companion or does anyone know? I know 3 are used for remote purposes and one is for Machine Time code. Which midi port in the USB communicates with TC Companion?
DM's port #1. You can always verify port numbers by looking at DM's MIDI/SETUP screen.
Cheers Jarno,
Its been a few years since i set up my DM4800 and you forget this stuff. I just reviewed it in the online manual. I will ,make sure that i haven't accidently chose DM's port one for anything in Protools for example. The remotes are of-course correctly set as is the MTC (They are all working) but just in case i have chosen this port (Port one) for anything incorrectly in the software..If it isn't something like this i am really stumped......i.e. i have no idea why i cannot back up my CF card to host computer. Everything else, MTC, Meter bridge is working perfectly in TC companion. the only problem i have is when i try to back up my CF part on my host computer.
as i think about this though if the info is being transmitted through port one from DM to computer The TC companion is showing up the projects on the left pane and the meters are perfect too. If the problem was something disturbing port one surely these areas would not be working?
On the other hand, you say the issue occurs when you attempt a backup. It's apparently at that point you get the error message. That doesn't necessarily rule out a USB conflict; perhaps TMC is able to acquire the DM *file specs* but cannot perform a backup transfer because the 'line is busy.'

Again, this is just a guess. But my experience with the DM and occasional USB problems suggests that these strange things can happen.

Here's something you should try:

Immediately after doing a COLD boot of your Mac - and BEFORE you load your DAW - load TMC. Wait until the TMC menu is up, then attempt another backup. In otherwords, don't try to back up a mixer file WHILE your DAW is resident. If this works, it definately points to a USB conflict.

I run into something similar with ProTools on a Win7; sometimes TMC won't load when PT is resident, displaying a 'Mixer Not Found' contention. But, after I close PT, I can perform backups without problem.

Hi dan
Yes the issue only occurs when i attempt to do a backup. Other than this the TC companion performs fine. I have not actually tried to perform a backup while any DAW is resident. I have simply booted the mac (After booting the Dm of course) and loaded the TM companion. It communicates with the desk and the projects are visible in the left pane. The right pane allows me to choose a folder to save my back up in. I hit back up (I have tried back up all and projects separately) i get the usual notes telling me what projects are being backed up and then the folder they are going to. The blue line starts to run across and about halfway through i get the error message (Back up file not found) Ahhhhhhhhhh man.its doing my head in lol
I wonder could the issue be communication with the CF card but that is obviously working as the projects can be seen both in the mixer window and again in the left pane of DM 4800. I have backed up before on the old TC companion but the same error is showing when i tried that again last night. I normally used to back up my projects via TC companion to host computer and then out again to a spare CF card just to be sure......
I did take it out and put it back in. Got a bit nervous actually cos it took a sec or two to show up the projects on screen. I could try putting in a different CF card and trying again in fact i will tomorrow.... Again can i thank everybody who has been kind enough to take the time to help me with this problem. have some time in studio tomorrow so going to try as many ideas as possible..


New posts

New threads

Members online

No members online now.