US600 and Windows 10

Discussion in 'USB PC Audio Interfaces and Control Surfaces' started by ry1633, May 27, 2018.

  1. ry1633

    ry1633 New Member

    Joined:
    Jan 2014
    Messages:
    10
    Likes:
    0
    Gear:
    Tascam US600
    I have a Tascam US600 interface that for at least 5-6 years. I am running it now on my new laptop under Windows 10 and am starting to have some driver issues with it. Although, in theory, it should work with Windows 10 also. I am using the latest V1.03rc1 drivers and looks fine under Device Manager but sometimes when I boot up my computer Windows won’t find it or will give me a driver error.

    A problem that I have a lot with it under Windows 10 is that it looks find under Device Manager, but the Control Panel doesn’t list it as a Sound device at all, so I can’t actually use it. See screenshot of Device Manager and Control Panel side-by-side.

    Is my US600 going bad? Or is this a Windows or driver issue?

    Attached Files:

  2. Arjan P

    Arjan P Well-Known Member

    Joined:
    Oct 2012
    Messages:
    940
    Likes:
    321
    From:
    Netherlands
    Gear:
    DM3200 IFFW
    Maybe you can install the driver under Windows 7 or even XP compatibility. It sometimes helps with older hardware under Windows 10.
  3. ry1633

    ry1633 New Member

    Joined:
    Jan 2014
    Messages:
    10
    Likes:
    0
    Gear:
    Tascam US600
    I just tried to install the most recent drivers for the US600 under Windows 7 compatibility mode. Rebooted and didn't work. Interface is listed as ok and enabled in Device Manager, but not present at all in Sound/Control Panel.
  4. ry1633

    ry1633 New Member

    Joined:
    Jan 2014
    Messages:
    10
    Likes:
    0
    Gear:
    Tascam US600
    I also tried changing the Power Management settings in Windows 10 on the USB Root Hub. I also tried plugging in the US600 to both the USB 2.0 and 3.0 ports on my laptop, and neither has resolved the problem.
  5. ry1633

    ry1633 New Member

    Joined:
    Jan 2014
    Messages:
    10
    Likes:
    0
    Gear:
    Tascam US600
    Oddly enough I've found out that the oldest drivers for the US600 are the most stable for me.; the version 1.00. The other ones, the v1.02 and the v1.03rc1 drivers are the ones causing me the most problems. I downgraded to the v1.00 drivers and they are working much better so far. Weird.