DM4800 Transport triggering midi ??? and rice krispies


New Member
Dec 3, 2013
Gear owned
Hi folks, new to the forum, have been using my board for about 4 yrs. ... recently purchased a new imac with 32 gigs ram. After installing all software (DP7, Machfive2) and using an m-audio keystation 61, also downloaded all drivers and updates, I can't seem to configure the transport on the DM4800.
In addition to this problem, I'm getting rice krispies (snap crackel & pop) on recorded tracks ... I figure it's the firewire 400 to 800 cable and Thunderbolt adaptor but don't know for certain.
Have anyone of you encountered these issues with your DM's ?
  • Like
Reactions: Chris

Since I'm not a Mac/DP user, I can't offer any help there. But the crackling artifacts are possibly due to a buffer and/or sample rate problem. If you'd been working with your desk for 4 years without problems, and have just encountered these new issues, it should be fairly easy to back track through the upgrades to find the source of the issue.

We have several Mac-savvy users on the group; hopefully they can jump in to your rescue.

We have really struggled with the rice crispies as well. In my case its a dm4800 into an imac using a firewire 800 to 400 cable, no thunderbolt adapter. Every so often we get a digital clicking sound on tracks that we sometimes don't notice until listening back. I haven't been able to gate or EQ it out so it always means having to redo the tracks and its a real pain.

I don't know what causes it but it is related to a clock sync issue. the way I fix it is first I close protools, change the clock setting on the board and then immediately change it back to my original setting, usually switched from 44.1 to 48 back to 44.1. Then I reopen protools. This fixes the issue 70% of the time. If it doesn't resolve then I shut down the board and imac, then reboot everything back up. this just about always fixes it temporarily, but then its back anywhere from a few days to a few months later. Very frustrating and I've only been able to fix the symptom, not actually cure the problem. I even tried switching my actual cable between the board and imac but it had no effect.
  • Like
Reactions: Chris
I agree that it sounds like a sample rate thing. Just make sure your DAW and DM are set to the same sample rate. Also, check the DMs PROJECT page. (ALT/PROJECT/Clock). Normally, you should be set to "Internal", so that the DMs clock is the master for your sample rate. Also look at FsMode on the right. It should also match the sample rate you want. Ditto for "OUT SPEED"
If PTs has a setting for Clock master or slave, I would think it should be set to slave, so it gets it's clocking from the DM.
TascMan said:
If PTs has a setting for Clock master or slave, I would think it should be set to slave, so it gets it's clocking from the DM.

That's pretty much automatic. The Firewire ASIO drivers 'hijack' Protools and force it to do their bidding. If anything is changed in the FireWire ASIO menu - buffer, etc - Protools throws a sh*tfit. Then you have to reload the program, because 'the wheels have fallen off.' :cry:

Moral of story: don't mess with ASIO while PT is resident. It can ruin at least 1/2 of your day. :twisted:

same goes for Mac. You can't actually open a file that was recorded in a clock setting different than the current setting of the board, it will give an error.
Hey guys,

Yeah im experiencing the same issue...
Im getting crackles when tracking... By powers of deduction i narrowed it down to the firewire issue... But im in the same boat.. I didn't replace the firewire 400/800 cable as yet, what I did was pretty much power cycle the MacPro and DM4800. When everything was off I disconnected the firewire cable for a few seconds then reconnected..

Upon return, it seems to be good.

My clock setting in the "Project" page is set to 48kHz internal, so PT sessions slave to this by default..

Funny thing is; is that when tracking 44.1kHz the problem hasn't arisen..... as yet...

Not so elementary so far...

Anyone come up with a definitive answer or workaround???

My next tactic was just to simply replace the F/W cable, but it seems reading previous post here that it wont make a difference..

Thanks for reading!
Gross Generalities Dept: The degree to which fire wire performs properly - particularly at higher sample rates - is a function of two drivers 'under contract' to co-exist without warfare.

I don't use a Mac, but from what I gather there are IE1394 drivers therein. If so, the same is true for PC. In both cases, those 'native' drivers have to play nice with Tascam's F/W drivers. If these two are squabbling and beating each other upside the head while you're trying to get work done, well - you probably won't.

I know this, because I was plagued with the same thing until a very shrewd member of this forum (thanks again Charlie!) mentioned the term "Legacy Driver." This pertains to one of many (non-default) choices in Win7's copious Drivers menus. Previously, the Delphius Exhibit 23-A/V.1.0.98 driver (name VERY approximate) was engaged in disharmonious 96khz intercourse with the DM's V1.21 (and subsequent upgrade). Although I was unaware of the bloody conflict, I could hear chronic 'gun-shots' 'popping' all over my audio. Now, the bullets are no longer flying because the old regime was overthrown.

Dumb metaphors aside, your issue is quite likely very similar. Might be worth a look 'under the hood.' :)

I just starting to have the same issue. My Mac Pro and DM4800 was working fine but then had to move to Marvricks. So got the new drivers and all was ok for a while. (2 Weeks) Im starting to get a few pops, crackles as well. Its very hard to notice and I don't usually hear it when recording but when mixing back its more apparent. Usually sounds like it clicks and pops / and warbles which is weird.

I never had the issue on Lion so I believe its operating and firewire drivers or something along those lines. Im not sure I can do much about it at this stage other than wait for updats, but that seems to be taking a very long time from Tascam. I have the latest beta driver but still it would be nice to see Tascam move like they had a purpose. Lets hope they get going and realise that so many people need it - We are a pro-studio and its how we make money so it really important, we can work around it but its a time waster and costs the client money which is never a good thing.

Anyway if anyone has other ideas on how to get this fixed then let me know. I will give the clock issue a go but I'm sure its good on my system, all set to 41.
I never had the issue on Lion so I believe its operating and firewire drivers or something along those lines. Im not sure I can do much about it at this stage other than wait for updats, but that seems to be taking a very long time from Tascam.
Maybe the update should come from the company that broke it in the first place? I agree Tascam could be more pro-active in releasing final drivers instead of beta ones circulating allover the place for 2 years, but let's stay clear on what is causing the issues.
if anyone has other ideas on how to get this fixed then let me know.

This isn't a 'fix', per se, but might get you by temporarily. Just increase the buffer size in your DM/Fwire settings for mix down. Increase it as high as it'll go and see if the pops don't clear up. Latency isn't an issue in the mix phase anyway, so it might be worth a shot. You could also try freezing or bouncing MIDI tracks or wave/audio tracks with extra plugins to decrease CPU load. These two things might be a decent workaround for the time being.

Hey Gary....

Sorry to hear of the troubles with Mac OS 10.9.2 and the DM firewire card.
It really sucks to deal with digital noise in a recording environment.

Sounds like you jumped from Lion to Mavericks.... 10.7 to 10.9.
That is a big leap... you jumped over a Mountain Lion. ;-)
I'm wondering if there might be some updates needed in your other software...
Your DAW and plugins etc.

I can report that Mavericks... 10.9.2 is working great with a DM firewire card on a Mac Pro 5,1.
No snaps, crackles or pops.

I have been vigilant in updating software and system to the latest versions.
Trying to avoid the catch up game that I have played so many times.

Sometimes if it ain't broke, it will be.

Mavericks has been out for 6 months and I think it is a very good and stable OS.
I'm thinking Tascam should be able to bless a driver for it.
Im my case, the beta driver is working great.

Let me know if I can help.
I had the 'snap crackle pop' thing happening here at one time as well.

In my case it was definitely due to 'digital locking'. Devices were not locking.

But it was not related to my DAW (Mac Pro). It was related to an external CD Burner I had hooked up to my my AES/EBU Digital Out (via xlr) The CD burner was not locking to the console and was causing constant snapping. Even while in the Stereo Bus Mode....which was very strange.
Digging into the Settings on the Burner solved the issue. But it took a while to figure out.

Also, I have a Lexicon 300 Reverb Unit that can be connected digitally but only runs at 44.1 or 48.0......If I set the console to any other rate.....the snapping starts up again....full force.
So I guess I am saying check any other external digital devices (if any) that may not be locking.
  • Like
Reactions: Arjan P
I am familiar with this symptom, that clicking does occurs when you have external gear connected that doesnt have the same sample rate clock settings...

However, for this instance i'm just using the firewire card to connect to the mac pro... And have no other external equipment..

On DM4800 I have the clock settings set to internal so PT11 is slaving, which is all good because I dont have the choice to change because in the startup Dialogue screen of PT11 is greyed, which is fine.

The problem that persists intermittently, is that the clicking is only when you monitor back from PT11 and sampling at 48kHz not at 44.1kHz...

Like I say it doesn't happen all the time but intermittently.
Why don't you troubleshoot by downloading Reaper for the Mac. Try recording multiple tracks using 48khz or any other sampling rate that gave you a problem in order to see if your PT settings are causing the issue. If it happens in Reaper too then I would start looking at your OS settings and possibly conflicting software/drivers. You can then work backwards from there. Also you should run the DPC Latency tool to see if you are having issues with your firewire card. My machine scores between 100-200 at rest. Which firewire chipset are you connecting your DM too? Is your FW onboard the Mac? Can you test with other FW PCIe cards? My Sweetwater Creation Station's PCI firewire card didn't work well at all with my DM3200. I had to purchase a new card and went through 2 different brands/chipsets in order to find one that worked perfect. Could be that too.
Last edited:
Has anybody tried using this product to solve the issue:
Kramer PT-1FW DV / Firewire Line Protector
Youre issue is a configuration problem. A FW line protector, to protect FW interfaces from "sparks" by plugging and unplugging won't cure the problem you are experiencing.

New threads

Members online

No members online now.