US-200 not working with macOS Sierra

Discussion in 'USB PC Audio Interfaces and Control Surfaces' started by clopezlga, Sep 26, 2016.

  1. Salva Romanelli

    Salva Romanelli New Member

    Joined:
    Apr 2017
    Messages:
    1
    Likes:
    0
    Hi,i followed all the process, but when i tried to rebuild kext cache i got this error!

    MacBook-Pro-de-Salva:Volumes salvaromanelli$ sudo kextcache -prelinked-kernel /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache -K /System/Library/Kernels/kernel /System/Library/Extensions

    Password:

    String/URL conversion failure.
  2. joshi

    joshi New Member

    Joined:
    May 2017
    Messages:
    1
    Likes:
    0
    Gear:
    1641
    Man, Nevirtus, you're a KING!!! thanks a lot. works perfect!
    (I have a tascam 1641)
    tell me your PayPal account please.
  3. musicadi

    musicadi New Member

    Joined:
    Jun 2017
    Messages:
    4
    Likes:
    0
    Gear:
    US-1641
    Hi,

    I just bought an US-1641 and was concerned that I'd have to sell it again, because it wasn't recognised in Sierra.

    I followed your instructions and it works perfectly! Thank you!

    Although, this last step gives me this error:

    Prelinked kernel directory '/System/Library/Caches/com.apple.kext.caches/Startup/' cannot be used

    When entering the command again, it starts rebuilding the cache and there is a set of errors>

    String/URL conversion failure.

    AppleDataSetManagement.kext - dependency for com.apple.iokit.IOAHCIBlockStorage lacks valid OSBundleCompatibleVersion.

    AppleDataSetManagement.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)

    AppleDataSetManagement.kext - dependency for com.apple.iokit.IOAHCIBlockStorage lacks valid OSBundleCompatibleVersion.

    KernelCache ID: (edited out)

    String/URL conversion failure.


    Nevertheless, the US-1641 is being recognised and works perfectly.

    I just don't understand why Tascam didn't make this small workaround for Sierra.

    Anyway, thanks a lot for your instructions on making it work!

  4. musicadi

    musicadi New Member

    Joined:
    Jun 2017
    Messages:
    4
    Likes:
    0
    Gear:
    US-1641
  5. fedele.brian94

    fedele.brian94 New Member

    Joined:
    Jul 2017
    Messages:
    1
    Likes:
    0
    Gear:
    us-200
    hi! I have a tascam us-200, I tried to follow the procedure but I can't have the permission (I'm talking about the first step) what can I do? thank you so much
  6. netvolve

    netvolve New Member

    Joined:
    Dec 2017
    Messages:
    1
    Likes:
    0
    Gear:
    TASCAM US-1641
    Any chance to get this working on High Sierra? I have a US-1641
  7. NateTheGreatx21x

    NateTheGreatx21x New Member

    Joined:
    Jan 2018
    Messages:
    1
    Likes:
    0
    Gear:
    tascam us-1641
    I also have the US-1641 on High Sierra, any fixes? I've tried Netvirtus instructions but after restarting my mac wont boot and i have to restore to a previous time machine
  8. batmanjack

    batmanjack New Member

    Joined:
    Jun 2018
    Messages:
    1
    Likes:
    0
    Gear:
    US-200
    Anyone got any news for High Sierra? I'm not really too hot on going through Nevirtus’ directions if there’s a danger of bricking my macOS installation.

    I have the US-200 and I'm extremely disappointed by the lack of support for this. When I bought this, it seemed to be the newly developed alternative to the older US-144mkII. Yet here we are, the aforementioned is still supported, while the US-200 is not.
  9. Ese EseGe

    Ese EseGe New Member

    Joined:
    Jan 2019
    Messages:
    2
    Likes:
    0
    Gear:
    Tascam DM-4800
    Hi! I'm having Fireware Issues with a Tascam DM-4800 (With a if-fw/dm mkII expansion card) and OS El Capitan 10.11.6(on a late 2009 i7 iMac). In fact, I would say that the issue is concretely with the expansion card, wich is not detected in its own app. The system says that there is a fireware port (It indicates max speed 800, and It doesnt show the red message saying that there is no device found). We have tested same setup on a Mac Laptop with same El Capitan version and it works fine (It is detected by the expansion card app and also works fine with Logic X) but there seems to be some kind of problem in this one wich we arent able to solve.

    Reading all around the internet we've seen al kind of issues and fixes wich didn't worked (restart-reset SMC, and related) and I got to this post but im not very experimented in solving OS/Apple related issues.

    How can I know what name do I have to replace in 'TASCAM_US1641' in order to do the same technique with my DM_4800 or with the if-fw/dm mkII?

    Thanks in advance, and any suggestion or need for extra information will be provided :).
  10. FranciscoIzuibejeres

    FranciscoIzuibejeres New Member

    Joined:
    Jan 2019
    Messages:
    1
    Likes:
    0
    Gear:
    TASCAM US-800
    Hello @Nervirtus and everybody here.

    My unit is a US-800 also discontinued, and i had make it work in mac OS 10.9.5 (Mavericks) instaling Asio4all driver or something like that, until yesterday, that i got updated to Sierra O

    I`ve never used the terminal before, so i´d ask you to check my "resumen" of the steps you recomended before, replacing the model of the unit:


    ABRIR TERMINAL:


    file /Library/Extensions/TASCAM_US800.kext/Contents/MacOS/TASCAM_US800



    REEMPLAZAR EL BINARIO i386 CON:

    sudo lipo -thin x86_64 -output ~/Desktop/TASCAM_US800 /Library/Extensions/TASCAM_US800.kext/Contents/MacOS/TASCAM_US800



    SE GENERA EL ARCHIVO LLAMADO TASCAM_US800 QUE SOLO DEBERÍA TENER EL BINARIO x86_64



    BORRAR EL ORIGINAL:

    sudo rm /Library/Extensions/TASCAM_US800.kext/Contents/MacOS/TASCAM_US800



    COPIAR EL NUEVO BINARIO:

    sudo cp ~/Desktop/TASCAM_US800 /Library/Extensions/TASCAM_US800.kext/Contents/MacOS/



    INTENTAR CARGAR EL NUEVO KEXT:

    sudo kextload /Library/Extensions/TASCAM_US800.kext



    ATENCIÓN: No debe haber errores en este punto. Puede utilizar kextstat como un control adicional aquí.


    AHORA RECONSTRUIR EL CACHÉ DE KEXT:

    sudo rm -rf /System/Library/Caches/com.apple.kext.caches

    sudo kextcache -prelinked-kernel /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache -K /System/Library/Kernels/kernel /System/Library/Extensions



    Reiniciar la Mac, eliminar ese archivo de su escritorio y asumiendo que todo salió bien, vuelva a usar su TASCAM US-800



    Muchas gracias por todo, espero que me des OK para llevar a cabo la tarea.
  11. Ese EseGe

    Ese EseGe New Member

    Joined:
    Jan 2019
    Messages:
    2
    Likes:
    0
    Gear:
    Tascam DM-4800
    Thanks! The whole system is being actually revised by another person but I'll pass him this link in case he finds it helpful. Lots of thanks for taking your time :)
  12. caronte23

    caronte23 New Member

    Joined:
    Mar 2019
    Messages:
    1
    Likes:
    0
    Please someone help me out, I have a US-1641, with or without following Nervirtus' guide I get the same issue, where outside of DAWs sometimes it works, sometimes I have to reset it, but in DAWs i get no playback at all, both core audio or bit accurate drivers. The weird thing is that when I first installed it on sierra with the el captain drivers it worked no problem, DAWs or not, then then next day I suddenly started having issues..
    I got this soundcard pretty cheap thinking I got a bargain, but I think I'll hato to return this...
  13. n8tron

    n8tron New Member

    Joined:
    Mar 2019
    Messages:
    1
    Likes:
    0
    Gear:
    US 1641
    Nevirtus, YOU ROCK! I am now able to use US 1641 on Mojave! I wasn't able to clear cache, but it worked anyway. Stoked!
  14. yum.yab

    yum.yab New Member

    Joined:
    Jul 2019
    Messages:
    4
    Likes:
    0
    I used the Nevirtus method many times and it worked perfectly but this last time I tried I ran into a problem. When I tried to load the kext with
    sudo kextload /Library/Extensions/TASCAM_US1641.kext

    I got the error
    /Library/Extensions/TASCAM_US200.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

    I solved this by disabling System Integrity Protection by booting into recovery mode and using the csrutil disable command in the terminal. Reboot, try to load the kext again and it should work.
    Dont forget to repeat the steps and this time enter csrutil enable to reenable your SIP.

    Many thanks again the Nevirtus for his method!
  15. Evan

    Evan New Member

    Joined:
    Dec 2019
    Messages:
    1
    Likes:
    0
    Gear:
    US-600
    I can confirm this works on High Sierra and using the US-600. I followed all steps and thought it did not work at the end. As a last ditch effort I unistalled all drivers again and re-installed and now boom...working. So happy thanks so much.

    [​IMG]