Using the FW-1884 in Windows 8


Well-Known Member
Oct 15, 2012
Gear owned
Nice to have this forum back.

For you early adopters who already have the release version of Windows 8, has anyone tried the FW-1884? From all I have read, Windows 8 runs even more efficiently than Windows 7, and the drivers from 7 are 'supposed' to work.

Given the challenge we faced getting Tascam to release the 64-bit driver for Windows 7, I'm hoping that drivers works in 8 also. Even if it doesn't seem to, I've read that some installers can be tricked simply by changing the text in the install script so Windows 8 would be recognized as a supported OS.
Worked on windows 8 64 bit using Studio One 32 and 64 for me. I went back to 7 though for a bit, but might set up another dual partition for Boots for testing. ran ok, about the same as 7.
Wow, that's great. So did the Windows 7 drivers install normally in Windows 8, or did you upgrade an existing Windows 7 computer?
I did and upgrade first, it worked, then I did a clean. worked also. You got me thinking to do it again,.
Yes I got the FW1884 going under Windows 8 Professional 64 bit - this was intially and upgrade from Win 7 pro 64 bit. The straight upgrade with all applications transferred didnt work so well - lots of BSODs - so in the end I did a fresh Windows 8 install which generally worked better.

One thing that bothers me a bit which someone may be able to throw light on is:
The FW1884 is a bit intermittent in the way it initally connects to the Windows 8 PC at bootup. Sometimes I get a fast flashing firewire green light on it. Wait a little switch it off - disconnect and reconnect firewire cable and switch on again - the problem seems to clear and I get a steady green firewire light and audio seems to be good.

I've tried trying to install the legacy driver from the drivers I kept back from windows 7 pro. Windows 8 seems reluctant to go for the legacy firewire driver (at least it does not say legacy) I suspect I may have to remove the existing driver and update again to make it look for the old legacy driver.

Otherwise does anyone have any suggestions for permanently getting rid of the winking firewire light at boot up so I dont have to keep disconnecting and reconnecfting cables + swicthing the FW powerswitch on and off to get a stable connection?

Simon Rodwell
This is what happend to me now that I think of it.. would lose connection all the time and had to turn off then on the tascam... In device manager check to see if windows is allowed to turn off device to save power...if it is.. dont let windows turn it off. maybe control alt delete and look for the tascam unit and set it as real time priority if it comes up. Im going to put windows 8 back up and see what I can find tonight..
Great. Let me know what you find out. Both your suggestions are good - the task manager looks better in Windows 8 Pro. I seem to remember when I got Windows 7 going with the FW I had similar problems and remembered trying to change the IRQ priority level on one of the firewire devices at one stage. I also remember not being sure which one of my two firewire devices was controlling the FW. One is VIA and the other LSI. I always thought the VIA was the host motherboard controller because my card is an old Adaptec TI one. So I focussed a lot of my attention on the LSI firewire controller as I thought that was the one controlling my card. The host port never works well with the TASCAM if it doesnt have a T1 chipset as most FW users know.

Still the overall good news is that the FW seems to work OK with Windows 8 64 Pro
when it finally connects. I reckon i am getting lower latency values with it - although I dont think the Adaptec card gives the best anyway to be honest even though it has the Texas T1 chipset.

Let me know what you discover and thanks
Bump to see if there has been any further progress on this?
YES. after many hours searching the web for a resolve i managed to get tascam fw 1884 working as it should under windows 8.this is how i did it on a 64bit win 8 system.
firstly run cmd as administrator then type the following and enter/ exit
bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
then follow these instructions from
then install fw1884 exe by right click and choose properties/compatibility/then run the trouble shooter/troubleshoot program/tick worked in previous/tick win 7/run and load successfull.
if youve followed this then it should mean you now have fw1884 working correctly without having to disable signature on every boot.
Hi, ... could the problem be solved by purchasing a new firewire card?
I'm under the impression that no FireWire is supported under win8.
Microsoft have binned that tech.
Wow, thank you so much for the post! I was able to install the firewire card fine, but for the life of me I could not install the drivers for the 1884 on Windows 8. This worked flawlessly. Thank you again, I can't tell you how much I appreciate it!
I'm glad it helped someone who was suffering the same nonsense.
yes i use v1.8.0 drivers on win8-64 pro. i have found i need to boot computer first then fw1884+fe8+fe8 to get it to load/startup correctly. for shutdown turn off pc first then power down tascam gear. runs great with cubase 7 - 64
finally got 1884 installed to windows 8

It seems to be working Soft LCD shows but I can not find the 1884 control panel. Am I missing something? How do I get the Control panel in Win 8?
Last edited by a moderator:
I don't know about Windows 8, but perhaps if you know the name of the program that should be running to give you the Control Panel, it will help you to find and run it. It is named this:

Oh sorry forgot to post that I found it. It runs so much smoother inWindows 8 than it did in XP! SO far....
Could you post the step-by-step instructions to install the FW-1884 into Windows 8?

If you already did that, is there a link?


New threads

Members online

No members online now.